Jump to content
MrHK

Tổng hợp các lỗi trên Prestashop ver 1.4.1.0

Recommended Posts

Các bạn thông báo lỗi xảy ra trong quá trình sử dụng và việt hóa Prestashop ver 1.4.1.0 tại đây để bên CC fix trong thời gian sớm nhất nhé.
Sau đây là một số lỗi mình gặp trong quá trình sử dụng phiên bản 1.4.1.0:
- Không cập nhật logo quốc gia trong phần Tools/Languages được.
- Nếu trong quá trình cài đặt Prestashop, các bạn upload logo, banner, icon, ... thì sau này khi quản lý, các bạn sẽ không thể upload lên lại được và bị lỗi đen. Hiện tại chỉ có cách giữ nguyên tình trạng lúc cài đặt, không nên sửa đổi bất cứ gì tránh tình trạng lỗi sau này.

Share this post


Link to post
Share on other sites

Bổ sung:
- Không thể cài đặt thêm file ngôn ngữ từ PC

Share this post


Link to post
Share on other sites

Không hiểu sao ở Prestashop phiên ban 1.4.1.0 này thì lúc đặt hàng vào giỏ hàng thì không vào giỏ riêng của từng khách hàng mà lại vào giỏ hàng chung của khách?
Và lúc đặt hàng thì thanh toán như thế nào? Nó cứ báo không có nhà cung cấp ở khu vực này.

Share this post


Link to post
Share on other sites

Prestashop 1.4 này không thể tìm thấy chỗ nào để việt hóa các tab (thẻ) trên menu trong mục Quản Trị. Đã thử tìm các file bên ngoài nhưng vẫn ko thấy,

-----------------------
Đã thấy. OK

Share this post


Link to post
Share on other sites

Prestashop 1.4.1.0 bị lỗi "There are no carriers available that deliver to this address." mặc dù đã add thêm nhiều Nhà cung cấp nhưng vẫn không hiểu tại sao lại không vận chuyển được. Ai biết xin chỉ giùm

Share this post


Link to post
Share on other sites

Vừa phát hiện thêm 1 lỗi trầm trọng của Prestashop ver 1.4.1.0 đó là:
- Import DB từ localhost lên hostsv không được. Up lên xong, sau khi config toàn bộ dữ liệu thì link trên hostsv không nhận được, chỉ ra 1 màn hình trắng phau.
Mình đã tìm được cách khắc phục nhưng chỉ vào được trang quản lý: sau khi import và config tất cả thì vào PhpMyAdmin trên hostsv chỉnh lại cái ps_configuration, tìm đến 2 trường Host name và Host name SSL chỉnh lại đường dẫn là link trên host, lưu ý không có "http://"
Còn về trang Front Office tại sao không hiển thị theme thì mình nghĩ là do host tự set bậy permisson, hiện đang test tiếp.
Ai có ý kiến gì thì cùng chia sẻ hướng giải quyết nhé.

Share this post


Link to post
Share on other sites

Đã tìm được hướng khắc phục.
Các bạn lưu ý là Prestashop sau khi đưa lên hostSV thì nên vào file ps_configuration chỉnh lại tất cả các link điều hướng về localhost khi test ở localhost vì sau khi up lên hostSV, cho dù có 1 link về localhost cũng gây nên lỗi không hiển thị themes.
Đặc biệt là các module có liên quan đến configuration.

Share this post


Link to post
Share on other sites

Mình cũng đã thử upload lên host và cũng vào bảng ps_configuration sửa link localhost thành link host. Nhưng khi chạy lên thì trang của mình bị mất phần footer và phần right.
Có bạn nào biết tại sao thì chỉ hộ mình với!
thanks!

Share this post


Link to post
Share on other sites

nhiều lỗi vậy . Mình cũng đã sử dụng 1 thời gian như sau không thích lại quay về với bản 1.3.7 dùng cho quen.

Share this post


Link to post
Share on other sites

Ở trong ps_configuration chỉ sửa 2 link host thôi, các phần còn lại mà sửa cẩn thận trang bị lỗi. Mình gặp 1 tình trạng tương tự sau khi up lên và sửa lại link thì nó ko hiển thị trang bình thường được mà hiển thị loạn cả lên.

Share this post


Link to post
Share on other sites
Các bạn thông báo lỗi xảy ra trong quá trình sử dụng và việt hóa Prestashop ver 1.4.1.0 tại đây để bên CC fix trong thời gian sớm nhất nhé.
Sau đây là một số lỗi mình gặp trong quá trình sử dụng phiên bản 1.4.1.0:
- Không cập nhật logo quốc gia trong phần Tools/Languages được.
- Nếu trong quá trình cài đặt Prestashop, các bạn upload logo, banner, icon, ... thì sau này khi quản lý, các bạn sẽ không thể upload lên lại được và bị lỗi đen. Hiện tại chỉ có cách giữ nguyên tình trạng lúc cài đặt, không nên sửa đổi bất cứ gì tránh tình trạng lỗi sau này.

Thanks! Thêm kinh nghiệm để không mắc phải

Share this post


Link to post
Share on other sites

Mình bị lỗi với module Featured Products on the homepage v0.9 . khi để mặc định show 10 sản phẩm thì không sao. Khi chỉnh tăng lên 15 sản phẩm thì bị lỗi là từ sản phẩm thứ 11 trở đi hình ảnh bị lặp lại của 1 sản phẩm ở trên. giống như trong hình mình có đính kèm. Bạn nào biết giúp mình với. Cảm ơn nhiều

post-200633-0-25710500-1316055079_thumb.jpg

Share this post


Link to post
Share on other sites

Mình có lỗi thế này chưa tìm ra,mong được giải quyết sớm:

 

Mình chạy module blockadvertising,nhưng khi chạy xong,kiểm tra lại code html bằng firebug thì cái code html của module blockadvertising không nằm div có id là right_column mà trong trang footer mình để $HOOK_RIGHT_COLUMN như sau:

<div id="right_column" class="column">

{$HOOK_RIGHT_COLUMN}

</div>

Giờ mình làm sao để code hiện thị module nằm trong div có class advertising nằm trong div có id right_column và class column.,,ai biết chỉ giúp mình nhé.version mình dang dùng là 1.4.4.1.Thanks

Share this post


Link to post
Share on other sites

Bạn cần CHMOD thư mục /img quyền 755 hoặc 777. Với logo PNG khi upload lên sẽ được convert sang định dạng JPG do đó màu nền sẽ chuyển sang màu đen.

 

Bộ language pack tiếng Việt mình đã bổ sung các file còn thiếu. Việt hóa tương đối đầy đủ tuy nhiên phần dịch sử dụng Google translate nên về chưa sát nghĩa.

Các bạn có thể download theo link sau http://www.fshare.vn/file/X611JIRPJV/

Share this post


Link to post
Share on other sites

Prestashop 1.4 này không thể tìm thấy chỗ nào để việt hóa các tab (thẻ) trên menu trong mục Quản Trị. Đã thử tìm các file bên ngoài nhưng vẫn ko thấy,

-----------------------

Đã thấy. OK

Vậy bạn có thể chia sẻ cách làm của bạn với mọi người được không ?

Share this post


Link to post
Share on other sites

Ở trong ps_configuration chỉ sửa 2 link host thôi, các phần còn lại mà sửa cẩn thận trang bị lỗi. Mình gặp 1 tình trạng tương tự sau khi up lên và sửa lại link thì nó ko hiển thị trang bình thường được mà hiển thị loạn cả lên.

Bạn lưu ý khi chỉnh sửa đường dẫn source code. Khi chỉnh sai thì browser sẽ không load được file css

Share this post


Link to post
Share on other sites

Chào các bạn,

 

Mình đang cài PS bản 1.4.4.1 - Không thể việt hóa được các module, hiện mình cài trên localhost nên ko thể demo, kiểu web: 3 cột, left/ body/ right, các module bên trái và phải chỉ việt hóa được vài cái thôi.

 

Vào trong Tools -> translate -> chọn mục Module -> chọn cờ Việt Nam (thì trang trắng luôn)

{dĩ nhiên là font / back - dịch bằng goole translate bình thường }

 

Mong trợ giúp - thanks

Share this post


Link to post
Share on other sites

đã khắc phụ lỗi trắng trang rồi - nói chung là chưa ai gặp như mình nên không ai trả lời bài viết cả (do test trên host free nên sever không cấp quyền truy xuất)

Share this post


Link to post
Share on other sites

Mình bị lỗi với module Featured Products on the homepage v0.9 . khi để mặc định show 10 sản phẩm thì không sao. Khi chỉnh tăng lên 15 sản phẩm thì bị lỗi là từ sản phẩm thứ 11 trở đi hình ảnh bị lặp lại của 1 sản phẩm ở trên. giống như trong hình mình có đính kèm. Bạn nào biết giúp mình với. Cảm ơn nhiều

 

Cái này mình biết lỗi do đâu rồi. Nó xung đột với module zoom hình của bạn đó. :D gỡ đi là xong

Share this post


Link to post
Share on other sites

Các bạn cho hỏi ,

 

+ Trước mình dùng bản 1.3.x trở về trước thì khi mình tùy biến các module bằng các đoạn htm thì ok , nhưng từ khi dùng bản 1.4.7 thì mình tùy biến trong các module bằng các đoạn html thì nó không có tác dụng .

 

Mọi người ai có hướng khắc phục thì xin trợ giúp mình với . Thanks

Share this post


Link to post
Share on other sites

Các bạn cho hỏi ,

 

+ Trước mình dùng bản 1.3.x trở về trước thì khi mình tùy biến các module bằng các đoạn htm thì ok , nhưng từ khi dùng bản 1.4.7 thì mình tùy biến trong các module bằng các đoạn html thì nó không có tác dụng .

 

Mọi người ai có hướng khắc phục thì xin trợ giúp mình với . Thanks

 

Bạn vào Trang quản trị > Preferences > Performance

bật smarty compile Yes

và tắt Cache No đi là được.

Share this post


Link to post
Share on other sites

nói thật là mã nguồn nào cũng lắm lỗi lắm cơ ! mình làm thằng mua sắm vui bằng mấy mã nguồn rồi ! chán !

Share this post


Link to post
Share on other sites

http://officetool.com.vn

Trong phan code tui da thay doi Power by... rôì nhưng vào lại trang chủ thì vân thây y nhu cũ . module hô trơ trực tuyên tui cũng thay đôỉ trong code nhưng vânx ko đươc. đem cái mô đule đó sang cài ơ môt trang pres mơí tinh chưa từng cài module đó thì lại hiên thay đôỉ bình thương.

Điên đâù. ko biêts tại sao

Share this post


Link to post
Share on other sites

Các bạn cho hỏi ,

 

+ Trước mình dùng bản 1.3.x trở về trước thì khi mình tùy biến các module bằng các đoạn htm thì ok , nhưng từ khi dùng bản 1.4.7 thì mình tùy biến trong các module bằng các đoạn html thì nó không có tác dụng .

 

Mọi người ai có hướng khắc phục thì xin trợ giúp mình với . Thanks

Bạn mở thư mục /themes/module/ tìm file template *.tpl tương ứng để sửa nhé

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More