Jump to content

Problème connection : API PrestaShop et PostMan


Futamiya
 Share

Recommended Posts

Bonjour,

Cela va faire 72 h que j'essaie de connecter PrestaShop avec une plateforme web, via API.

L'idée serait de connecter les données des stocks des produits, qui sont vendus sur la plateforme prestashop, à un outil appelé mecalux (plateforme de gestion des stocks).

Je me tourne vers vous, car à chaque fois que j'essaie de mettre en place une synchronisation automatique dans la configuration de l'autre plateforme, j'ai un message d'erreur 401. L'authentification manuelle marche.

J'ai donc décidé de me tourner vers PostMan pour régler cette erreur. L'objectif serait de permettre une authentification avec Postman après s'être déconnecté de l'autre plateforme (gestion des stocks).

Problème : il n'y a aucunes documentations concernant la synchronisation entre deux plateformes.

Je suis totalement perdue.

ps L'authentification sur Prestashop est : BASIC

Je demande votre aide

Cordialement

Futamiya

Share this post


Link to post
Share on other sites

Merci

Pouvez-vous m'apporter plus de précision s'il vous plait ?

Je suis débutante en développement, et c'est la première fois que je suis confrontée à ce genre de situation.

Vous voulez dire que dans mon url je dois l'appeler comme ça :

https://domaine/api?ws_key=ma-clé

plutôt que

https://ma-clé@mon-domaine/api 

?????

Share this post


Link to post
Share on other sites

La synchronisation se fait sur la plateforme de gestion des stocks.

De ce fait, ils ont leur propre configuration :

image.png.95d7db470fa5b6a22ddb478aa60d63bf.png

Par exemple, ici :

1/ URL webservice

2/ clé 1

De ce fait, lorsque j'implante le format que vous proposez, il ne répond plus le message 401, mais il répond un message disant qu'il ne reconnait pas le langage évoqué.

....

Je suis coincée ^^'

Share this post


Link to post
Share on other sites

Le problème est lié à votre hébergement qui ne transmet pas l'authentification (fcgid) j'imagine qu'en mettant:

votre-boutique.com/api?ws_key=xxxxx et xxxxx dans le champs 2, le bug de votre hébergement qui ne transmet pas l'authentication devrait faire que ça fonctionne

Share this post


Link to post
Share on other sites

En effet, dans la configuration de mon webservice, j'ai fait ceci :

image.png.b514374ad5de679bf9acba225692cdc4.png

Car la configuration de mon PHP est Apache.

Je ne peux pas toucher à la configuration du PHP, car cela impacterait l'ensemble du serveur de tous mes sites web.

 

En suivant vos conseils, j'obtiens ce message d'erreur :

...err:Authorizations error : API can't access LANGUAGES in Prestashop

En effet, automatiquement la plateforme de gestion des stocks créer ceci comme path :

http//ma-clé@mon-domaine/api?ws_key=ma-clé

Donc automatiquement, il implante ma clé avant mon @domain donc bon....

Je ne sais pas comment faire...

Share this post


Link to post
Share on other sites

La configuration fcgid d'apache qui n'affecte en rien les autres sites c'est:

<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
</IfModule>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More