Jump to content

SOLVED: disabled a module: now locked out of backoffice: HTTP ERROR 500


Recommended Posts

Posted (edited)

New user, installed 1.7.7.4 on Strato provider.

Due to a very slow backend I disabled some modules. That worked well, but it seems that I disabled the wrong modules as I am now locked out of the backoffice. Front end works well. 

if I try the normal login /adminXXXYY = HTTP error 500.
If I try /admin > Page not found, in a prestashop environment.

Modules that I disabled were statistical backend modules, such as products used, browers info etc. When changing to another backoffice page the dreaded HTTP500 error came. 

Help very much appreciated. My business is just reopening due to Covid.
Had this issue before, reinstalled site but would rather prefer not to do that again.

Can I install the modules in another way?
Have FTP access + PHP Myadmin. 

Edited by AquaPlanning
solved! + typo (see edit history)

Share this post


Link to post
Share on other sites

First try to put your shop in debug.

If you can't acces you dashboard you can enable it through FTP by accessing config/defines.inc.php and usually @line  29 you will find :

define('_PS_MODE_DEV_', false);

change it to:

define('_PS_MODE_DEV_', true);

It will give you a report when trying to reach your backend. Maybe someone can help you with that.

Then second: I have not very good experiences with shops on Strato. Its a good system for hobby websites, but if you want to do a serious job please take a specialized hosting. There are several options for that. As i see youre from the netherlands you could contact www.wallgrind.nl Its also for startups a good company.

Share this post


Link to post
Share on other sites

Thanks!

Debug mode true: I can access the backend!
Debug mode false: I can't.

Site looks completely normal in debug mode. 
 

I just moved to Strato... First need to get my business back up and running after last years misery. 

Share this post


Link to post
Share on other sites

With debug true > everything OK. No errors on the bottom.
With debug false > HTTP error 500. 

One of the modules that I disinstalled / deactivated must be causing this. 
The administration modules I disinstalled did not appear critical: Best supplier, Best vouchers, Browsers and operating systems etc. Unfortunately I did not note which ones I disabled. 


 

Share this post


Link to post
Share on other sites

  • AquaPlanning changed the title to SOLVED: disabled a module: now locked out of backoffice: HTTP ERROR 500

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More