Jump to content

Recommended Posts

Καλησπέρα σας.

Έχω ένα eshop με την 1.7.7.0 - έκδοση PHP 7.4.13 - και αντιμετωπίζω πολλαπλά προβλήματα με το backoffice.

Αρχικά όταν κάνω login και συνδέομαι το backoffice είναι μονίμως σε φόρτωση και δεν με αφήνει να πατήσω σε κανένα κουμπί.

  • Δεν μπορώ να επεξεργαστώ προϊόντα και όταν πατάω "preview" αντί να με στείλει στο e-shop μου ανοίγει νέα καρτέλα με την αγγελία στο backoffice.
  • Σήμερα προσπάθησα να κάνω update στην 1.7.7.1, πατάω το κουμπί "upgrade prestashop now!" και δεν κάνει τίποτα.
  • Στις τιμές έχει εξαφανιστεί το ποσό πώλησης με ΦΠΑ.

Γενικότερα οι περισσότερες επιλογές από το backoffice δεν λειτουργούν και τα κουμπιά ενώ μπορώ να τα πατήσω δεν εκτελούν την εντολή. Το πρόβλημα εμφανίστηκε μόλις αναβάθμισα από 1.7.6.9 στην 1.7.7.0.

 

Από την άλλη το e-shop στέλνει παραγγελίες κανονικά χωρίς πρόβλημα.

Επισυνάπτω ένα βίντεο και δύο φωτογραφίες από τις παραμέτρους για να καταλάβετε περίπου τι πρόβλημα υπάρχει.

Υπάρχει καμιά ιδέα για το τι μπορεί να φταίει; 

 

Ευχαριστώ εκ των προτέρων

screen-capture.mov

φώτο 1.png

φώτο 2.png

φώτο 3.png

φώτο 4.png

Edited by mstav (see edit history)

Share this post


Link to post
Share on other sites

Ότι έχει να κάνει με memory limit αφορά ρυθμίσεις της php. Όμως ενεργοποίησε το debug να δεις τι σου εμφανίζει και πόσταρέ το και εδώ.

Share this post


Link to post
Share on other sites
35 minutes ago, Prestan0ob said:

Ότι έχει να κάνει με memory limit αφορά ρυθμίσεις της php. Όμως ενεργοποίησε το debug να δεις τι σου εμφανίζει και πόσταρέ το και εδώ.

Μου βγάζει το παρακάτω μήνυμα πολλές φορές στη σειρά.

Deprecated: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /var/www/vhosts/21299300521.v-phost.com/eshop.maxairasautoparts.gr/src/Adapter/EntityMapper.php on line 99
 

Ανεβάζω και κάποια screenshot.

φώτο 5.png

φωτο 6.png

φώτο 7.png

φώτο 8.png

Share this post


Link to post
Share on other sites

Κατέβασε την PHP απο 7.4 σε 7.3 και είσαι οκ. Σε 7.3 δεν θα έχεις πρόβλημα. Σε περίπτωση που έχεις κατεβάζεις σε 7.2.

527833407_.png.206714f43ffacd078d10bb9c0498b4c7.png

Share this post


Link to post
Share on other sites

Δοκίμασα με php 7.3 και 7.2 και δυστυχώς κάνει ακόμα τα ίδια.

 

Τώρα το άφησα στην 7.2.34

Edited by mstav (see edit history)

Share this post


Link to post
Share on other sites

Δυστυχώς το πρόβλημα παραμένει.

 

Εάν κάνω αναβάθμιση στην 1.7.7.1 χειροκίνητα (από το backoffice δεν με αφήνει) υπάρχει περίπτωση να διορθωθεί το πρόβλημα ;

Share this post


Link to post
Share on other sites

όχι δεν νομίζω. Απενεργοποίησε και ενεργοποίησε το subscription ή κάνε με κάποιο άλλο τρόπο που μπορείς restart μήπως δεν έχει πάρει την αλλαγή της PHP.

Τέλος εαν δεν γίνει κάτι πάρε ένα backup και κάνε χειροκίνητη αναβάθμιση μήπως γίνει επικάλυψη κάποιων αρχείων που ίσως έχουν πρόβλημα και δουλέψει.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
On 1/15/2021 at 3:12 PM, Prestan0ob said:

όχι δεν νομίζω. Απενεργοποίησε και ενεργοποίησε το subscription ή κάνε με κάποιο άλλο τρόπο που μπορείς restart μήπως δεν έχει πάρει την αλλαγή της PHP.

Τέλος εαν δεν γίνει κάτι πάρε ένα backup και κάνε χειροκίνητη αναβάθμιση μήπως γίνει επικάλυψη κάποιων αρχείων που ίσως έχουν πρόβλημα και δουλέψει.

Καλησπέρα. Μετά από τόσες μέρες προσπαθειών και δοκιμών δεν βρήκαμε καμία λύση.

Η χειροκίνητη αναβάθμιση έγινε αλλά και πάλι δεν δούλεψε.

Τελευταία επιλογή είναι να το ξαναστήσουμε από την αρχή γιατί σε μία δοκιμή που έγινε σε test domain δούλεψε κανονικά οπότε προς τα εκεί καταλήγουμε.

 

Σε ευχαριστώ πολύ πάντως για την βοήθεια σου.

 

EDIT: Τελικά βρέθηκε το πρόβλημα και είναι στο theme που έχω αγοράσει. Είναι ένα συγκεκριμένο module το οποίο όταν το διαγράφεις δουλεύει ξανά το backoffice αλλά δημιουργεί bug στο front end. Έχω στείλει μήνυμα στον developer του θέματος γιατί έχω αγοράσει 12μηνη στήριξη αλλά σε περίπτωση που δεν μου το φτιάξει μπορώ να ζητήσω τα χρήματα πίσω;

Edited by mstav (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More