Jump to content

Problème d'affichage déclinaison selon stock disponible


JuOs
 Share

Recommended Posts

Bonjour, 

Je cherche à :

- automatiser le fait de mettre les déclinaisons encore disponibles par défaut. Aujourd'hui, je dois choisir manuellement la déclinaison par défaut, mais à partir du moment où elle n'est plus disponible, je souhaiterai qu'automatiquement une déclinaison toujours disponible prennent le relai. 

- sur les pages catégories, lorsque le client filtre par taille, je souhaiterai que : les produits avec la déclinaison taille sélectionnée et qui ont une quantité 0 ne s'affichent pas sur les pages catégories. Mais ok pour les afficher sur la fiche produit car sinon lors d'un réassort, je serai obligé de recréer les déclinaisons avec codes EAN etc... donc sans pour autant supprimer manuellement chaque autre déclinaison qui ont une quantité 0 

Je suis sous prestashop 1.7.6.5 et le thème warehouse

Merci pour votre aide  !

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Bonjour @Eolia

J'ai acheté et installé votre module qui a effectivement réglé mon problème d'automatiser le fait de mettre les déclinaisons encore disponibles par défaut. 

Par contre, sur mes pages catégories, mon problème est toujours présent : lorsque le client filtre par taille, les produits avec quantité 0 avec sur cette taille apparaissent toujours sur mes pages catégorie. Par contre, en cliquant sur la fiche produit concernée, la taille n'est effectivement plus proposée grâce au module installé.

Voici ma configuration Fiche produit : 

image.png.725499344ea5453c78fed00dc6335ebc.png

 

Merci

 

Share this post


Link to post
Share on other sites

Ok pigé, j'ai dit une bêtise, les attributs ne sont pas affectés par la visibilité, ça ne concerne que les produits eux-mêmes.

Le module de navigation à facette n'a jamais filtré sur les quantités dispos, il faudrait se hooker sur actionProductListModifier pour virer les déclis vides de l'affichage.

Share this post


Link to post
Share on other sites

Après avoir laissé de côté quelques jours ce problème... 

En me repenchant dessus, j'ai uniquement cliqué sur "Créez des attributs et indexez vos caractéristiques" dans le module de navigation à facettes

Le problème est réglé et tout fonctionne. Alors je ne sais pas si ça s'est débloqué tout seul entre temps ou si c'est cette petite manip qui a réglé le soucis. Mais tout est ok pour moi 

En tout cas, merci @Eolia pour votre réactivité à chaque fois !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More