Jump to content
  • 0

Wartungsmodus funktioniert nicht


knut4shop

Question

Hallo Gemeinde,

hat zufällig von euch auch jemand das Problem, dass der Wartungsmodus nicht funktioniert? Bei mir äußert sich das wie folgt:

Wartungsmodus aktivieren, Wartungs-IP leer lassen (mit Absicht), speichern, cache löschen.

Beim Besuch des Shops erhalte meine Wartungsmeldung, beim direkten aktualisieren kann ich den Shop trotzdem betreten und Käufe tätigen. Im Backendbereich "Wartung"  wird dann die IP-Adresse des Besuchers in die Whitelist eingetragen (PS_MAINTENANCE_IP).

Ich habe dazu auch schon einige Postings im Netz gelesen, allerdings zur Version 1.6. Den Lösungsvorschlag in der Tools.php den return $_SERVER['REMOTE_ADDR']; in return $_SERVER['HTTP_X_REAL_IP']; zu ändern löst das Problem erstmal nicht. 

 

Shop-Version: 1.7.6.9

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
6 hours ago, knut4shop said:

Beim Besuch des Shops erhalte meine Wartungsmeldung, beim direkten aktualisieren kann ich den Shop trotzdem betreten und Käufe tätigen. Im Backendbereich "Wartung"  wird dann die IP-Adresse des Besuchers in die Whitelist eingetragen (PS_MAINTENANCE_IP).

Das klingt in der Tat sehr seltsam. Ich kann nur vermuten dass hier ein Modul oder Override aktiv ist. Zur Not mal alle Shop Dateien nach PS_MAINTENANCE_IP durchsuchen, die einzige Stelle wo dieser Parameter gesetzt wird sollte MaintenanceConfiguration.php im src Verzeichnis sein.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More