Jump to content

Restauration d'un site à partir d'une sauvegarde complète (en local)


Recommended Posts

Bonjour,

Dans le cadre de mon stage universitaire je dois effectuer plusieurs modifications sur le site web d'une entreprise. Je fais mes premiers pas sur Prestashop que je maîtrise encore mal. Ça fait une semaine que je cherche à faire une copie du site sur ma machine personnelle pour travailler en local. Ma machine est sous Windows 10 et j'utilise wampserver64.

C'est sans problème que j'ai suivi un tuto pour installer la version 1.7.5 de Prestashop sur ma machine en local. Après ça j'ai commencé à récupérer les différentes sauvegardes (sauvegarde des fichiers et sauvegarde de la BDD). J'ai commencé par celle de la BDD. Pour cela je me suis connecté sur la back-office du site en ligne et j'ai utilisé la fonction native à Prestashop pour faire une sauvegarde de la BDD. Pour la sauvegarde des fichiers j'ai utilisé FileZilla pour me connecter au serveur et télécharger le bon dossier. J'ai eu quelques difficultés sur cette étape. Six dossiers situés dans la racine du site n'ont pas été téléchargé la première fois, j'ai dû faire un deuxième téléchargement pour les récupérer. Et comme je n'avais pas les droits d'accès le fichier nommé htaccess.save situé aussi dans la racine, n'a pas pu être téléchargé.

J'ai ensuite placé le dossier du site dans mon répertoire wamp64/www/ et j'ai nettoyé ma BDD avec phpMyAdmin avant d'importer la bonne BDD. Quand je veux me connecter au back-office en local j'ai évidemment eu une erreur 500 qui me dit (en mode dé-bug) que j'ai un problème pour me connecter à la base de données. J'ai alors récupérer dans ma corbeille les paramètres du fichier suivant root/app/config/parameters.php (issus de mon installation de Prestashop). Et avec ça je n'ai plus d'erreur 500 je n'ai plus qu'une page blanche sans autre information.

Voilà où j'en suis. Si quelqu'un à une idée pour m'aider à finaliser mon installation en local je suis preneur. Je suis prêt à tout recommencer à partir de zéro aussi, si on me dit que ce que j'ai fait jusque-là ne va pas du tout. Merci à toute l'aide que vous pourriez m'apporter.

 

Share this post


Link to post
Share on other sites

J'ai sensiblement le meme problème que j'ai détaillé dans ce nouveau post  - j'ai portant aussi suivi a la lettre le post d'Eolia. Mais j'ai tes ces erreurs de connexion a la db...

 

Share this post


Link to post
Share on other sites
Il y a 3 heures, AdminLollipop a dit :

J'ai sensiblement le meme problème que j'ai détaillé dans ce nouveau post  

Bonjour

Je suis allé sur le nouveau post.avez-vous suivi les recommandations de Mediacom87 ? Pour corriger votre version de PHP.

Et vous n'avez pas répondu à la question que Eolia vous à poser..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More