Jump to content

Recommended Posts

Bonsoir,

j'ai un site web depuis plusieurs année fait en front page, j'ai aussi installé opencart 1.5 avec sa base de donné fonctionnelle mais que je n'ai pas uttilisé (longue histoire)

avec la covid -19 je reprend le collier mais avec prestachop 1.6.124 ( mon spacer.pnghébergeur a php5.2). après avoir crée une deuxieme base de donné ( pour prestashop ) je commence l'installation:

Choix de la langue:  français ok ,

Acceptation des licences ok,

Compatibilité système: le système passe tout droit, quand j'y reviens dans une autre fenêtre il me marque ok "La compatibilité de PrestaShop avec votre système a été vérifiée"

et indique "Vous utilisez la version 5.2.4 de PHP. PrestaShop ne supportera bientôt plus les versions PHP antérieures à 5.4. Pour anticiper ce changement, nous vous recommandons d'effectuer une mise à jour vers PHP 5.4 dès maintenant !"

Informations: ok

Configuration du système:  la fonction tester la base de donnée ne fonction pas. je dois cliquer sur suivent a chaque fois et c'est la que le "fun" commence ,quand je fait volontairement une erreure il me dit qu'il y a une erreur, mais quand tout semble bon, il affiche la page suivante (vois photo ) mais il n'y a pas de barre de progression et puis plus rien même après 30 minutes d'attente rien,   comme Adresse du serveur de la base j'ai utiliser "localhost" non, et puis " http:// l'adresse de la base de donnée" non plus ,  pour le Nom de la base et l'Identifiant de la base deux nom différant non, et puis deux nom identique non plus, j’ai effacé et ré-crée la base de donne une bonne douzaine de fois non, toujours cette page blanche, mes connaissance étant limiter j'ai besoin d'aide, Merci Luc

 

 

Share this post


Link to post
Share on other sites

Désolé pour la photo en plein centre, vous auriez du lire :

avec la covid -19 je reprend le collier mais avec prestachop 1.6.124 ( mon hébergeur a php5.2).

après avoir crée une deuxieme base de donné ( pour prestashop ) je commence l'installation:

Merci Luc

Share this post


Link to post
Share on other sites

PHP5.6 ou 7.0 pour prestashop 1.6.1.24

Share this post


Link to post
Share on other sites

Bonjour doekia,

Merci Pour ta réponse,

tu doit bien te douter que ce n'est pas la réponse que j'attendais,  j'espérai plus " , "  " / " ou " : "  a la mauvaise place et hop, voila l'installation est complété

sa ma pris deux semaine d’effort avant de d'écrire sur ce Forum, juste pour être sur que j'avais fait mes devoir avant de demander de l'aide, j'ai installer a plusieurs reprise (+20) 1.6.1.24 et refait la base de donnée (+12) croyant que j’avais fait une erreur quelque part, j'ai lu, re-lu et re-re-lu toute la documentation officiel de Prestashop et partout le minimum indiqué est php5.2, Même durant l'installation prestashop me dit lui même que j'ai php 5.2 et que c'est compatible, mais a la fin l'installation ne fonctionne pas

et la, tu me dit que c'est php 5.6 minimum , et je ne met pas tes compétences en doute loin de la

alors il me semble que prestashop devrais avoir la décence d’écrire une petite ligne de commende dans le programme d’installation de 1.6.1.24 disant " vous utilisez php5.2 et vous n'êtes pas compatible vous devez utilise php 5.6 ". sans oublier la documentation officiel juste changer 5.2 pour 5.6

quand ont est un ti-nouveaux comme moi ou d'autre, avez vous idée du trouble que c'est de essayer d’installer un programme qui de toute façon ne fonctionneras pas

 

encore une fois merci doekia pour la réponse a mon problème

 

maintenant considérant que j'ai php5.2 quel est la version la plus récente de prestashop je peux installer ?

Merci Luc

Share this post


Link to post
Share on other sites

Bonsoir

Quel est l'hébergeur ? En général, il est possible de modifier la version de PHP. Rester en PHP 5.2 c'est aller au-devant de difficultés.

Vous dites :

Citation

 comme Adresse du serveur de la base j'ai utiliser "localhost" non, et puis " http:// l'adresse de la base de donnée" non plus ,  pour le Nom de la base et l'Identifiant de la base deux nom différant non, et puis deux nom identique non plus,

Ce n'est pas très compréhensible. Pour accéder à la base de données créée, vous avez sans doute un lien vous permettant d'afficher le nom du serveur sur l'espace où vous l'avez créé, l'utilisateur, et le nom de la base.

Si vous ne vous rappelez pas du mot de passe, il suffit d'en recréer un.

En créant la base de données, avez-vous bien donné tous les droits à l'utilisateur ?

Quand vous dites que la fonction de test de connexion à la base de données ne fonctionne pas, vous voulez dire quoi ? Qu'il vous dit qu'il ne peut pas se connecter ? Si oui, c'est que vous ne rentrez pas les bons paramètres

Share this post


Link to post
Share on other sites

Bonsoir Kerlin,

Merci de répondre,

pour l'hébergeur le maximum c'est php5.2 je ne peux pas l'augmenter, a plus long terme je vais devoir le quitter

2 hours ago, kerlin said:

Quand vous dites que la fonction de test de connexion à la base de données ne fonctionne pas, vous voulez dire quoi ? Qu'il vous dit qu'il ne peut pas se connecter ? Si oui, c'est que vous ne rentrez pas les bons paramètres

c'est simple je clique et il ne ce produit rien, pas de confirmation de connections ou de non connections a la base de donnée

même quand je garde les paramètres par défaut je clique et en principe il devrais recharger la page et me dire qu 'il ne peux pas ce connecter et non, rien ne se passe c'est comme si je cliquais dans le vide, la page ne bouge pas, la fonction ne marche pas. je dois alors cliquer sur le bouton " suivant " et la la page se recharge, et avec les paramètres par défaut  j'ai un message " impossible de se connecter " ( c'est normal c'est pas les bon paramètres) mais quand je met les bon paramètres la page se recharge et je tombe sur la page blanche que j'ai mis en photo plus haut

pour la base de donnée j'ai trouvé un petit fichier en php pour la tester et il se connecte

<?php
$link = mysql_connect("adresse base", "identifiant de la base", "mot de passe"), 
    or die("Impossible de se connecter : " . mysql_error());
echo 'Connexion réussie';
mysql_close($link);
?>

"adresse base" je met "localhost" en réponse je reçois " Connexion réussie "

lors de la création de la base j'ai aussi eu une adresse  "http://adressebase.cc/phpmyadmin " et quand je me rand a cette adresse j'arrive a une page de connection "php/myadmin" , j'entre mes identifiants et mot de passe et voila je suis connecté, j'ai deux répertoire, le premier "information schema" avec des sous répertoire a l'intérieure, et le deuxième  "nom de la base prestashop" avec rien a l'intérieure pas de table ni de donnée

2 hours ago, kerlin said:
  Citation

 comme Adresse du serveur de la base j'ai utiliser "localhost" non, et puis " http:// l'adresse de la base de donnée" non plus ,  pour le Nom de la base et l'Identifiant de la base deux nom différant non, et puis deux nom identique non plus,

j’essayai juste d’expliqué que j'ai finis par essayer toute les combinaison possible avec comme adresse "localhost" ou "http://adressebase.cc/phpmyadmin " et la base de donnée que j'ai renommé a plusieurs fois, avec des nom différant ou identique pour " nom de la base de donnée " et le "nom d'utilisateur" selon les nombreux post que j'ai lu. et a chaque fois que j'utilise "localhost" ou "http://adressebase.cc/phpmyadmin " si mes identifiants sont bon la page se recharge et je tombe sur cette fameuse page (vois photo ) ou il n'y a pas de barre de progression et puis plus rien

Merci Luc

2 hours ago, kerlin said:

 

Share this post


Link to post
Share on other sites
Il y a 11 heures, Luc nascar a dit :

tu doit bien te douter que ce n'est pas la réponse que j'attendais

heu non je ne me doutais pas que tu voulais que je réponde a coté de la plaque, mais si c'est le cas essai carré-carré-rond-rond-carré-croix-triangle

  • Haha 1

Share this post


Link to post
Share on other sites

si la base de donnée est vide c'est normal puisque l'installation de Prestashop ne s'est pas faite. Ne pas toucher à information schema.

Avec le petit script, avez-vous essayé la connexion à la base de données créée avec le NOM du serveur de bdd (pas l'url, donc sans http !!)

Un exemple pour un site hébergé chez OVH :

nom_de_la_base.mysql.db

 

Et pas l'adresse pour accéder à PhpMyAdmin !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More