Jump to content

Recommended Posts

Hallo , wir haben aktuell ein Problem ..

Neu Installierte Version und Aktuelle Version von Prestashop

Php Version 7.2 ( weitere ebenfalls schon versucht ohne erfolg )

classes/Tools.php ist vorhanden und wurde aucheinmal neu hochgeladen ( ohne erfolg )

db/db.php ebenfalls geändert in  $string = strip_tags(nl2br($string)); ( ohne erfolg )

 

Wenn wir den Debug Modus einschalten erhalten wir diese Meldung :

Fatal error: Uncaught Error: Class 'Tools' not found in /var/www/...../......../httpdocs/classes/db/Db.php:794 Stack trace: #0 /var/www/..../......../httpdocs/config/alias.php(47): DbCore->escape('configuration', false) #1 /var/www/...../......./httpdocs/config/alias.php(52): pSQL('configuration') #2 /var/www/...../......./httpdocs/classes/Configuration.php(155): bqSQL('configuration') #3 /var/www/vhosts/......./httpdocs/classes/Configuration.php(209): ConfigurationCore::loadConfiguration() #4 /var/www/....../......./httpdocs/classes/PrestaShopAutoload.php(171): ConfigurationCore::get('PS_DISABLE_OVER...') #5 /var/www/...../........./httpdocs/classes/PrestaShopAutoload.php(130): PrestaShopAutoload->generateIndex() #6 [internal function]: PrestaShopAutoload->load('Tools') #7 /var/www/....../........./httpdocs/config/config.inc.php(85): spl_autoload_call('Tools') #8 /var/www/..../....../httpdocs/index.php(27): require('/var/www/.....') #9 {main} thrown in /var/www/...../.....eu/httpdocs/classes/db/Db.php on line 794

 

hat hier jemand eine Idee ? Frage mich nur wenn das  wie man lesen kann schon eine altes Problem ist ? Das hier noch keine Lösung gibt ?

Wir wollten von Wordpress nach Prestashop wechseln ... Nun stellt sich die Frage .. ob es wirklich eine gute  Idee ist.

Danke für die Hilfe

Share this post


Link to post
Share on other sites

Versuche mal /var/cache zu /var/cache_old umzubennen, beim nächsten Aufruf wird dann ein neuer Cache erzeugt.

Ansonsten findet Google noch folgende Lösung

Quote

For people using Plesk, this is the solution for your problem.
Disable PHP-FPM and set FastCGI instead in PHP Settings.
Memcached and php-fpm can't work together on prestashop.
After switching to FastCGI issue was gone.

Quelle: https://github.com/PrestaShop/PrestaShop/issues/12667

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More