Jump to content

Recommended Posts

Bonjour à tous,

J'utilise la fonction d'export de bons de livraison PDF depuis mon site. Celle-ci est une peu lourde à traiter car j'ai beaucoup de commandes.
Problème : le serveur plante avant la fin d'exécution de la requête,et provoque une erreur en front. Est-ce qu'il n'y pas un réglage sur mon serveur à effectuer pour augmenter le délai avant timeout ? Ou est-ce que ça peut venir d'autre chose ?
J'ai un hébergement chez OVH.

Merci de votre aide !

Share this post


Link to post
Share on other sites

Augmenter la mémoire (memory_limit)

Augmenter le timeout (max_execution_time)

Découper l'impression avec un période plus étroite

Share this post


Link to post
Share on other sites

Merci pour votre retour.
Malheureusement je n'ai pas accès à ces commandes sur OVH mutualisé, j'ai le même problème sur la période la plus courte d'une journée. Par ailleurs j'imprime les bons par statut de commandé pour ma propre organisation. 

Le max_execution_time est à 5min, pourtant la page plante bien avant.
J'ai pourtant un serveur puissant, donc je suis étonné de ne pas pouvoir sortir plus de 20 bons d'un coup. C'est très ennuyeux surtout en ce moment car nous livrons des fruits et légumes des producteurs donc nos commandes explosent et nous ne pouvons pas nous organiser à cause de ça...

 

 

 

Share this post


Link to post
Share on other sites

Salut,

Quelle est la version exacte de votre prestashop ?

J’ai eu le même soucis sur l’une de mes boutiques car même en essayant d’exporter les commandes de la journée, c’était trop en charge serveur pour les calculs et la génération du pdf.

Du coup au début on le faisait depuis la page commande une par une mais c’est vraiment du temps perdu.

Notre solution c’est de lancer le traitement en Ajax en faisant par lot de 10 commandes en sauvegardant les lots sur le serveur puis à la fin de faire un zip de tous les pdf pour le téléchargement.

J’essayerai de partager ça sous forme d’un module demain si vous n’arrivez pas à vous vous en sortir

Bon courage 

Share this post


Link to post
Share on other sites

Salut Janett,

Merci beaucoup pour votre retour c'est très gentil de votre part.
Nous sommes sur la 1.7.6. 
J'ai eu OVH qui m'a fait désactiver l'option CDN sur notre serveur, car cela provoque un timeout à 1mn au lieu des 5 minutes de configuration serveur. 
Cela devrait être actif en fin de journée donc je pourrai tester à nouveau et je vous donnerai des nouvelles.

Si ça ne suffit pas je suis effectivement très preneur....

Merci!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More