Jump to content

Admin Catalog Categories Charset


Recommended Posts

9 hours ago, ggyyvv said:

Are category names displayed correctly in the table "ps_category_lang"?

Yes, names in category_lang are displayed correctly (first screenshot) as and in pruduct_lang (second screenshot) etc.

Also categories are displayed correctly in Catalog/Products Menu of Admin panel (third screenshot).

Screenshot_2020-03-17 shon com ua localhost shon_pres760 psgn_category_lang phpMyAdmin 4 9 0 1.png

Screenshot_2020-03-17 shon com ua localhost shon_pres760 psgn_product_lang phpMyAdmin 4 9 0 1.png

Screenshot_2020-03-17 Products • shon com ua.png

Edited by sergeiki (see edit history)

Share this post


Link to post
Share on other sites
1 hour ago, ggyyvv said:

there are no problems on the clean version of the Prestashop
try to install a clean version and connect your database

Thx for your answers. I want to make a next addition.

In previous PS installation i had problems with a russian letter "И".

Therefore in current installation at once after installation I copied from DbMySQLi.php in DbPDO.php next code:

// UTF-8 support
if (!$this->link->query('SET NAMES \'utf8\'')) {
    throw new PrestaShopDatabaseException(Tools::displayError('PrestaShop Fatal error: no utf-8 support. Please check your server configuration.'));
}

It solved issue of "И" and all works well but a not critical above issue with back-end categories exists... ((

Maybe a categories module uses another settings to connect to DB (not DbPDO.php file) or if it make a select query then it do not use utf8 settings?..
Back-end is codded on Symfony and it is very difficult understand a code...

Share this post


Link to post
Share on other sites
13 hours ago, ggyyvv said:

as you see, everything works
try to remove all your corrections

I use "$this->link->query('SET NAMES \'utf8\'')" because there is "init connect SET NAMES cp1251" in the mysql database settings in hosting using by me.
I can't change it to utf8 because I don't have rights (mysql error #1227).
Therefore I use that corrections...

Share this post


Link to post
Share on other sites
1 hour ago, ggyyvv said:

try to contact the hoster - they must solve this problem!

The hoster replied that it could not change the global settings on the public server(

1 hour ago, ggyyvv said:

if possible, send the structure of your database (data not needed)

Ok!

shon_pres760.sql.zip

Share this post


Link to post
Share on other sites
6 hours ago, ggyyvv said:

specify which hosting?

I don't know, me need to ask my employer, I have login for admin cPanel only.

5 hours ago, ggyyvv said:

although, I think it's easier to change this hosting
please specify if you modified other files?

I did not modify any files more.

 

6 hours ago, ggyyvv said:

ok
How is displayed if edited?

In edition mode all okay see attachment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More