Jump to content
Garbure

[Résolu] Modification compte client impossible

Recommended Posts

Bonjour,

Je vous sollicite car je n'arrive plus à modifier un compte client. Il indique "Ce champ est obligatoire : optin." même si tous les champs sont remplis...

Je suis 1.7.6.0, avec le thème par défaut, Version de PHP : 7.2.26. Voici une photo...

https://drive.google.com/file/d/1-NA3rEDMaAnUat00vQ8vTIDulILcMsqY/view?usp=sharing

Si quelqu'un a une piste...

Merci à vous

 

Edited by Garbure
résolu (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

comme le montre votre capture d'écran, le champ Optin (offres partenaires) est gris au lieu d'être rouge, donc sa valeur est indéfinie il suffit donc de mettre une valeur soit Oui, soit Non, mais un valeur.

Je précise que pour réussir à mettre cette valeur il suffit de cliquer sur le "bouton" Oui ou Non.

Share this post


Link to post
Share on other sites

Le champ optin ne DOIT JAMAIS être obligatoire en Europe. C'est purement illégal.

BO > Customers > Customer settings | bas de page: Set required fields for this section, ne pas mettre optin

Share this post


Link to post
Share on other sites

Bonjour,

Merci de vos réponses... Le comportement est bizarre. J'avais désactivé l'offre partenaire car je trouve cela envahissant pour le client. Je l'ai réactivé mais si elle est sur "non", je ne peux pas le modifier. Par contre, si je coche oui pour le client, je peux le modifier... 

https://drive.google.com/file/d/1ZkgQ1xtTTUkIb4_xFnQO3JJDDMu8ReLn/view?usp=sharing

Donc, pour me dépanner, j'active l'offre partenaire, je fais la modification et je désactive... C'est pas top, mais je peux faire la modification.

 

Share this post


Link to post
Share on other sites

Bonjour,

Mon problème est plus important. Si dans le backoffice, dans paramètre de la boutique\Client, activer les offres partenaires : non. Impossible de créer un compte : Erreur 500

Si j'active les offres partenaires, le client est obligé de cocher la case pour s’inscrire...

https://drive.google.com/file/d/1B3BFwTTgxIko6NS_bhiTlZMc9Prk0jcE/view?usp=sharing

Si quelqu'un a une piste pour résoudre mon problème ou quelque fichier je peux restaurer depuis mes backups. 

Merci

 

Share this post


Link to post
Share on other sites
Le 2/26/2020 à 1:20 PM, doekia a dit :

Le champ optin ne DOIT JAMAIS être obligatoire en Europe. C'est purement illégal.

BO > Customers > Customer settings | bas de page: Set required fields for this section, ne pas mettre optin

 

Share this post


Link to post
Share on other sites

Merci de votre réponse,

Je sais bien que c'est illégal, mais si le client ne coche pas cette option, il ne peut pas créer de compte. Pareil si je désactive l'option dans le backoffice. 

Ce n'est pas une volonté de ma pars, je cherche juste une solution...

 

Share this post


Link to post
Share on other sites

Désactive l'option, vide tes cache ... l'option ne doit ni être obligatoire, ni générer d'erreur

Share this post


Link to post
Share on other sites

Bonjour,

Malheureusement, comme cela ne fonctionnait toujours pas, j'ai mis à jour ma boutique en 1.7.6.4... Même résultats. 

Si quelqu'un a une idée dans quel fichier aller chercher, je suppose que j'ai fait une mauvaise manipulation, mais je ne sais pas où chercher.

Cordialement

Share this post


Link to post
Share on other sites
Le 02/03/2020 à 2:25 PM, doekia a dit :

Désactive l'option, vide tes cache ... l'option ne doit ni être obligatoire, ni générer d'erreur

Pourtant l’information était bien précisée.

Prenez le temps de bien lire les réponses que font les bénévoles.

Le 26/02/2020 à 1:20 PM, doekia a dit :

Le champ optin ne DOIT JAMAIS être obligatoire en Europe. C'est purement illégal.

BO > Customers > Customer settings | bas de page: Set required fields for this section, ne pas mettre optin

et n'oubliez pas de mettre le topic en Résolu

772762601_topicresolu.png.da616ed9356e78ecf3a7b296fea2b2fd.png

Share this post


Link to post
Share on other sites

Bonjour,

Sans vouloir paraître désagréable, j'ai bien lu votre réponse. Je désactivé l'option dans Paramètre de la boutique\Client et non dans Gestion des clients, ce qui n'est pas préciser dans votre réponse. D'ailleurs, j'ai bien conscience que vous êtes des bénévoles, c'est pour cela que je poste la solution à mon problème pour  d'autres personnes. Pour information, l'option opt-in est désactivé dans ma boutique...

Je passe le post en résolu. 

Cordialement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More