Jump to content
NETZchecker

Deaktivieren Debug Modus weiße Seite im Admin

Recommended Posts

Hallo zusammen,

ich habe ein großes Problem. Wenn ich in meinem Shop den Debug Modus ausschalte habe ich 2 (große) Probleme:

1. Viele Änderungen die ich durchgeführt habe, wie zum Beispiel alle Übersetzungen, das Hauptmenü etc. sind im Frontend weg. Keine Ahnung was das mit dem Debug Modus zu tun hat, der soll doch eigentlich nur die Fehler ausgeben?

2. Wenn ich den Debug Modus ausschalte kann ich auf viele Seiten im Admin nicht mehr zugreifen. Zum Beispiel "Leistung" bei dem ich den Cache löschen kann. Es kommt nur eine weiße Seite, sonst nichts.

Mir wäre es ja egal ob Debug Modus an oder aus, nur funktioniert dann die Suche im Frontend nicht richtig. Ich bekomme dann bei jeder Suche Fehlermeldungen wie zum Beispiel:

Quote

(1/1) ContextErrorException

Notice: Undefined index: category

in 8b8c707f137a25b3730c16795c6bdf3e401f9400_2.file.product-list.tpl.php line 169

at Block_6666718185e399cf24d8082_34543939->callBlock(object(SmartyDevTemplate))in smarty_internal_runtime_inheritance.php line 247

Vielen Dank schon mal fürs Lesen!

Edited by NETZchecker (see edit history)

Share this post


Link to post
Share on other sites

Du solltest vielleicht als erstes einmal den Cache löschen.

Share this post


Link to post
Share on other sites

Hallo!

danke für dein Antwort! Die Lösung war eigentlich ganz simpel. Und ich hab stundenlang gesucht. 😂

Ich musste im Verzeichnis /var/cache/ den Ordner /prod/ manuell löschen. Dann hat es funktioniert.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More