Jump to content
dlcrea

Problème compatibilité Prestashop 1.6.1.24 et PHP 7.1

Recommended Posts

Bonjour,

Après une mise en jour de Prestashop 1.6.1.6 vers 1.6.1.24 (en local sur Wamp), j'ai passé la version de php à 7.1 comme c'est la version que Prestashop recommande avec 1.6.1.24. Côté front pas de souci, par contre impossible de me connecter à l'admin : "Erreur de chargement de la page. La connexion a été réinitialisée".

Pour voir si c'était à cause de ma mise à jour qui ne s'était peut-être pas bien passé, j'ai installé un nouveau prestashop 1.6.1.24 sur une nouvelle base, et j'ai exactement le même problème. J'ai vu un post sur ce même forum où quelqu'un a résolu ce problème en passant sur une version antérieure de PHP et effectivement ça fonctionne avec PHP 7.0... sauf que Prestashop recommande la version 7.1.

Est-ce que quelqu'un a un Prestashop 1.6.1.24 qui fonctionne correctement avec PHP 7.1 ? Est-ce que quelqu'un a déjà eu ce genre de problème ?

Share this post


Link to post
Share on other sites

Le coeur PrestaShop 1.6.1.24 devrait correctement fonctionner en PHP7.1, mais il ce n'est probablement pas le cas de tous tes modules.

Quoiqu'il en soit tu peux rester en php7.0.

Note néanmoins que pendant 5ans la norme était php5.6, aussi il est fort possible que des modules ne fonctionnent pas vraiment au delà de cette version PHP

Share this post


Link to post
Share on other sites

Merci doekia pour ta réponse rapide. Par contre, si le problème vient des modules, je ne devrais pas avoir le même souci avec la nouvelle installation de Prestashop 1.6.1.24 (j'ai installé Prestashop 1.6.1.24, créée une nouvelle base, les tables se sont créées avec l'installation et je n'ai rien ajouté de plus, donc les modules présents sont ceux de base avec cette version de Prestashop).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More