Jump to content

Fix PHPUnit vulnerabilities on Prestashop (free module)


Recommended Posts

Hello everybody!

According to the official report, Critical Security Vulnerability was found In PrestaShop Modules that allows attackers are exploiting a vulnerability in PHPUnit to perform arbitrary code execution in servers running PrestaShop websites. 

For more information about this security hole, see here: https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/ 

As this is a big security problem happens with many Prestashop websites so it requires your urgent attention to check your website and remove all PHPUnit folders on your server to close the attack vector, we have developed this simple module that could help you to check and delete the PHPUnit directories in 1 click. The module is attached in the downloads.

spacer.png

 

Enjoy and give us your feedback!

ets_phpunit_remover.zip

*Note: You need to login to download if it shows "Unavailable"

Edited by ets-soft
Insert introduction video (see edit history)
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
16 hours ago, elecevo said:

Hello your module is not available anymore. Possible to download it again? Thank you in advance.

Hello,

The download file is still available on the 1st post. You need to log into PrestaShop forum to be able to see the download link. 

My best regard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More