Jump to content
funnybirds

[Résolu] règle panier non appliquée au total

Recommended Posts

Bonsoir à tous,

Je rencontre un problème avec une règle de panier, je souhaite offrir 200€ sur un produit avec un code promo, jusque là rien de compliqué, j'ai bien configuré la règle, elle s'applique bien dans le panier sur l'article en question mais les 200€ ne sont pas déduits du prix de l'article.

Par contre si au lieu d'un montant de 200€ j'applique un pourcentage de 17% par exemple là pas de problème c'est bien déduit ...

Je ne comprends pas et je n'ai pas trouvé d'info en cherchant sur le forum.

Je suis en 1.7.5

Merci d'avance pour votre aide

Edited by funnybirds (see edit history)

Share this post


Link to post
Share on other sites

Pourquoi dis-tu que ce n'est pas bien déduit ? Pouvez-vous donner un exemple ?

Share this post


Link to post
Share on other sites

Je répond à sa place mais on est 2 à bosser sur le même PS.

La promo n'est pas déduite tout court.

Article à 1000€ avec règle panier -200€, le total panier reste à 1000€, alors qu'il affiche bien la réduction de -200€.
Les restrictions fonctionnent, puisque si on modifie uniquement l'action pour choisir -20%, ça fonctionne parfaitement, c'est bien déduit du panier pour se retrouver à 800€
Est-ce plus clair ?

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour votre réponse.

Avec un montant fixe le code promo fonctionne puisque il s'affiche dans le panier -200€ mais n'est pas déduit du prix de l'article dans le total TTC

Exemple avec un montant fixe :

4349.jpg

et voila ce que ça donne avec un pourcentage

4350.jpg

C'est un peu gênant .... Je cherche depuis hier mais sans succès !

Le site est https://drole2roue.com

C'est un multiboutique au cas où ...

Merci pour votre aide

Share this post


Link to post
Share on other sites
il y a une heure, funnybirds a dit :

C'est un multiboutique au cas où ...

Peut être la réponse, car en 1.7 le multi boutique rencontre énormément de soucis.

Pour ce genre de cas, essayez de les reproduire sur des installes fraiches et sur les version les plus récentes car le soucis est peut être déjà corrigé.

Si malgré tous vos test rien de corrige ce soucis vous pouvez poster une requête de correction auprès de PrestaShop sur https://github.com/PrestaShop/PrestaShop/issues/new?template=bug_report.md

Share this post


Link to post
Share on other sites

Joffrey à testé sur la boutique 1 de notre multiboutique les remises fonctionnent correctement avec le thème Classic, on c'est dit chouette le problème c'est le thème !! eh bah non... :((

J'ai testé la boutique 2 (drole2roue.com) avec le thème Classic même problème !!!
ça ne vient pas du thème mais peut être plus du multiboutique comme le dit Mediacom87 !

fil ouvert sur github

Merci de nous aider, le site est en prod et la remise annoncée ... ça nous porte préjudice et nous ne trouvons pas de solution.

4359.jpg

4358.jpg

Share this post


Link to post
Share on other sites

Je n'ai plus le bouton pour faire cela ! il est bien à coté du débug normalement non ? ailleurs ?
On peut faire autrement ?

Merci

off%20overide.JPG

Share this post


Link to post
Share on other sites

surcharge = override
On a tenté en les désactivant, pas mieux.
On a vraiment une non prise en comtpe de la réduc sur une promotion en montant. Même la ligne "réduction" ne s'affiche pas dans le panier.
Un coup de main serait super apprécié

 

Share this post


Link to post
Share on other sites

Personne n'a un début d'idée ?
On tourne en rond, on a changé la boutique de thème, mis à jour, rincé les caches, désactivés les modules hors PS un par un et ... rien :(

Share this post


Link to post
Share on other sites

Bonjour à tous,

Nous avons trouvé le problème. Ce n'est pas un bug de la 1.7 (on va pas tout lui mettre sur le dos !) on passera le cheminement pour en arriver à trouver la solution... c'était un problème dans les devise. Sans que l'on sache pourquoi, le taux de change de la devise Euro était à 0 ce qui provoque ce bug de la promo en montant fix. Une fois passé à 1 plus de problème.

Des heures (jours) de recherche pour en arriver à ça, si ça peut aider quelqu'un ....

devises.png

Share this post


Link to post
Share on other sites
Il y a 2 heures, funnybirds a dit :

Nous avons trouvé le problème. Ce n'est pas un bug de la 1.7 (on va pas tout lui mettre sur le dos !) on passera le cheminement pour en arriver à trouver la solution... c'était un problème dans les devise. Sans que l'on sache pourquoi, le taux de change de la devise Euro était à 0 ce qui provoque ce bug de la promo en montant fix. Une fois passé à 1 plus de problème.

maintenant, il va falloir passer des jours à trouver pourquoi le taux était passé à 0 🙂

Merci pour votre retour.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More