Jump to content

[SOLVED] Products don't appear in the category after selecting country! 1.7.4.3


Recommended Posts

Hello

Products don't appear in the category after selecting country! an example, i created a new account and selected to Germany. I returned to categories but products don't appear in the categories. Products displaying only to Turkey. There are problems in all countries except Turkey and I didn't make any country and catalog restrictions.

can you help me please? thanks

website: https://en.klen.com.tr

Edited by SeizeTheDay (see edit history)

Share this post


Link to post
Share on other sites
1 hour ago, SeizeTheDay said:

Hello

Products don't appear in the category after selecting country! an example, i created a new account and selected to Germany. I returned to categories but products don't appear in the categories. Products displaying only to Turkey. There are problems in all countries except Turkey and I didn't make any country and catalog restrictions.

can you help me please? thanks

website: https://en.klen.com.tr

I don´t see any problems displaying products in categories!! Maybe you need to clear the cache from prestashop backoffice and your browsers cache!!

productscategories.thumb.JPG.d95aab6367a30362631d096e3d851fd8.JPG

Best Regards

Share this post


Link to post
Share on other sites
On 11/17/2019 at 12:51 AM, PCQUATRO said:

I don´t see any problems displaying products in categories!! Maybe you need to clear the cache from prestashop backoffice and your browsers cache!!

Best Regards

Hi. @PCQUATRO

I think you have entered the site as visitor. Please register first, add an address, then look at the categories. Products are not visible after logging in. There are problems in all countries except Turkey and I didn't make any country and catalog restrictions.

 

after logging in.jpg

Edited by SeizeTheDay (see edit history)

Share this post


Link to post
Share on other sites
3 hours ago, SeizeTheDay said:

Hi. @PCQUATRO

I think you have entered the site as visitor. Please register first, add an address, then look at the categories. Products are not visible after logging in. There are problems in all countries except Turkey and I didn't make any country and catalog restrictions.

Try to turn off geolocatrion and select the countries you want in the list...

geolocation.thumb.JPG.a6833308502810b340b3f7ca4851f351.JPG

Also try to enable all zones and countries you need in locations...

zonecountry.thumb.JPG.87308cb8bea56ca5c3392132e39012da.JPG 

Best Regards

Share this post


Link to post
Share on other sites
On 11/21/2019 at 2:05 AM, PCQUATRO said:

Try to turn off geolocatrion and select the countries you want in the list...

geolocation.thumb.JPG.a6833308502810b340b3f7ca4851f351.JPG

Also try to enable all zones and countries you need in locations...

zonecountry.thumb.JPG.87308cb8bea56ca5c3392132e39012da.JPG 

Best Regards

@PCQUATRO thanks for helps but the problem still continues. What might be caused?

Share this post


Link to post
Share on other sites

UPDATE:

In backoffice follow these steps:

  • (sidebar) International -> Localization

  • (tab) Geolocation

  • Change settings as you can see you can hide your catalog for restricted countries

Kind regards,

Crezzur

Edited by Crezzur (see edit history)

Share this post


Link to post
Share on other sites
1 minute ago, Crezzur said:

We just created an account, and are only able to select turkey. (products are showing then)

Can you explain it a bit more what causes the disappearing products?

Hi @Crezzur Pls try select a country again. I activated. I do not understand why the products do not appear. After selecting other countries (except Turkey), the products do not appear in the category + The same problem exists in the choice of currency. The main currency of the store is the euro. but when we change the currency on the front office, the products don't appear again in category. I'm in trouble.

Share this post


Link to post
Share on other sites

You must have some kind of filtering somewhere, check your products and categories, because for instance in country turkey some categories are not displayed in other currencies and others are, like for instance "Neckalces" witch can be displayed in all currencies...

currency.thumb.JPG.6f7a3f6367fd5efe87d8925af577021a.JPG

Check your settings by comparing that categorie with the other categories. You might also consider upgrading to prestashop 1.7.6.1.

Remember ALWAYS BACKUP FIRST.

Best Regards

Share this post


Link to post
Share on other sites
  • 5 months later...
  • 9 months later...

Hello, thsx for your post.

Are you still having this problem? It seems to me that I have this same problem, for no apparent reason, although my site has been working fine so far.

And I can't find a solution. Best regards France

(I am under Presta 1.7.6.9)

 

 

Share this post


Link to post
Share on other sites

Hello, we just found the source and cause of this problem. It looks like it came from the module: Faceted Navigation. It looks like it's bugging. We deactivated it from the back office, and everything is back to normal. This post I hope will help someone. Coridally

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More