Jump to content
ghaitoute

Front-office (version anglais) temps d'attente insupportable

Recommended Posts

Bonjour a tous, 

Je vous expose mon problème, J'ai un site en deux langues français et anglais.

Le front office marchent bien mais sur la version anglais, le site met beaucoup de temps avec un temps d'attente entre 10 et 20 sec ce qui est insupportable.

Voila le rapport de GTMETRIX:  https://gtmetrix.com/reports/swimrunland.fr/8PNLiVBm

Merci pour votre aide.

Edited by ghaitoute (see edit history)

Share this post


Link to post
Share on other sites

et l'image qui devrait s'afficher dans le sous menu  WETSUITS/WOMEN WETSUITS est la deuxième image a remplacer ou supprimer

Share this post


Link to post
Share on other sites

 

12 minutes ago, solsol69 said:
4 minutes ago, solsol69 said:

et l'image qui devrait s'afficher dans le sous menu  WETSUITS/WOMEN WETSUITS est la deuxième image a remplacer ou supprimer

Merci c'est fait, mais le site en version anglaise met beaucoup de temps... avez vous jeter un coup d'oeil sur le rapport GTMETRIX que j'ai posté?

 

Edited by ghaitoute (see edit history)

Share this post


Link to post
Share on other sites

quel type de serveur avez vous ? avez vous activer le cache ? avez vous optimiser le poid de vos images ?

Share this post


Link to post
Share on other sites

pour la partie serveur, c'est pas moi qui s'en charge, je pense aussi que c'est un probleme de cache, j'ai rajouter quelque ligne de code le .htaccess comme indiqué sur le rapport GTMETRIX mais ça ne marche toujours pas. dois je contacter l'administrateur de serveur pour lui demander d'activer le cache? que dois je lui dire?( voir les PJ)

merci infiniment pour votre aide.

 

Capture d'écran 2019-10-24 09.25.02.png

Capture d'écran 2019-10-24 09.24.47.png

Capture d'écran 2019-10-24 09.27.55.png

Capture d'écran 2019-10-24 09.31.34.png

Capture d'écran 2019-10-24 09.32.05.png

Share this post


Link to post
Share on other sites

Bonjour

Je pense qu'il serait bon en premier lieu  d’éviter ( si vous pouvez ) les images en .png ( bien plus lourdes que les .jpg ) 

Et aussi récupérer les images optimiser de gtmetrix et les remplacer par la version optimisé ( photo ci joint ) ça rendra votre page légèrement plus rapide pour le chargement..

Et coté serveur voir avec votre administrateur je ne suis pas sur mais creuser du coté de gzip et le mode deflate.( a verifier je ne suis pas un expert sous plesk)

Cote prestashop est ce que votre cache est activé ? ( dans performance )

Archived Performance Report for  http   www swimrunland fr    GTmetrix.png

Share this post


Link to post
Share on other sites
1 minute ago, solsol69 said:

Bonjour

Je pense qu'il serait bon en premier lieu  d’éviter ( si vous pouvez ) les images en .png ( bien plus lourdes que les .jpg ) 

Et aussi récupérer les images optimiser de gtmetrix et les remplacer par la version optimisé ( photo ci joint ) ça rendra votre page légèrement plus rapide pour le chargement..

Et coté serveur voir avec votre administrateur je ne suis pas sur mais creuser du coté de gzip et le mode deflate.( a verifier je ne suis pas un expert sous plesk)

Cote prestashop est ce que votre cache est activé ? ( dans performance )

Archived Performance Report for  http   www swimrunland fr    GTmetrix.png

oui le cache et le ccc option sont activés, c'est juste la version anglaise du site  qui pose un problème,  son chargement est très long :(

Share this post


Link to post
Share on other sites

essayer cette configuration dans Paramètres avancés/Performances

 

et vide le cache pour tester si cela corrige le probleme

Performances.png

Share this post


Link to post
Share on other sites
17 minutes ago, solsol69 said:

essayer cette configuration dans Paramètres avancés/Performances

 

et vide le cache pour tester si cela corrige le probleme

Performances.png

Merci solsol69.

c'est fait mais apparemment ça ne corrige pas le problème 😕

Share this post


Link to post
Share on other sites

peut etre faut il aussi vider le cache de presta en passant par votre ftp .

Share this post


Link to post
Share on other sites
8 minutes ago, solsol69 said:

peut etre faut il aussi vider le cache de presta en passant par votre ftp .

Je viens de vérifier le dossier cache est vide voir PJ.

 

Capture d'écran 2019-10-24 11.43.20.png

Share this post


Link to post
Share on other sites
9 minutes ago, solsol69 said:

sur presta 1.7 il se trouve dans var/cache/prod/smarty/compile

je viens de vider le dossier compile comme vous m'avez indiquer mais la version anglaise est toujours longue à charger 😕

Share this post


Link to post
Share on other sites

et en régénérant votre fichier .htaccess ?

Avant il faut le sauvegarder sur votre pc ( via ftp )

le supprimer  de votre ftp et aller dans 

 parametre de la boutique /Trafic et SEO / SEO & URL

cliquer sur URL simplifiée : le mettre sur non et enregistrer

puis le remetre sur oui et enregistrer.

cela va regenerer un htaccess

 

Share this post


Link to post
Share on other sites
4 hours ago, solsol69 said:

et en régénérant votre fichier .htaccess ?

Avant il faut le sauvegarder sur votre pc ( via ftp )

le supprimer  de votre ftp et aller dans 

 parametre de la boutique /Trafic et SEO / SEO & URL

cliquer sur URL simplifiée : le mettre sur non et enregistrer

puis le remetre sur oui et enregistrer.

cela va regenerer un htaccess

 

je viens de le faire mais toujours le meme problème :(

Share this post


Link to post
Share on other sites
7 minutes ago, solsol69 said:

Dernier test essayer de desactiver temporairement le slider

je viens de le faire, le problème est toujours la... ce que j'arrive pas à comprendre pourquoi le site ralenti juste sur la version angulaise et non pas sur la version principale :(

Share this post


Link to post
Share on other sites
On 10/24/2019 at 6:57 PM, solsol69 said:

Dernier test essayer de desactiver temporairement le slider

Bonsoir, je viens de jeter un coup d'oeil sur le serveur dans les fichiers logs, si vous pouvez me m'aider a comprendre ce message d'erreur en PJ.

AH01071: Got error 'PHP message: PHP Fatal error: Uncaught InvalidArgumentException: Locale "q" could not be parsed in /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Localize.php:244\nStack trace:\n#0 /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Localize.php(79): PrestaShop\\PrestaShop\\Core\\Cldr\\Localize::canonicalize('q')\n#1 /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Localize.php(180): PrestaShop\\PrestaShop\\Core\\Cldr\\Localize::getBrowserLocales()\n#2 /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Localize.php(152): PrestaShop\\PrestaShop\\Core\\Cldr\\Localize::getPreferedLocale()\n#3 /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Localize.php(122): PrestaShop\\PrestaShop\\Core\\Cldr\\Localize::getLocale()\n#4 /var/www/vhosts/swimrunland.fr/httpdocs/src/Core/Cldr/Repository.php(93): PrestaShop\\PrestaShop\\Core\\Cldr\\Localize::getLanguage()\n#5 /var/www/vhosts/swimrunland.fr/httpdocs/classes/Tools.php(724): PrestaShop\\PrestaShop\\Core\\Cldr\\Repository->__construct('')\n#6 /var/www/vhosts/swimrunland.fr/h...\n'

merci infiniment.

 

Capture d'écran 2019-10-26 11.26.30.png

Capture d'écran 2019-10-26 17.55.29.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More