Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

 
Photo

PS directory


  • Please log in to reply
14 replies to this topic
VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 11 October 2009 - 07:55 PM

Can someone help?

I would like to move mine shop from folder /shop/ to main www site.
I'w copied all the files but i can't acess it there.
I'w tryed to edit settings.inc.php by erasing /shop/ in: define('__PS_BASE_URI__', '/shop/'); but it don't works! :(

fs_xyz

    PrestaShop Apprentice

  • Members
  • PipPip
  • 66 posts

Posted 12 October 2009 - 01:00 AM

If your new www also a domain name, a "/" will be enough.
If not, you need to write your new www. Example : www.example.com
Sorry for the broken English, not my 1st language.

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 06:53 AM

I just want to change it from http://www.shop.com/shop to http://www.shop.com
But i must be missing something becouse nothing seems to work. :( i constantly get http 500 internal server error.

ruilong

    PrestaShop Addict

  • Moderators
  • 735 posts

Posted 12 October 2009 - 06:58 AM

Hi,

you need to change config/settings.inc.php
define('PS_BASE_URI', '/');


that should do it.
what do the 500 errors say?
Modules and themes for prestashop.
E-butik med prestashop inkl hosting och gratis installation.

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 07:11 AM

Crap, it dont work! :(

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 07:18 AM

Do i need to change paths in some other files aswell? ..or in database?

Maybe it would be easier to just somehow redirect?
but, how to do that?

ruilong

    PrestaShop Addict

  • Moderators
  • 735 posts

Posted 12 October 2009 - 07:27 AM

You may try the htaccess file.. it's possible that's what makes the wrong urls
Modules and themes for prestashop.
E-butik med prestashop inkl hosting och gratis installation.

ruilong

    PrestaShop Addict

  • Moderators
  • 735 posts

Posted 12 October 2009 - 07:29 AM

I just checked the database, in table configuration there is a PS BASE URI key.. must be new since 1.2.
you need to change this also to / instead of /SHOP/
Modules and themes for prestashop.
E-butik med prestashop inkl hosting och gratis installation.

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 07:51 AM

hmmm... ill try transfer once again, maybe i missed something.

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 08:49 AM

still not working... :(

i dont get it.

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 11:58 AM

damn, iw downloaded and tryed localy and it also not working.
iw changed from /shop/ to just / and it dont work!


what else could be wrong???

I just dont get it... i acts as it MUST be inside of some directory in public_html folder, otherwise it wont work!?

TropischBruin

    PrestaShop Fanatic

  • Moderators
  • 2199 posts

Posted 12 October 2009 - 01:33 PM

Is there a redirect active that redirects from / to /shop/?
Norman in 't VeldtModeratorPrestaShopForums
Help PrestaShop, make a donation!

VIXUS

    PrestaShop Addict

  • Members
  • PipPipPip
  • 588 posts

Posted 12 October 2009 - 01:56 PM

yes, iw turned that ON becouse i dont know how to make it work properly. :(

TropischBruin

    PrestaShop Fanatic

  • Moderators
  • 2199 posts

Posted 12 October 2009 - 02:14 PM

Turn it off?
Norman in 't VeldtModeratorPrestaShopForums
Help PrestaShop, make a donation!

wiros

    PrestaShop Apprentice

  • Members
  • PipPip
  • 40 posts

Posted 19 November 2009 - 11:20 PM

Turn it off?



Is it solved? I got the same problem




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users