Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

Photo

Getting Warning: MemcachePool::set(): No servers added.

memcachepool memcache set no servers warning error

  • Please log in to reply
5 replies to this topic
dhurley

    PrestaShop Apprentice

  • Members
  • PipPip
  • 47 posts

Posted 25 September 2013 - 06:31 AM

I have a new server that I am working on. It was set up with Memcache. I was able to enable it through the backoffice performance settings and the install warning on that page went away. Now it is generating this error:

 

Warning: MemcachePool::set(): No servers added to memcache connection in */classes/cache/CacheMemcache.php on line 156

 

Not many Google results on this. Im stumped.

 

Any help would be appreciated, thanks!



hideo

    PrestaShop Newbie

  • Members
  • Pip
  • 12 posts

Posted 06 October 2013 - 01:04 PM

Hi,
 
I have seen this just after enabling cache "memcache" today.
 
I have troubles with CPU usage in 1.5.4.1, same after upgrading to 1.5.5. So I'm trying everything to solve this. Enabling memcache was one of my action :)
 
I keep you posted if I find something.
 
Hideo


hideo

    PrestaShop Newbie

  • Members
  • Pip
  • 12 posts

Posted 13 October 2013 - 11:36 AM

Hi,

 

I saw that when you add a server (the IP of your dedicated server), you have another error message:

[error] [client xx.xxx.xxx.xxx] PHP Notice:  MemcachePool::get(): Server xx.xxx.xxx.xxx (tcp 11211, udp 0) failed with: Connection refused (111)

 

But this might be fixed by authorising connexion on 11211 port of your server. I try to fix it and I post if this works.

 

Hideo



hideo

    PrestaShop Newbie

  • Members
  • Pip
  • 12 posts

Posted 14 October 2013 - 12:17 AM

Hi again,

 

The problem is due to the memcached configuration:

 

>> vi /etc/memcached.conf

Comment the line "-l 127.0.0.1" and add "-l xx.xxx.xxx.xx", where "xx.xxx.xxx.xx" is the IP of your server.

 

>> service memcached restart

>> service apache2 restart (not sure this one is needed)

 

I've seen this here: http://serverfault.c...o-memcache-host 

 

Hope this helps.

 

Hideo



expertgazfioul

    PrestaShop Newbie

  • Members
  • Pip
  • 20 posts

Posted 24 February 2014 - 11:58 AM

Hi,

I have exactly the same error. 

The only solution i found is disable the cache

I am still looking for the solution

Thanks



estefana

    PrestaShop Apprentice

  • Members
  • PipPip
  • 33 posts

Posted 03 March 2014 - 12:45 PM

Why is there never a solution posted to this issue?

 

Never mind. I give up. I will find a different shop solution.







Also tagged with one or more of these keywords: memcachepool, memcache, set, no servers, warning, error

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users