Jump to content
VVERGARA

Actualizar Prestashop 1.6 a 1.7 (SOLUCIONADO)

Recommended Posts

Posted (edited)

Buenos dias, tengo prestashop 1.6.1.24 a la ultima version disponible y quiero actualizar con 1-Click. y en la lista de comprobación me aparece "PrestaShop requirements are not satisfied." con una señal de advertencia. Seguramente es una tonteria pero no se como solucionarlo. Gracias.

Screenshot_2019-08-23 1-Click Upgrade 1-Click Upgrade • My Outlet.png

Edited by VVERGARA (see edit history)

Share this post


Link to post
Share on other sites

Hola vvergara,

Pincha sobre "See details" y pon la captura de pantalla para ver que más pide.

Un saludo. 

Share this post


Link to post
Share on other sites
28 minutes ago, VVERGARA said:

Un poco más arriba te dice que tu servidor está funcionando con una versión de php soportada, sin embargo, en esa url te explican que temina el soporte para PHP 5.4 y 5.5, y que va a pasar lo mismo con php 5.6.

De todas formas si vas a instalar Prestashop 1.7  es mejor que actives en tu hosting como mínimo PHP 7.0 (te recomiendan la 7.1), en la url te dicen que  Prestashop funciona correctamente hasta php 7.2, pero no todos los módulos te van a funcionar con php 7.2. Prueba las diferentes opciones de PHP que te permita tu hosting y que veas que te funcionan correctamente. Desde el panel de control de tu hosting puedes ajustar la versión de PHP antes de actualizar el prestashop.

Php 7 hara tu web algo más rápida, y sobre todo más segura.

Un saludo

Edited by Javierlpz (see edit history)

Share this post


Link to post
Share on other sites

Si Gracias... el problema era en el hosting que el que teniamos no nos permitía actualizar la version PHP mas alla de la 6.1. Ya está solucionado muchas Gracias.

Share this post


Link to post
Share on other sites
En 4/9/2019 a las 4:46 PM, Javierlpz dijo:

Un poco más arriba te dice que tu servidor está funcionando con una versión de php soportada, sin embargo, en esa url te explican que temina el soporte para PHP 5.4 y 5.5, y que va a pasar lo mismo con php 5.6.

De todas formas si vas a instalar Prestashop 1.7  es mejor que actives en tu hosting como mínimo PHP 7.0 (te recomiendan la 7.1), en la url te dicen que  Prestashop funciona correctamente hasta php 7.2, pero no todos los módulos te van a funcionar con php 7.2. Prueba las diferentes opciones de PHP que te permita tu hosting y que veas que te funcionan correctamente. Desde el panel de control de tu hosting puedes ajustar la versión de PHP antes de actualizar el prestashop.

Php 7 hara tu web algo más rápida, y sobre todo más segura.

Un saludo

Buenas tardes,

Me he encontrado con esto y he intentando actualizar el PHP, el problema es que cuando llego a la actualización PHP 7.1 en mi panel, mi backoffice de prestashop 1.6.1.11 se cae y no carga. He intentado actualizar al .18 o .23  pero no veo como con el 1 click upgrade que me quiere llevar directamente al 1.7. Tampoco sé si podría ir subiendo versiones de PHP y prestashop gradualmente hasta llegar a las versiones deseadas.

Por otra  parte, he intentado instalar directamente la versión 1.7 y conectarla con mi base de datos. Esto funciona, los artículos aparecen, pero no coge las categorias entre otras cosas, por mil temas de incompatibilidad por lo que he visto. No sé si existe algún módulo para convertir las tablas aunque la instalación tenga que hacerla manual. Tengo una nueva plantilla para el 1.7, porque con esta operación me pone automáticamente la classic, que entiendo que tendría que poner en el paso final.

Me planteo hacer la migración de categorías y resto de información desde myphp, pero me da miedo que cuando intente importarlas a la versión 1.7 me vuelva a dar el mismo error del punto anterior.

Todo esto claro, lo he intentado con un clon de mi web.

Gracias!!

Share this post


Link to post
Share on other sites

A ver, por partes:

La versión 1.6.1.11 de Prestashop NO es compatible con PHP 7. La última versión de la rama 1.6 (creo que es la 1.6.1.24), sí que lo es.

Por tanto, para actualizar desde la versión 1.6.1.11 a la 1.7.x se puede hacer en dos pasos (primero actualizar a la 1.6.1.24 y luego a la 1.7.x).

Otra opción es actualizar directamente desde la 1.6.1.11 a la 1.7.x conservando la versión 5.6 de PHP y luego cambiarla a la 7.2. Esto debería funcionar sin problemas, a pesar de que el módulo de actualización ADVIERTA de que es mejor actualizar la versión de PHP.

Otra cosa es el tema de cambiar de la versión 1.6.x a la 1.7.x en sí. Los tema de las versiones 1.6 NO son compatibles con las veresiones 1.7. La mayoría de los módulos, tampoco. Por tanto, se puede realizar una actualización correcta y luego encontrarnos con muchas cosas que no funcionan, pero que no es porque la actualización haya fallado, sino porque lo que tenemos instalado en nuestra tienda no es compatible con la versión 1.7. Lo que habría que hacer es desactivar antes de la actualización todos los módulos no nativos de Prestashop, cambiar al tema por defecto y luego realizar la actualización. Y una vez finalizada esta, seguir con el tema por defecto o buscar uno compatible con las versiones 1.7 y lo mismo con los módulos, buscar versiones actualizadas para PS 1.7.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More