Jump to content

Recommended Posts

Bonjour,

Mon site actuel utilise la version 1.4 de Prestashop et je souhaite passer à la version 1.7.

Deux éléments à savoir : 1. il s'agit d'une boutique de e-commerce sur laquelle des ventes sont réalisées tous les jours donc je ne souhaite pas de coupure d'activité, et 2. le site a été réalisé il y a déjà plusieurs années, donc la plupart des modules ne sont pas compatibles avec la nouvelle version de Prestashop, et la partie visuelle avait demandé beaucoup de personnalisation (codage spécifique).

Ma première réaction a été de télécharger la version 1.7.6 en local et de créer un nouveau site en partant de zéro avec migration des données clients/commandes/etc via un module de migration. De cette façon, le site actuel tourne toujours, et je peux prendre mon temps pour créer un nouveau site aux normes. Le problème est que, comme le site est en local actuellement, la migration des données est impossible - plusieurs dizaines de milliers d'éléments sont concernés, et la migration de 100 éléments prend déjà toute une journée...

Ma question est donc la suivante : y a-t-il un autre moyen pour passer à la version 1.7 et migrer toutes les infos voulues tout en gardant mon site actuel actif ? Si oui, comment faire ?

Merci d'avance pour votre aide !

 

Share this post


Link to post
Share on other sites

Bonjour, ceci est bien partie.

Pourquoi ne pas tout simplement créer un sous domaine.
dev.tonsite, tu y met donc la version 1.7.6 puis tu fait ta migration avec bien sur le module de migration pro.

Puis tu fini ta configuration et le tour est jouer.

Cordialement.

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

 

Une simple exportation de ta base de données complète du site en production depuis la console PHPadmin de ton hébergeur (en format zip, c'est plus simple) est rapide, puis importer cette sauvegarde dans ta nouvelle base de données sur ton serveur SQL de développement pour voir les compatibilités et faire les upgrades nécessaires, pour les fichiers Prestashop, une copie de tes fichiers du serveur d'hébergement sur ton ordinateur en FTP ou SFTP vers ton site est simple, bien qu'un peu long, puis éditer le fichier config.php pour changer l'accès à la base de données et editer SQL pour changer le nom de domaine en localhost.


C'est plus simple à faire depuis la version Prestashop 1.6.24 vers 1.7.x il me semble.
Peut-être commencer par migrer sur cette version 1.6.24 avant de passer à 1.7.x si le template le permet, ou passer sur le template par default ???
Ne pas oublier de passer en PHP 7.1 mais de préférence 7.2 ou 7.3 sur le serveur de développement une fois migré à la version 1.6 ou 1.7.x, pour voir si le Template et les modules sont bien à jour et compatibles.

Gilles


 

Edited by gillesvt (see edit history)

Share this post


Link to post
Share on other sites

@Esh-Network : Merci pour votre réponse ! Cela me semble en effet une solution simple et rapide. J'ai donc créé un sous-domaine et ai installé la dernière de Prestashop via mon hébergeur. Malheureusement, je suis face à un nouveau problème. En effet, la version de Prestashop de mon ancien site fonctionne en PHP 5.4, or pour installer la dernière version de Prestashop, il me faut la version 5.6 au minimum et je n'ose pas effectuer le changement de PHP sous peine de faire "bugger" mon ancien site. Comment puis-je faire ?

 

On 8/19/2019 at 5:46 PM, Esh-Network said:

Bonjour, ceci est bien partie.

Pourquoi ne pas tout simplement créer un sous domaine.
dev.tonsite, tu y met donc la version 1.7.6 puis tu fait ta migration avec bien sur le module de migration pro.

Puis tu fini ta configuration et le tour est jouer.

Cordialement.

 

Share this post


Link to post
Share on other sites
On 8/24/2019 at 3:58 PM, gillesvt said:

Bonjour,

 

Une simple exportation de ta base de données complète du site en production depuis la console PHPadmin de ton hébergeur (en format zip, c'est plus simple) est rapide, puis importer cette sauvegarde dans ta nouvelle base de données sur ton serveur SQL de développement pour voir les compatibilités et faire les upgrades nécessaires, pour les fichiers Prestashop, une copie de tes fichiers du serveur d'hébergement sur ton ordinateur en FTP ou SFTP vers ton site est simple, bien qu'un peu long, puis éditer le fichier config.php pour changer l'accès à la base de données et editer SQL pour changer le nom de domaine en localhost.


C'est plus simple à faire depuis la version Prestashop 1.6.24 vers 1.7.x il me semble.
Peut-être commencer par migrer sur cette version 1.6.24 avant de passer à 1.7.x si le template le permet, ou passer sur le template par default ???
Ne pas oublier de passer en PHP 7.1 mais de préférence 7.2 ou 7.3 sur le serveur de développement une fois migré à la version 1.6 ou 1.7.x, pour voir si le Template et les modules sont bien à jour et compatibles.

Gilles


 

Bonjour Gilles et merci pour votre réponse !

Je ne sais pas exactement si un template a été utilisé car j'avais demandé un visuel très spécifique... aussi cela me paraît compliqué de passer à la 1.6.24 sans changer mon site actuel (mon ancienne agence web l'a fortement déconseillé). J'ai essayé la première solution donnée, mais je rencontre un nouveau problème, de PHP cette fois. 

Share this post


Link to post
Share on other sites

Bonjour, tu peu sans soucis passer en php7.1. 

La 1.6.1.24 l’a support très bien. Est dû coup la 1.7.6.0 fonctionnera aussi. ;) 

 

il se peu que quelques changement à faire au niveau de pho sois nécessaire genre le Max exécution Time 

est d autres mais rien de compliquer à faire.

Share this post


Link to post
Share on other sites
1 hour ago, Esh-Network said:

Bonjour, tu peu sans soucis passer en php7.1. 

La 1.6.1.24 l’a support très bien. Est dû coup la 1.7.6.0 fonctionnera aussi. ;) 

 

il se peu que quelques changement à faire au niveau de pho sois nécessaire genre le Max exécution Time 

est d autres mais rien de compliquer à faire.

En fait, c'est la version 1.4 de mon site actuel qui me pose problème. C'est-à-dire que lorsque je vais changer la version du PHP, cela va affecter également mon site actuel, à moins que je me trompe ? Est-que je peux passer en PHP 5.6 avec une version de prestashop aussi vieille que la 1.4.4.0 ? J'ai peur que ça fasse bugger mon site actuel, et comme je l'énonçais dans mon premier message, j'ai besoin que celui-ci reste opérationnel.

Share this post


Link to post
Share on other sites

De toutes façon le module prend juste les informations en base de données donc même si ton site bug le temps de transférer les donnés pas grave. 

 

Une fois les données transférer tu passe ton site en dev direct en prod puis tu met la maintenance le temps de finir la configuration. 

Share this post


Link to post
Share on other sites
Posted (edited)
Le 25/08/2019 à 9:44 PM, pomme47 a dit :

En fait, c'est la version 1.4 de mon site actuel qui me pose problème. C'est-à-dire que lorsque je vais changer la version du PHP, cela va affecter également mon site actuel, à moins que je me trompe ? Est-que je peux passer en PHP 5.6 avec une version de prestashop aussi vieille que la 1.4.4.0 ? J'ai peur que ça fasse bugger mon site actuel, et comme je l'énonçais dans mon premier message, j'ai besoin que celui-ci reste opérationnel.

Bonjour,

 

Tu peux rester en php 5.6 pour faire les upgrades Prestashop puis extensions (des fois faire les upgrade d'extensions posent problème si tu les fais avant la bonne version Prestashop. Une fois tous les upgrades réalisés, tu peux tenter le PHP 7.1 à 7.3 suivant ton hébergeur.

Si tu es sur OVH, tu peux utiliser plusieurs versions de php pour différents sites, il suffit de télécharger le fichier .ovhconfig à la racine de l'hébergement et le recopier dans le dossier racine de ton nouveau site, puis tu modifies en éditant la deuxième ligne qui concerne la version PHP 5.6, 7.O à 7.3 que tu souhaites utiliser.

Ça se présente sous un fichier texte UTF_8, comme ci-dessous, firewall est une option de OVH qui peut aussi être activé ou désactivé sur chaque site si le firewall est bien sûr activé sur l'hébergement et les domaines :

app.engine=php
app.engine.version=7.3
http.firewall=security
environment=production
container.image=stable

Sinon, tu peux utiliser l'application server MAMP ou sa version Windows, et développer en local, pour les tests... C'est plus sûr que de toucher à la configuration serveur, il suffira une fois que ton upgrade est ok avec 1.7.x et PHP 7.x de transférer une copie de ton ancien site dans un nouveau répertoire en sous domaine, et créer une nouvelle base de données pour répéter la façon dont tu as pu faire tes upgrades. Il faut éditer le fichier .ovhconfig pour mettre les paramètres à jour. Et éditer la base de données pour modifier le nom de domaine en sous domaine.
Tant qu'à faire, si ton site ne l'est pas encore, il faut le passer en https plutôt qu'HTTP, c'est sur Prestashop que tu peux le faire, après avoir validé ton nom de domaine es SSL activé.
Si il y a des erreurs de sécurité à l'affichage du site, c'est en général des liens internes vers des images qu'il faut modifier, et si ils y a des images importées par liens depuis d'autres sites, le mieux est de les mettre en interne si le domaine pointé n'est pas HTTPS.
Pour la base SQL, le mieux est de créer une nouvelle base de données dans laquelle tu importes celle en production, et de mettre le site principal en maintenance, le temps de faire les upgrades sites et SQL, si tu ne veux pas perdre de données récentes.

 

Bon courage,


Gilles

 

Edited by gillesvt (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More