Jump to content
nobilis

Mise à jour Stripe (Mettez à jour votre intégration)

Recommended Posts

Bonjour,

J'utilise Stripe sans problème depuis 2 ans sur mon Prestashop 1.6.0.14.

Stripe demande maintenant de mettre à jour mon intégration pour être aux normes pour se préparer à la SCA (protection du client).

Que faut-il faire concrètement ?

Merci

Share this post


Link to post
Share on other sites
Posted (edited)

I changed this yesterday - and with the new version : 2.0.3 and receiving lots of errors in the Stripe dashboard, and some orders where the order amount does not equal the payment amount!

Citation

 J'ai changé cela hier - et avec la nouvelle version : 2.0.3 et la réception de nombreuses erreurs dans le tableau de bord Stripe, et certaines commandes dont le montant de la commande n'est pas égal au montant du paiement !

 

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Disabled, deleted the new version

Installed the old version from a backup - this is working OK

Citation

Désactivé, suppression de la nouvelle version

J'ai installé l'ancienne version à partir d'une sauvegarde - cela fonctionne bien.

 

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks Andrew for your reply !

Wich version and how/where download it ?

Best regards

Citation

 Merci Andrew pour votre réponse !

Quelle version et comment la télécharger ?

Meilleures salutations

 

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

I went back to version: 1.5.2 - which I had on a backup

I also just got a new message from the developers:

 

Quote:

"Good morning,

 

You have to install the version 2.0.3 of the module that should solve the problem.

 

The procedure to follow in the order is:

- Uninstall the current version of Stripe

- Empty the Prestashop cache

- Install the new module

 

Keep me updated.

 

Best regards,

 

Francesco - 202 ecommerce"

Though I am a bit afraid to try - as last time I think it cost us around £500 in sales

Citation

 Je suis retourné à la version : 1.5.2 - que j'avais sur une sauvegarde

Je viens aussi de recevoir un nouveau message des développeurs :

 

Citation :

"Bonjour. Bonjour,

 

Vous devez installer la version 2.0.3 du module qui devrait résoudre le problème.

 

La procédure à suivre dans l'ordre est :

- Désinstaller la version actuelle de Stripe

- Vider le cache de Prestashop

- Installer le nouveau module

 

Tenez-moi au courant.

 

Meilleures salutations,

 

Francesco - 202 ecommerce"

Bien que j'ai un peu peur d'essayer - comme la dernière fois, je pense que cela nous a coûté environ £500 en ventes.

 

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites

I tried of course that and no, it does not work! 202ecommerce is always the same, it is they who make the module it seems to me!

Can you share your old  version?

In the meantime, I installed Paypal Braintree, but the commissions are more expensive ...

Best regards

Share this post


Link to post
Share on other sites

Good luck - I hope it works OK for you 

As I said - I had to completely uninstall and delete the broken version

I tried just renaming the broken one and installing this, but that didn't work

Then I had to re-setup the API keys

Share this post


Link to post
Share on other sites

Ils vont se calmer les anglophones a venir polluer le forum français et avec un contenu hors-topic ?

 

Share this post


Link to post
Share on other sites
Posted (edited)

La question de ce topic est:

Stripe demande maintenant de mettre à jour mon intégration pour être aux normes pour se préparer à la SCA (protection du client). Que dois-je faire ?

La réponse:

rien

 

Un gus qui a un autre problème comme celui d'un problème de mise à jour doit s'ouvrir son propre topic. C'est la base des règles du forum. De plus si le forum est divisé en langue c'est pour que cela aussi soit respecté. Lub każdy używa wybranego przez siebie języka i wszystko stanie się znacznie bardziej skomplikowane.

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Citation

1 topic = 1 sujet de conversation
- Si vous avez plus d’une question, créez plus d’un sujet !
- Ne posez pas votre question dans un topic qui ne traite pas exactement le même sujet. Ouvrez un nouveau topic, c’est fait pour ça !

Citation

Respecter la langue du forum
PrestaShop regroupant des communautés du monde entier, les forums sont divisés par langues.
Merci de poster dans un forum dans la langue qui lui correspond. 

 

Share this post


Link to post
Share on other sites

Bonjour,

Vous confirmer donc qu'il ne faut pas mettre à jour le module ou prendre la version payante Stripe Paiement Pro (SCA Ready) ou faire une autre action ?

Voici le message que j'ai reçu de Stripe À compter du 14 septembre, conformément à une nouvelle directive, l'ensemble de l'industrie devra respecter les exigences d'authentification forte du client (SCA) pour de nombreux paiements en Europe. Les paiements effectués sans authentification à deux facteurs pourront être refusés par les banques de vos clients.

J'ai actuellement la dernière version du Module Stripe Officiel.

Merci pour votre aide.

Share this post


Link to post
Share on other sites

@Mathy tu es en Ps 1.7.x ?

Car moi qui suis en 1.6, le mail est légèrement différent:

Citation

Bonjour,

À compter du 14 septembre, conformément à une nouvelle directive, l'ensemble de l'industrie devra respecter les exigences d'authentification forte du client (SCA) pour de nombreux paiements en Europe. Les paiements effectués sans authentification à deux facteurs pourront être refusés par les banques de vos clients.

Les informations dont nous disposons indiquent que vous utilisez actuellement PrestaShop pour accepter des paiements avec Stripe. PrestaShop a lancé une mise à jour pour se préparer à la SCA. Pour éviter une hausse des refus de paiement, vous devrez mettre à jour l'ancienne version de PrestaShop avant le 14 septembre.

De quelle mise à jour s'agit-il ? Passer en 1.7 ?

Share this post


Link to post
Share on other sites

Je parle d'une mise à jour de stripe pas de Prestashop. Pour stripe j'ai le module Module Stripe officiel v2.0.3.

Share this post


Link to post
Share on other sites

Bonjour,

Je vous confirme que la seule chose à faire pour être compatible SCA est de mettre le module Stripe à jour dans sa dernière version, actuellement 2.0.3 sur AddOn. 

La version 2.0.4 du module est disponible sur demande au support officiel Stripe en attendant sa sortie officielle sur AddOn.
Elle règle les remarques et retours faites dans ce fil.

Vous pouvez l'obtenir via une demande au support : https://addons.prestashop.com/fr/contactez-nous?id_product=24922

Cette version apporte entre autres des bugfix et la compatibilité avec IE11.

L'équipe support est disponible afin de vous apporter son aide en cas de problème avec le nouveau module.

Bonne journée !

Share this post


Link to post
Share on other sites

Attention la version 2.0.3 requiert IMPERATIVEMENT php5.6 et supérieur.

La définition des constantes PRIMARY_KEY_FIELD et KEY_FIELD ne permet pas de tableau avant les 5.6 https://www.php.net/manual/en/language.constants.syntax.php (only scalar)

Il est néanmoins facile de convertir celles-ci en public static variable et d'ajuster stripe_official/vendor/totpsclasslib/src/Db/DbTableDefinitionModel.php et stripe_official/vendor/totpsclasslib/src/Db/DbTableDefinitionRelation.php en conséquence;

La 2.0.4 présentera sûrement le même soucis pour les installs legacy

  • Like 1

Share this post


Link to post
Share on other sites

Merci bcp pour votre réponse.

Très bonne journée.

Share this post


Link to post
Share on other sites

Bonjour,

Je confirme la remarque de doekia, la nouvelle version du module Stripe requiert une version PHP 5.6 ou supérieure.
Vous pouvez prendre connaissance de la version PHP de votre serveur dans votre back office de PrestaShop.

Share this post


Link to post
Share on other sites
19 hours ago, Mediacom87 said:

Bonjour,

 

 

desole .....

Share this post


Link to post
Share on other sites

@202 ecommerce bonjour,

Si on dispose de la dernière version officielle (2.0.3), pourquoi reçoit-on des mails de Stripe nous demandant de mettre à jour ?

"Action requise : mettez à jour votre intégration de PrestaShop avec Stripe pour éviter les refus de paiement"

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 3 heures, 202ecommerce a dit :

Bonjour,

Je confirme la remarque de doekia, la nouvelle version du module Stripe requiert une version PHP 5.6 ou supérieure.
Vous pouvez prendre connaissance de la version PHP de votre serveur dans votre back office de PrestaShop.

Peut-être envisager de modifier le code pour qu'il soit 5.3 compatible - il n'y a que 6 lignes à changer, c'est mineur et ça permettrait de couvrir quasi toutes les versions dans tous les univers dédiés/vps possible ?

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Bonjour doekia,
Nous allons prendre en compte votre suggestion et l'étudier.
Merci !

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour 202ecommerce,

Je suis un ancien client de chez vous, j'ai mis à jour stripe pour des raisons de SCA

Depuis ça ne fonctionne plus: côté client apparaît seulement un bouton non cliquable " acheter maintenant"

Côté dashboard, il ne s'affiche rien du tout aucun historique...

(voir les copies d’écrans ci-jointes)

Je suis en prestashop 1.6.1.6
PHP: 5.6.40-0+deb8u5
MySQL 5.6.45-86.1-log

J'ai essayé plusieurs fois de désinstaller, vider le cache + forcer la compilation à chaque appel.... En vain, ça ne fonctionne toujours pas.

Je voudrais retourner sur la version antérieure de stripe, mais je ne la trouve pas.

Pourriez-vous me communiquer l'ancienne version du module stripe pour Prestashop ? Le temps de trouver une solution à ce problème.

Merci

1.jpg

2.jpg

Edited by n-r-j-c-a-r (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)
Le 22/08/2019 à 1:34 PM, andrew a dit :

Good luck - I hope it works OK for you 

As I said - I had to completely uninstall and delete the broken version

I tried just renaming the broken one and installing this, but that didn't work

Then I had to re-setup the API keys

 J'ai cherché d'autres personnes qui ont des problèmes similaires aux miens, on dirait que je vous ai tous trouvés !! Malheureusement, il y a eu des transactions où les frais d'affranchissement ont été surfacturés, sous-facturés et pas du tout facturés pour l'affranchissement.   Le développeur, bien que rapide à répondre, n'a malheureusement pas réussi à résoudre le problème pour nous non plus, donc nous n'avons pas eu d'autre choix que de désactiver le mod car il faudrait littéralement une grosse commande de l'étranger pour paralyser notre profit si le port n'était pas chargé mais depuis, j'ai trouvé ce thread et installé votre ancien mod, aucune idée du résultat mais ça doit être mieux que ce qui se passe.   Merci d'avoir partagé ce vieux fichier et j'espère qu'il sera corrigé bientôt :)

Marko

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 12 heures, ThankBooks a dit :

 Unfortunately, we've had transactions overcharging, undercharging, and not charging at all for postage.  

 Ceci, j'ai eaxact mêmes problèmes prestashop 1.6

J'ai essayé la version alpha 2.04 mais j'ai toujours exactement le même problème. J'ai désinstallé, effacé le cache réinstallé en 2.04 et j'ai toujours de gros problèmes.

Le problème, c'est que cela rend mes clients nerveux et qu'ils paient de nouveau le deuxième paiement est également facturé, mais je dois alors rembourser et je suis facturé par bande pour les deux transactions.

s'il vous plaît, réparez

Demain, je reviens en arrière 

 

 

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 11 heures, isdngirl a dit :

This, I'm having eaxact same issues prestashop 1.6

I tried the alpha 2.04 but still exactly exact same issue. I uninstalled, cleared cache reinstalled 2.04 and still having massive problems.

The problem is it makes my customers nervous and they pay the price of the transaction.

please fix

tomorrow i roll back 

 

 

 Nous avons installé l'ancienne version fournie par Andrew et j'ai fait un achat test qui n'a pas posé de problème.   Je ne sais pas si c'est par défaut non plus, mais nous avons aussi remarqué beaucoup de transactions incomplètes depuis la dernière mise à jour, et en lisant un peu plus, il semble que le module/stripe va maintenant "pré-cache" les informations du panier, que la transaction soit payée par bande ou non et génère un enregistrement dans le tableau de bord des bandes, alors si le client finit par payer par une méthode différente, l'enregistrement dans le tableau de bord devient "incomplet", ce qui est un peu un cauchemar parce que maintenant il semble que nous avons manqué beaucoup de transactions mais comme je le dis je pense que c'est le nouveau module qui "cache" simplement les informations du panier, mais cela m'inquiète légèrement par rapport à quoi que ce soit concernant les paiements "en cache" ou enregistrés avant même l'intention de payer par bande est établie.

J'espère que les gars auront une dose bientôt.

Edited by Mediacom87
Traduction pour respecter la langue du forum. (see edit history)

Share this post


Link to post
Share on other sites

Juste pour prévenir, tout nouveau post en anglais sera simplement effacé.

Je ne vais pas m'amuser à tout traduire à la place des gens.

Merci de respecter les règles du forum.

 

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Mediacom87 said:

Juste pour prévenir, tout nouveau post en anglais sera simplement effacé.

Je ne vais pas m'amuser à tout traduire à la place des gens.

Merci de respecter les règles du forum.

 

 

très désolé je n'ai pas réalisé la chose langue de forum

Share this post


Link to post
Share on other sites
On 8/23/2019 at 10:07 AM, doekia said:

Attention la version 2.0.3 requiert IMPERATIVEMENT php5.6 et supérieur.

La définition des constantes PRIMARY_KEY_FIELD et KEY_FIELD ne permet pas de tableau avant les 5.6 https://www.php.net/manual/en/language.constants.syntax.php (only scalar)

Il est néanmoins facile de convertir celles-ci en public static variable et d'ajuster stripe_official/vendor/totpsclasslib/src/Db/DbTableDefinitionModel.php et stripe_official/vendor/totpsclasslib/src/Db/DbTableDefinitionRelation.php en conséquence;

La 2.0.4 présentera sûrement le même soucis pour les installs legacy

Bonjour @doekia

J'ai la version prestashop 1.7.1.1 avec le module stripe (je ne connais pas la version que j'ai installé et n'arrive pas à trouver l'info sur le dashboard).

Je n'ai pas encore fait le changement de version Stripe et je me pose la question de savoir si on doit ne rien faire (comme cela a été dit plus haut dans le post) ou s'il faut effectivement mettre à jour. Et dans ce cas, faut-il supprimer mon module stripe pour le remplacer par le module "stripe prestashop SCA-ready" ??


si oui, pourriez vous m'expliquer ce qui doit exactement être modifié si l'on décide de changer de version stripe pour régler le problème de migration dû aux SCA ??
Je ne suis pas très au fait de l'informatique et sur votre réponse concernant les php5.6, je ne comprends rien du tout (je ne sais pas à quoi cela correspond).
Pourriez vous me dire quelles sont les étapes et les modifications à apporter ? Pourriez vous me les décrire ?
Merci, cordialement,

Jude


 

Share this post


Link to post
Share on other sites

Bonjour 

 

Petit probleme avec la nouvelle version que je teste actuellement 

(2.0.4)

 

Le principal bug rencontré est le suivant : 

- en affichage mobile,  lorsque je met les informations de carte et quand je passe d'un champ a un autre ( numero, date, cryptogramme), l'affichage remonte vers le haut .... 

ce qui fait que je suis obliger de "scroll down" pour voir à nouveau le module de stripe et continuer a écrire les informations. 

Comment faire pour ne pas avoir ce probleme et rester à la meme hauteur lors de toutes les saisies d'informations?? 

Quelqu'un a t il aussi ce souci ? 

Mon prestashop : 1.6.1.18

Version du module stripe (2.0.4)

 

 

Sinon en general, je recommande egalement : supprimer tous les modules stripe sur votre boutique et procéder à l'installation du nouveau module sinon bug...

 

Share this post


Link to post
Share on other sites
On 23/08/2019 at 08:47, 202ecommerce said:

Bonjour,

Je vous confirme que la seule chose à faire pour être compatible SCA est de mettre le module Stripe à jour dans sa dernière version, actuellement 2.0.3 sur AddOn. 

La version 2.0.4 du module est disponible sur demande au support officiel Stripe en attendant sa sortie officielle sur AddOn.
Elle règle les remarques et retours faites dans ce fil.

Vous pouvez l'obtenir via une demande au support : https://addons.prestashop.com/fr/contactez-nous?id_product=24922

Cette version apporte entre autres des bugfix et la compatibilité avec IE11.

L'équipe support est disponible afin de vous apporter son aide en cas de problème avec le nouveau module.

Bonne journée !

Quelqu'un peut-il confirmer que ce module devrait fonctionner comme prévu ou existe-t-il encore des problèmes, nous avons essayé d'installer la nouvelle version plusieurs fois et nous ne pouvons même plus obtenir les numéros d'API à enregistrer, plutôt que de continuer à envoyer des tickets de support technique Mieux vaut demander aux développeurs de commenter ici pour que tous les problèmes soient informés, mais si vous dites que le module fonctionne comme prévu, nous devrons vous contacter via le support.
Merci

Share this post


Link to post
Share on other sites

Si le support de Stripe peut confirmer cette solution à savoir 

Rester sur le module 1.5 et modifier la limite de 3D secure dans le code pour le passer à 30€

 

dans stripe_official.php a la ligne 1000-1001, abaissez la valeur à 30 pour le passage à 3D secure sur la transaction

 

if (!$secure_mode_all && $amount >= 30) { $secure_mode_all = 1; }

Share this post


Link to post
Share on other sites
On 8/17/2019 at 11:53 AM, nobilis said:

Bonjour,

J'utilise Stripe sans problème depuis 2 ans sur mon Prestashop 1.6.0.14.

Stripe demande maintenant de mettre à jour mon intégration pour être aux normes pour se préparer à la SCA (protection du client).

Que faut-il faire concrètement ?

Merci

Bonjour avez vous eu de réponse exacte ? Car je ne sais pas si il faut mettre le module stripe a jour ou prestashop à jour.

Share this post


Link to post
Share on other sites
On 8/28/2019 at 8:41 AM, AmicaSoap said:

 Nous avons installé l'ancienne version fournie par Andrew et j'ai fait un achat test qui n'a pas posé de problème.   Je ne sais pas si c'est par défaut non plus, mais nous avons aussi remarqué beaucoup de transactions incomplètes depuis la dernière mise à jour, et en lisant un peu plus, il semble que le module/stripe va maintenant "pré-cache" les informations du panier, que la transaction soit payée par bande ou non et génère un enregistrement dans le tableau de bord des bandes, alors si le client finit par payer par une méthode différente, l'enregistrement dans le tableau de bord devient "incomplet", ce qui est un peu un cauchemar parce que maintenant il semble que nous avons manqué beaucoup de transactions mais comme je le dis je pense que c'est le nouveau module qui "cache" simplement les informations du panier, mais cela m'inquiète légèrement par rapport à quoi que ce soit concernant les paiements "en cache" ou enregistrés avant même l'intention de payer par bande est établie.

J'espère que les gars auront une dose bientôt.

Bonjour AmicaSoap, 

J'ai exactement le même souci survenu depuis le 23 Juin. J'ai au moins 90 paiements en incomplet et je ne sais pas quoi en pensé. 
La version de mon presta est en 1.6.21 et en php 7

Aujourd'hui je ne sais pas si un client a appuyer sur le bouton acheter et que je l'ai perdu ou alors autre chose. 
Pas d'erreur remonté, pas de logs, rien.... 

Super compliqué et j'arrive à avoir personne. 

Bon courage à tous

Share this post


Link to post
Share on other sites

Cela pourrait valoir la peine, traduit merci de lire - Merci pour vos commentaires Amica Soap, assurez-vous de répondre à tous les clients qui nous parviennent via le formulaire d'assistance:

https://addons.prestashop.com/en/contact-us?id_product=24922&_ga=2.81736023.1734990164.1568289431-1728332132.1568289431

3 minutes ago, 202ecommerce said:

 

Thanks for your feedback AmicaSoap, please be sure that we're answering every customer reaching us through the support form :
https://addons.prestashop.com/en/contact-us?id_product=24922

We're very disapointed that we weren't able to help you with your issue.

Please be assure that if you send the id of your support topic, we'll be happy to help you.

Share this post


Link to post
Share on other sites
4 minutes ago, AmicaSoap said:

Cela pourrait valoir la peine, traduit merci de lire - Merci pour vos commentaires Amica Soap, assurez-vous de répondre à tous les clients qui nous parviennent via le formulaire d'assistance:

https://addons.prestashop.com/en/contact-us?id_product=24922&_ga=2.81736023.1734990164.1568289431-1728332132.1568289431

Merci mais je n'ai pas accès à votre page contact qui est géré par votre compte.
Pourriez vous me faire un ScrenShot ?

Merci de votre retour. 

Share this post


Link to post
Share on other sites

Ah, désolé, je ne savais pas que cela ferait cela, en gros le développeur a expliqué que si quelqu'un avec ces problèmes peut le contacter via le support du module, il sera ravi de vous aider, mais malheureusement, il lui a fallu un certain temps pour arriver à cela. Le point ayant précédemment expliqué que le module semblait bien fonctionner depuis le milieu du mois dernier, mais ceux d'entre nous qui ont encore des problèmes ont expliqué que le module ne fonctionnait toujours pas. Si vous trouvez le module dans la section de téléchargement, contactez le développeur à travers lequel ils ont promis de travailler à travers chaque numéro :)

... et des excuses pour mon français, je suis écossais avec Google Translate :)

Edited by AmicaSoap (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

Le module Stripe dans sa version antérieure a effectivement rencontré un problème de paiements incomplets remontant dans le dashboard Stripe. Cependant, il ne s'agissait pas de paiements abandonnés, un paiement était correctement passé.

Le module Stripe dans sa dernière version, 2.0.4 est stable :
https://addons.prestashop.com/fr/paiement-carte-wallet/24922-stripe-officiel-sca-ready.html

Les seuls signalements qui nous parviennent encore sont des tickets relatifs à des configurations de PrestaShop spécifiques.
En cas de difficulté, je vous invite à contacter directement notre support, qui vous répond rapidement :
https://addons.prestashop.com/fr/contactez-nous?id_product=24922

Bonne journée

Share this post


Link to post
Share on other sites

bonjour 

dans le processus de traitement du paiement, il est toujours écrit en anglais "processing"... 

Cela serait pas mal si ca serait écrit en francais... comment le modifier? Je crains que ca ne soit le module en lui meme qui ne peut que le faire, 

si vous avez la solution merci de me l'indiquer 

 

bien cordialement 

 

Share this post


Link to post
Share on other sites

Bonjour 

j'ai mis a jour le module et il y a bien toujours le probleme de charges supplementaires... ma configuration de prestashop est 100% normale ; je pense que vous n'avez pas resolu le probleme soulevé par les utilisateurs du forum.. 

 

Merci de nous indiquer la marche à suivre 

cordialement

Share this post


Link to post
Share on other sites

Prestashop 1.6.1.7

J'ai fait la mise à jour mais l'affichage du paiement est... plus qu'incomplet.
En revenant à l'ancienne version c'est plus complet... mais inutilisable !

Une idée pour corriger ça ?
Merci d'avance,

stripe-1-5-2.jpg

stripe-2-0-4.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More