Jump to content

The page isn’t redirecting properly - 1.7.6


Recommended Posts

(SOLVED)
Hello
I have installed prestashop 1.7.6.0 and deleted the install folder. Backend works fine, but frontend ends up with error "The page isn’t redirecting properly"...?
Thanx for help.
Lukas

Edited by Lukas Truninger
Solved; found the bug in the automatic installation (see edit history)

Share this post


Link to post
Share on other sites
  • 5 months later...
On 8/17/2019 at 1:55 PM, Lukas Truninger said:

(SOLVED)
Hello
I have installed prestashop 1.7.6.0 and deleted the install folder. Backend works fine, but frontend ends up with error "The page isn’t redirecting properly"...?
Thanx for help.
Lukas

  how to solved?? i have the same problem

Share this post


Link to post
Share on other sites
  • 3 weeks later...

Check the configuration of your web server, especially if you have configured the domain where PrestaShop resides to redirect all the HTTP requests to HTTPS. The part of the url that is being redirected on your web server probably matches the "Shop domain" value in the "SEO and URLs" section of the Prestashop´s Back Office.

If this is your case, you should enable the "Enable SSL" and "Enable SSL on all pages" options in "Preferences - Settings - General" section of the PrestaShop´s Back Office for the redirect loop to end.

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...
On 2/25/2020 at 6:31 AM, amorrua said:

Check the configuration of your web server, especially if you have configured the domain where PrestaShop resides to redirect all the HTTP requests to HTTPS. The part of the url that is being redirected on your web server probably matches the "Shop domain" value in the "SEO and URLs" section of the Prestashop´s Back Office.

If this is your case, you should enable the "Enable SSL" and "Enable SSL on all pages" options in "Preferences - Settings - General" section of the PrestaShop´s Back Office for the redirect loop to end.

I could kiss you for this. I have just had the same problem, and getting in to the admin panel (which was awkward to find as I didn't realise it was admin92n93hc or whatever - I was expecting it to be /admin or /administration and /login didn't work) and changing the SSL settings fixed it.

However when I loaded the admin panel, the Onboarding "menu" in the bottom right was in the way of the preferences settings. The continue and dismiss buttons would not work. Thankfully, I remembered I can delete stuff with Inspect Element. So I inspected the box and deleted it, and could reveal the hidden two configuration options. I could the change the setting.

The front end immediately began working, and clicking both buttons on the bottom left onboarding "menu" also functioned normally.

However it begs the question, why is this not more intitive? I've used a LOT of scripts in my time. Forum scripts, content management, ecommerce, contact form creation, among others, and not a single one has caused problems like this, with practically all working regardless of http or https, and most are able to detect when I installed the very script using a https:// installation link. I am surprised this process was not automatic, and was not a selectable option on installation. I have tried CS Cart and Open Cart alongside this script and neither of those had problems either.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 7 months later...
On 2/25/2020 at 6:31 AM, amorrua said:

Check the configuration of your web server, especially if you have configured the domain where PrestaShop resides to redirect all the HTTP requests to HTTPS. The part of the url that is being redirected on your web server probably matches the "Shop domain" value in the "SEO and URLs" section of the Prestashop´s Back Office.

If this is your case, you should enable the "Enable SSL" and "Enable SSL on all pages" options in "Preferences - Settings - General" section of the PrestaShop´s Back Office for the redirect loop to end.

Saved my day, thank you 😊

Share this post


Link to post
Share on other sites

Just for a curiosity - is there any way to change this setting somewhere in the files on server, since my back office is not working (may be this is the reason my back office is not working as well as some part of the front office).

Share this post


Link to post
Share on other sites
Posted (edited)

@HETPE3B, try updating the field "value" from 0 to 1 of the rows which "name" fields are "PS_SSL_ENABLED" and "PS_SSL_ENABLED_EVERYWHERE" on the table named "ps_configuration" from the Prestashop database.

Izengabea.png

Edited by amorrua (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More