Jump to content
penge17

Store Manager

Recommended Posts

Hi!

Használja valaki a Store Manager for Prestashop nevű progit?

https://www.prestashopmanager.com/

Véleményekre lennék kíváncsi, megéri e megvásárolni. Kb. 8000 terméket kellene frisíteni, stb. ahol jól jönnének a progi tulajdonságai. CSV import stb.

Share this post


Link to post
Share on other sites

Az egyik legjobb program amit a Ps-hez írtak. Annyi, hogy az ára nekünk magyaroknak meglehetősen borsos.

Érdemes kigondolni, hogy mit akarsz csinálni és telepíteni a 14 napos tesztidőszakot - azon belül megalkotni és kész.

Vagy rendszeres használatra kellene?

Share this post


Link to post
Share on other sites

Szia!

Köszi a választ! Én is azt gondoltam hogy kipróbálom a 14 napost. Sajnos az iFast.net szolgáltató tegnap éjjel megállt, így az oldal is.

Több 1000 terméket kell managelni csv és xml fileokból, kombinációk stb. Eddig úgy oldottam meg hogy megvásároltuk a "No more 500' nevű modult,

amivel nagyon szépen tudtam csv-t importálni anélkül hogy a server eldobta volna. De sajnos egy adag beimportálása után sok bélyegkép hiányzott, amit annak tudok be

hogy a szerver nem tudta elég gyorsan legenerálni a képeket. Remélem hétfőre ismét megy a szolgáltató és le tudom tesztelni.

Share this post


Link to post
Share on other sites

Bélyegkép? Az adminban a termékek felsorolásánál?

Sok sikert egyébként a Store manager-hez, szerintem szuper program.

Share this post


Link to post
Share on other sites

Bocs hogy ide írok, egy újabb hibába ütköztem.

Új terméket adok hozzá, és berakja 4294967295 ID szám alá. Az előtte lévő termék IDje: 74134184

Újabb termék hozzáadásánál pedig ezt a hiba üzenetet kapom a debuggal:

Duplicate entry '4294967295' for key 'PRIMARY'

INSERT INTO `ps_product_shop` (`id_product`, `id_category_default`, `id_tax_rules_group`, `on_sale`, `online_only`, `ecotax`, `minimal_quantity`, `price`, `wholesale_price`, `unity`, `unit_price_ratio`, `additional_shipping_cost`, `customizable`, `text_fields`, `uploadable_files`, `active`, `redirect_type`, `id_product_redirected`, `available_for_order`, `available_date`, `condition`, `show_price`, `indexed`, `visibility`, `cache_default_attribute`, `advanced_stock_management`, `date_add`, `date_upd`, `pack_stock_type`, `id_shop`) VALUES ('4294967295', '2', '1', '0', '0', '0', '1', '0', '0', '', '0', '0', '0', '0', '0', '1', '404', '0', '1', '0000-00-00', 'new', '1', '0', 'both', '0', '0', '2019-08-11 23:56:49', '2019-08-11 23:56:49', '3', '1')

Nem értem miért nem folytatja a következő ID-vel.

 

Share this post


Link to post
Share on other sites

Hát ezt elég nehéz megmondani látatlanban. Nem tudom hogyan töltöd be, még igazából azt sem hogy milyen ps verziót használsz.

Még akkor is nehéz lenne ha látnám :)

Én annyit látok, hogy a 4294967295 szám az INT kétszerese.

Share this post


Link to post
Share on other sites

Hi!

Store Manager valami isten császár program :)

Mutatom hogy folyamatosan mióta prestashopot használok milyen problémába ütközöm:

15f30a321b31e8790636d6d54f1d2c0e.png

Feltölti az árukészletet, közben felpakolja a képeket, de mikor a termékoldalra megyek fele, háromnegyede nem generálódik le a képeknek.

Admin felületen minden jó. Arra tippelek hogy a tárhely szolgáltató nem bírja le generálni a képeket, mivel korlátozza a szolgáltató a cpu és egyéb kihasználtságot.

Most egy image regenerator modulleal újra generáltatom a képeket. Tudtok erre valami megoldást? Vagy még az jutott eszembe hogy itt hagyom ezt a szolgáltatót és visszamegyek a tárhelyparkhoz.

Share this post


Link to post
Share on other sites

Hát mennyi terméked van pontosan? És hány terméksablonod van most adminban?

Share this post


Link to post
Share on other sites

Jelenleg 4000 körül van fent. Store managerrel vittem fel kb. 1000 terméket most. Közben olvasgattam és sokan panaszkodnak erre. A shared tárhelyekre mutogatnak, hogy a sok kép generálása nagyon igénybe veszi a szervert, és az beint a dolognak. Ezt  a folyamatot jó lenne lassítani valahogy, hogy ne zúduljon rá a szerverre a sok munka hirtelen.

https://urbantrend.hu az oldal címe egyébként.

Edited by penge17 (see edit history)

Share this post


Link to post
Share on other sites

4000 termék az semmi. Ha van mondjuk 6 termékkép sablon az 24.000 kép csak. Egy normál tárhelyszolgáltató képes ezt lekezelni.

Akkor inkább árakat mondanék: 15.000 ft körül van az alja azoknak akik ezt nagyjából gond nélkül tudják kezelni, de inkább 20-25.000 forint körülire tenném / év azokat a tárhelyszolgáltatókat akiknél már nincs ilyen generálási probléma.

Share this post


Link to post
Share on other sites

Hmm, ez nem rossz. Akkor beigazolódni látszik a szerver probléma. Cpanelen megfigyeltem hogy miközben megy az árufeltöltés a cpu, és egyéb kihasználtság a max közelében mozognak.

Azért jöttem ehhez a szolgáltatóhoz mert korlátlan tárhelyet adnak. Igaz az Inod korlátozva van, de az us 900.000 ha jól emlékszem. Szóval ezzel nincs baj, csak a teljesítménnyel.

A rengeteg kép miatt minimum 25 GB tárhelyre lenne szükségem. Tudsz esetleg ajánlani egy megfelelő szolgáltatót? Tegnap beszéltem a tárhelyparkkal, Ők 47.000 + Áfa adnának +30Gb-ot/ év. Sokallom egy kicsit, de lehet nem lesz más megoldás és visszamegyek hozzájuk.

d716d92de745c419c3d2ce268f6b788a.png

Esetleg ránéznél erre is?

https://www.digitalocean.com/?fbclid=IwAR2VMxhoD0ShSk_H1ucSgIN9VX3VWEGAB-oOoWG_gXaPfoop_x_51Q-6Zfw

 

Edited by penge17 (see edit history)

Share this post


Link to post
Share on other sites

A kolléga - Bokor Bence - mindenről pontos tájékoztatást fog adni hamarosan. :)

Share this post


Link to post
Share on other sites
On 8/13/2019 at 7:51 PM, pattila01 said:

A kolléga - Bokor Bence - mindenről pontos tájékoztatást fog adni hamarosan. :)

Hello!

 

Megtörtént a költözés sikeresen!

Viszont a képgenerálási hiba itt is ugyanúgy fennáll.

Store managerrel feltöltött árukészlet, ami szuperűl felmegy, minden a helyen, de a kategóriába lépve a bélyegképek többsége hiányzik :(

kétféleképpen is megpróbáltam a csvben lévő kép linkeket manipulálni. Az első ha hagyom az eredeti változatot és a szerver szedi le a távoli urlről a képeket,

és úgy is megpróbáltam ha saját gépről történik a feltöltés. Ugyanúgy hiányosak a képek.

Share this post


Link to post
Share on other sites

Próbáld meg az /img/tmp/ mappát átnevezni, majd helyére egy ugyanilyen tmp-t létrehozni, aztán próba.

Edited by pattila01 (see edit history)

Share this post


Link to post
Share on other sites

Nem válaszoltál a fenti-fenti bélyegkép kérdésemre, így inkább azt mondom hogy dobd be azt a linket ahol a probléma van, hadd nézzem meg.

Share this post


Link to post
Share on other sites

Kikapcsoltam a cache-t az admin felületen, csinálok egy újabb próbát.

Share this post


Link to post
Share on other sites

Nos.

Én a fenti linken nem látok termékeket (a bal oldali oszlopban lévő új termékeken kívül).

Ez direkt van így?

1. Minden cache és gyorsítótár legyen kikapcsolva és ürítve a Teljesítmény fülön (legalul is - de azt amúgy sem szabad bekapcsolni).

2. Amikor legeneráltad a képsablont akkor azt hogy csináltad? Az alábbi módon kellene:

admin - beállítások - képek - legalul kép kiválasztása: termék, aztán alatta formátum kiválasztása: home_default

előző képek törlése? => igen

és aztán kicsinyített képek frissítése gomb.

Megjegyzés: én úgy látom, hogy a home_default-od 500x500 px, de a valóságban nem használsz csak 262x262 pixelt. Megfontolandó a home_default átírása erre a méretre - gyorsabb betöltődés, jobb optimalizációs érték, élesebb kép (és hamarabb le is generálódik).

Továbbá: amikor rányomsz a gombra és elkezd dolgozni, akkor 5 perc után kiparkolhat 500 error-al. Azonban a háttérben a szerver még csinálja a feladatát, tehát ne zárd be, ne szakítsd meg (illetve ez így hülyeség, de csak óvatosságból írom - a lényeg itt ilyenkor az, hogy ne kezdd el ismét újból a generálást mert pár ilyen rá-rágenerálás már megakaszthatja a szervert).

Csak szépen nyugiban várj, a háttérben ő elvégzi az összes képet.

Kis várakozás után nézd meg hogy okés-e. Egyrészt bejön-e a kép, másrészt (ha méretet is változtattál) akkor megváltozott-e. Erre a legjobb módszer, ha generálás előtt megnyitod az egyik képet a böngésződben (pl. ezt: "https://urbantrend.hu/4272-home_default/noi-balerina-fekete-3173-black.jpg" kétszer (két külön fülön, tab-on). Majd ha végzett a generálás (vagy ha csak kíváncsi vagy) akkor az egyik tab-on F5-ölsz. Ha megváltozott a kép mérete akkor azon már túlhaladt a szerver, ergo megcsinálta amit kértél tőle.

Ha ezek után is van hiba akkor írd meg ismét a linket és megnézem hogy miért nem jön be a kép (csak most nem találtam terméket - csatoltam a képet).

urbantr.png

Share this post


Link to post
Share on other sites

Azért nem láttad a termékeket mert időközben töröltem hogy újra próbálkozzak. Ezt a generálás módszert ismertem, de nem gondoltam hogy minden termékfeltöltéssel ezt manuálisan el kell végezni. Azt gondoltam hogy ezt a shop magától végzi. Rosszul tudtam? Így soha nem próbáltam hogy csv import után elmegyek a képekhez és generáltatom a képeket :)

Share this post


Link to post
Share on other sites

Alapból sosem kell ezt megcsinálni normál manuális termékfeltöltéskor. Viszont költözéskor, CSV-s feltöltéskor, Prestamanager vagy egyéb esetekben (például amikor oldalt optimalizálunk és emiatt átszabjuk a terméksablonkép méretét, vagy amikor új sablont/témát telepítünk, mert az más képsablon méreteket használ) abszolút indokolt lehet.

Próbáld csak meg, szólj ha van látható vagy nem látható eredmény.

Share this post


Link to post
Share on other sites
2 minutes ago, pattila01 said:

Alapból sosem kell ezt megcsinálni normál manuális termékfeltöltéskor. Viszont költözéskor, CSV-s feltöltéskor, Prestamanager vagy egyéb esetekben (például amikor oldalt optimalizálunk és emiatt átszabjuk a terméksablonkép méretét, vagy amikor új sablont/témát telepítünk, mert az más képsablon méreteket használ) abszolút indokolt lehet.

Próbáld csak meg, szólj ha van látható vagy nem látható eredmény.

Rendben! 1000 köszönet. Az egész szarakodásom abból ered hogy én úgy gondoltam hogy a csv importnál ez magától megtörténik :)

Share this post


Link to post
Share on other sites

Ezzel a hibával megállt:

A "Nincs kép" kép nem írható (products) képek mappádba. Kérlek, ellenőrizd a mappa írási jogosultságait!

Share this post


Link to post
Share on other sites

Elméletileg végzett a termékképekkel (nálam például amit félretettem az kisebb lett). Amit ír az az az kép amikor a termékkép maga nem található (ez egy kérdőjel szokott lenni).

Tehát azt mondja, hogy a home_default-hoz tartozó nincs kép (valószínűleg "hu-default-home_default.jpg" lesz) nem írható a szerveren.

Azt nem hinném, hogy chmod probléma, inkább egyszerűen csak a hu (vagy az alapértelmezett) nyelven nincs meg ez a fájl. Simán pótold az en-ből és jó lesz.

Mint mondtam a termékek képeit ez nem érinti, azok rendben legenerálódtak. Akkor ez megoldva ha jól sejtem. Ha látsz most olyan kategóriát ahol nincs meg a home_default, dobd be.

---

A fenti regenerate thumbnails modulnak a te esetedben szerintem nincs értelme. Akkor látok benne némi fantáziát ha ilyen 40-100.000 termékes shopod van és a szerver gyengébb vagy rosszabb minőségű.

Share this post


Link to post
Share on other sites

Jó reggelt!

Tegnap éjjel megoldottam a hiányzó kép problémát. A magyar zászlós képet hiányolta a language optionsben, újra megmutattam neki a zászlót és azzal nincs baj.

A generálás végeztével a képek mérete változott is a beállítottak szerint, de a hiányosságok mindig megvannak. Azt vettem észre hogy mindig ugyanazok a termékek képei hiányoznak. Tegnap éjjel felraktam az iFastnetre egy új prestát, oda csont nélkűl felrakta a store manager a termékeket minden képpel együtt. Ezután felraktam rá egy témát, azzal is felpakolta a cuccot.

Most kipróbálom hogy ugyanazt a témát rakom oda is. Megmaradt a költöztetés előtti állapot is az iFastneten, oda szintén hiányosan töttődnek fel a képek. Én valami modulra, vagy valami hibás beállításra gyanakszom még, Az is érdekes hogy ugyanazokkal a termékekkel van gond. Esetleg adhatok neked hozzáférést hogy meg tudd próbálni? Biztos többet látsz.

Share this post


Link to post
Share on other sites
42 minutes ago, penge17 said:

Jó reggelt!

Tegnap éjjel megoldottam a hiányzó kép problémát. A magyar zászlós képet hiányolta a language optionsben, újra megmutattam neki a zászlót és azzal nincs baj.

A generálás végeztével a képek mérete változott is a beállítottak szerint, de a hiányosságok mindig megvannak. Azt vettem észre hogy mindig ugyanazok a termékek képei hiányoznak. Tegnap éjjel felraktam az iFastnetre egy új prestát, oda csont nélkűl felrakta a store manager a termékeket minden képpel együtt. Ezután felraktam rá egy témát, azzal is felpakolta a cuccot.

Most kipróbálom hogy ugyanazt a témát rakom oda is. Megmaradt a költöztetés előtti állapot is az iFastneten, oda szintén hiányosan töttődnek fel a képek. Én valami modulra, vagy valami hibás beállításra gyanakszom még, Az is érdekes hogy ugyanazokkal a termékekkel van gond. Esetleg adhatok neked hozzáférést hogy meg tudd próbálni? Biztos többet látsz.

 

Share this post


Link to post
Share on other sites

Attila!

Teszten felraktam azt a témát egy teljesen új prestára amit használok és rögtön jelentkezett a hiba! Ugyanazok a termékek amik eddig is szépen megvannak, legenerálódnak, és amik eddig is szarakodtak azok itt is hiányoznak. Kikapcsolom a modulokat és megpróbálom kiszűrni mi okozhatja. Template Monstertől van a téma.

Share this post


Link to post
Share on other sites

Megtaláltam a hibát. A témához mellékelt egyik modul volt a ludas. A neve "product list gakllery". Ezt elég volt kikapcsolni és rögtön megjelent minden hiányzó termék!

Köszönök minden segítséget. :)

 

  • Like 1

Share this post


Link to post
Share on other sites

Nagyon szuper :) Bocsi, csak most értem ide és olvastam vissza.

Nagyon szívesen :)

Share this post


Link to post
Share on other sites

Attila!

Van valami ötleted hogy tudom resetelni hogy a store manager hajlandó legyen ismét trial licencet adni? :)

 

Köszi

Share this post


Link to post
Share on other sites

Halihó,

ha jól tudom akkor az alaplap azonosítójához köti a regisztrációt. Ha rosszul tudom akkor mondjuk az operációs rendszer licenszéhez, vagy valamilyen más egyedi azonosítójához. Tehát egy másik OS-el kellene próbálkozni, vagy másik géppel - esetleg megpróbálni VM VirtualBox-ban futtatni, hátha... akkor nem kell nagyon birizgálni a jelenlegi OS-t.

 

Share this post


Link to post
Share on other sites
12 minutes ago, pattila01 said:

Halihó,

ha jól tudom akkor az alaplap azonosítójához köti a regisztrációt. Ha rosszul tudom akkor mondjuk az operációs rendszer licenszéhez, vagy valamilyen más egyedi azonosítójához. Tehát egy másik OS-el kellene próbálkozni, vagy másik géppel - esetleg megpróbálni VM VirtualBox-ban futtatni, hátha... akkor nem kell nagyon birizgálni a jelenlegi OS-t.

 

Köszönöm szépen!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More