Jump to content

Problém s výpisem dostupného množství - 1.4 (Vyřešeno)


999cz
 Share

Recommended Posts

Zdravím,

mám takový zajímavý problém, reinstall nepomohl, v templatu to taky není a vyzkoušel jsem opravdu všechno...

Vytvořím produkt, název čísla, nevyplním množství skladu, nechám default 1, v kombinaci vytvořím skupinu a attributy, kde zadám množství třeba 10.

Toto množství se mi přehodí do základních informací a vypisuje se i v přehledu produktů v adminu (množství není už možné vyplnit, protože je upraveno tou kombinací, ale tady pak nastává problém, že při výpisu produktů to vyhazuje hlášku
Dostupnosť: Produkt so zvolenými vlastnosťami neexistuje. Zvoľte si prosím iný.

Přitom když kombinaci vyhodím, tak se mi možnost objednání zobrazí. Veškeré prostředí mám nastavené na jeden jazyk jak BO, tak FO. Všechno se zobrazuje v pořádku, jenom sklad ne.

Setkal se s tím někdo? Nějaký nápad?

Díky za radu nebo tip.

Share this post


Link to post
Share on other sites

No to jsem chtěl udělat jako poslední možnost, protože tam je pravděpodobnost odpovědi hodně vzdálená:) takže jsem spíš chtěl zjistit, zda s tím někdo nemá zkušenost.

Share this post


Link to post
Share on other sites

Zdravím,

mám takový zajímavý problém, reinstall nepomohl, v templatu to taky není a vyzkoušel jsem opravdu všechno...

Vytvořím produkt, název čísla, nevyplním množství skladu, nechám default 1, v kombinaci vytvořím skupinu a attributy, kde zadám množství třeba 10.

Toto množství se mi přehodí do základních informací a vypisuje se i v přehledu produktů v adminu (množství není už možné vyplnit, protože je upraveno tou kombinací, ale tady pak nastává problém, že při výpisu produktů to vyhazuje hlášku
Dostupnosť: Produkt so zvolenými vlastnosťami neexistuje. Zvoľte si prosím iný.

Přitom když kombinaci vyhodím, tak se mi možnost objednání zobrazí. Veškeré prostředí mám nastavené na jeden jazyk jak BO, tak FO. Všechno se zobrazuje v pořádku, jenom sklad ne.

Setkal se s tím někdo? Nějaký nápad?

Díky za radu nebo tip.


Já už prestávam chovaniu PrestaShopu rozumieť. Čo inštalácia to iný problém. Mne to napríklad funguje správne, práve som to skúšal. Skúšal som to na verzii 1.4.0.17 na localhoste. A nie je to čistá inštalácia ale upgrade z verzie 1.3.5.0. Dokonca som postrehol, že viacere chyby ktoré popisuju uživatelia tu na fore sa u mňa nevyskytujú. U mňa sú zase iné problémy o ktorých tu na fóre nikto nepíše. Viem že kým bude verzia 1.4 stabilna prejde ešte veľa času. Zatiaľ si prerábam na túto verziu aspoň tému a niektoré moduly. Snáď sa dočkame raz aj skutočne stabilnej verzie.

Share this post


Link to post
Share on other sites

@jaro61: predstava, ze sa da urobit skutocne plnohodnotny upgrade (cez upgrade skrypt systemu) z 1.3.x na 1.4.x je dost naivna. Pri kontrole databazy sa da zistit, ze upgrade skript neprida do databazy dost vela udajov. Tie potom treba na zaklade diferencnej metody doplnit manualne a fixnut vyskytnute problemy.

Co sa tyka nazoru na stabilitu 1.4. zdielam uplne rovnaky nazor... ved napr. 1.3.7 je iba dostatocne vyladena 1.2.5.0. Nerozumiem dovodu, preco ju uz neponukaju ani na download...

Share this post


Link to post
Share on other sites

tak já nejradši používám verzi 1.2.2, ale vím, že jsem tam měl s něčím problém co tam nešlo rozchodit a na nové prestě to šlo, hm ale vyskytl se zase jiný problém:) jako musí se zase nechat, že 1.4 má celkem vychytávky už v základě, ale z pohledu kodéra bych je někdy bil a to hlavně kvůli compile, které ikdyž je vyplé, tak se tvoří, takže lahůdka na mazání:)

Share this post


Link to post
Share on other sites

Netvrdím že upgrade na 1.4 je plnohodnotná. Aj ja nachádzam v nej chyby ale iné akp tie ktoré sa tu často popisjú, Možno som na niektoré nenarazil asi preto. lebo sa hrajem len s funkciami ktoré používam ja. Veľa možnosti ani nepoužívam. Na localhoste ju mám len preto aby som si dorobil preklad, upravil témy a moduly. Inač ľutujem tých ktorý bezhlavo prešli v ostrej prevádzke na 1.4, a dokonca ani nevedia pracovať s DB.

Share this post


Link to post
Share on other sites

Ja som sa hral s funkcionalitou PS 1.4 naozaj minimalne a narazil som hned na niekolko chyb a problemov, ktore su tak zasadne, ze ten kto bezhlavo urobil upgrade, znefunkcnicl si tym obchod.

PS: ta poznamka o naivite pri upgrade nebola myslena na teba, ale vseobezne na tych, ktori nerozumeju co sa pri upgrade v systeme udeje a nemaju paru o tom co mysql.

Share this post


Link to post
Share on other sites

já jsem naštěstí žádný shop neodstavil, jenom na tom stavím nový...co jsi ještě našel jiného?
moc se mi to nechce předělávat na nižší verzi, ale jak to tak vidím, tak mi asi nic jiného nezbyde..

Share this post


Link to post
Share on other sites

Ked si aktivujete system platby na jednej stranke, ste odhlaseny a nevyplnite udaje adresy a aj napriek tomu stlacite tlacidlo pre pokracovanie procesu platby, neobjavia sa ziadne notifikacie o nevyplnenych udajoch, ale vyskoci okno o AJAX chybe.

Share this post


Link to post
Share on other sites

PS: ta poznamka o naivite pri upgrade nebola myslena na teba, ale vseobezne na tych, ktori nerozumeju co sa pri upgrade v systeme udeje a nemaju paru o tom co mysql.



Veď ja som to ani nebral osobne. ;-)

Share this post


Link to post
Share on other sites

no tak zatím se to dá obejít (natvrdo upravit templet, aby zobrazoval přidat do košíku), ale pořád to neřeší porblém, že to nezobrazuje sklad...a při atributech to nebere jiný atribut, než první...

Share this post


Link to post
Share on other sites

problém vyřešen - v hlavičce bylo js, které jsem potřeboval pro nějaké menu, které to dodrbávalo, až teď mě napadlo se na to podívat od začátku...

@Creative HERO - čistá instalace ti musí jít v pohodě, protože mě teď už funguje...:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More