Jump to content
bmcarvalho

erro 500 - so para 1 utilizador apos update 1.7.6

Recommended Posts

 

Apos atualizacao 1.7.6 encontrei 2 problemas.

1 -  erro 500 ao verificar as encomendas devido a problema na base de dados psu_currency. criou outra moeda em USD que provocou o erro, resolvido ao altterrar o PSU_Currency com phpmyadmin

 

2 -  no back office ao aceder aos clientes da-me o seguinte erro ( em baixo), mas nao existe cliente nenhum Carvalhais , se alterar e efectuar o log in com outro utilizador este erro nao ocorre

Alguma ideia ??

 

Symfony\Component\Debug\Exception\ContextErrorException

in src/Core/Grid/Query/CustomerQueryBuilder.php (line 214)

            }

            if ('date_add' === $filterName) {

                $qb->andWhere('c.date_add >= :date_from AND c.date_add <= :date_to');

                $qb->setParameter('date_from', sprintf('%s 0:0:0', $filterValue['from']));

                $qb->setParameter('date_to', sprintf('%s 23:59:59', $filterValue['to']));

                if (isset($filterValue['from'])) {

                    $qb->andWhere('c.date_add >= :date_from');

                    $qb->setParameter('date_from', sprintf('%s 0:0:0', $filterValue['from']));

                }

CustomerQueryBuilder->applyFilters(array('lastname' => 'Carvalhais', 'date_add' => array('from' => '2019-08-07')), object(QueryBuilder))in src/Core/Grid/Query/CustomerQueryBuilder.php (line 132)

CustomerQueryBuilder->getCustomerQueryBuilder(object(CustomerFilters))in src/Core/Grid/Query/CustomerQueryBuilder.php (line 79)

CustomerQueryBuilder->getSearchQueryBuilder(object(CustomerFilters))in src/Core/Grid/Data/Factory/DoctrineGridDataFactory.php (line 87)

DoctrineGridDataFactory->getData(object(CustomerFilters))in src/Core/Grid/Data/Factory/CustomerGridDataFactoryDecorator.php (line 75)

CustomerGridDataFactoryDecorator->getData(object(CustomerFilters))in src/Core/Grid/GridFactory.php (line 90)

GridFactory->getGrid(object(CustomerFilters))in src/PrestaShopBundle/Controller/Admin/Sell/Customer/CustomerController.php (line 93)

CustomerController->indexAction(object(Request), object(CustomerFilters))in vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php (line 151)

HttpKernel->handleRaw(object(Request), 1)in vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php (line 68)

HttpKernel->handle(object(Request), 1, false)in vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php (line 200)

Kernel->handle(object(Request), 1, false)in adminfolder/index.php (line 86)

 

 

erro.jpg

Edited by bmcarvalho (see edit history)

Share this post


Link to post
Share on other sites

Após muitas tentativas para o segundo erro a única solução foi apagar o empregado que tinha o erro  e voltar a criar. :)

Penso que foi algum problema com o modulo de faturação Moloni e prestashop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More