Jump to content

Kategorien leer/weiß und Artikel erscheinen nicht


Recommended Posts

Hallo zusammen,

 nach längerer Suche und ohne Ergebnis bzgl. meines Problems  habe ich mich entschlossen dieses Thema zu eröffnen.

Aktuell bin ich noch in der Erprobungsphase von 1.7.5.2 und hatte soweit alles verstanden. Nachdem ich dann Plug-Ins installieren wollte, ist mir der Shop irgendwie abgeschmiert.

Jetzt haben wir diesen neu aufgesetzt - also auf "Werkseinstellung". Komischerweise erscheinen jetzt die Artikel bzw. auch die Kategorieseiten als leer. Heißt, wenn ich eine Kategorie anklicke, erscheint einfach eine weiße Seite. Klicke ich die Artikel auf der Startseite an, die jetzt auch komischerweise ohne Bild angezeigt werden, dann kommt ebenfalls eine weiße Seite.

Woren kann das liegen? Gehostet wird das Ganze von einem Kollegen der Rechenzentrumsleiter ist - sollte wohl was von seiner Materie verstehen - oder kann es daran liegen, dass dort falsche Einstellungen vorgenommen wurden?

Persönlich bin ich in IT-Angelegenheiten eine Null...

Schonmal vielen Dank im Voraus für eure Antworten - oder auch gerne Verweise auf  vorhandene Threads die ich nicht gefunden habe.

Edited by Pappalino (see edit history)

Share this post


Link to post
Share on other sites

Hallo Pappalino.

Ich vermute mal, dass die vollständige Entfernung eines deiner Zusatzmodule oder auch ggf. eines Fremdtemplates fehlgeschlagen ist, es kann aber auch eine unvollständige Neuinstallation sein.

Um den Fehler zu finden, schalte mal im Backend unter 

Erweiterte Einstellungen --> Leistung 

in den DEBUG-Modus und poste dann die Fehlermeldung.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Ok, ich glaube ich weiß was du meinst, zu mindest erhalte ich jetzt folgende Fehlermeldung: Fatal error: Uncaught Error: Class 'Shopware\Kernel' not found in /www/htdocs/w00f434b/pappalino.it/shopware.php:103 Stack trace: #0 {main} thrown in /www/htdocs/w00f434b/pappalino.it/shopware.php on line 103

Share this post


Link to post
Share on other sites

Ja, aber bei Prestashop gibt es keine shopware.php - schon gar nicht im Hauptverzeichnis! Aber bei dir gibt es die, denn in  Zeile 103 geht es da tatsächlich um den Kernel:

103   $kernel = new Kernel($environment, $environment !== 'production');

Die solltest du also löschen, und falls erforderlich, alle anderen Restbestände einer vorherigen Shopware-Installation aus Webspace und Datenbank eliminieren.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More