Jump to content
teknashop

Aggiornamento a 1.7.6 e moduli...non funzionanti

Recommended Posts

Salve a tutti, ormai queella del Prestashop sembra un'epopea infinita.

Ancora una volta un grosso aggiornamento, ancora una volta tanti miglioramenti ma, ancora una volta i moduli che funzionavano PERFETTAMENTE sulla versione 1.6.1.24, ma non funzionavano sulla versione 1.7.5 e per cui si è stati costretti ad acquisstare nuove release, oggi con l'aggiornamento alla versione 1.7.6 tornano a non funzionare eti rimettono nella condizione di effettuare ulteriri spese.

I programmatori dei moduli (uno a caso FNAC della CommonServices) affermano che la versione 1.7.6 ha introdotto nuovi Core e per questo molti moduli non funzioneranno.

Domanda: i soloni che programmano Prestashop e perdono mesi in beta tester si rendono conto di quello che combinano agli utenti? oppure anche Prestashop è diventata una macchinetta mangiasoldi?

Deluso e in procinto di passare ad altro CMS

Share this post


Link to post
Share on other sites
1 hour ago, teknashop said:

ncora una volta un grosso aggiornamento, ancora una volta tanti miglioramenti ma, ancora una volta i moduli che funzionavano PERFETTAMENTE sulla versione 1.6.1.24, ma non funzionavano sulla versione 1.7.5

 

Non posso resistere alla tentazione di rispondere alla marea di buffonate che si dicono!

Una delle domande che spesso mi sono fatto riguardo al passaggio dalla 1.6 alla 1.7 e perchè aggiornare se il vostro shop funziona!

E' molto spesso sono arrivato alla conclusione che non vi  e alcuna ragione se non per vedere il vostro BO più accattivante e crearvi solo problemi.

E' anche vero che prestashop stesso suggerisce l'aggiornamento, ma si guarda solo quello che si vuole guardare....un click e via senza nemmeno informarsi quando è stato ben specificato che le due versioni sono strutturalmente diverse, richiedono componenti diversi e un php diverso.

Quindi via con l'aggiornamento senza sapere se il vostro hosting supporta prestashop 1.7 e ovviamente la pretesa che con 24 euro l'anno tutto funzioni e giustamente l'hoster ti dice che se vuoi un hosting dedicato a prestashop non puoi avere la botte piena e la moglie ubriraca perchè di fatto la 1.7 richiede prestazioni e componenti molto differenti dalla 1.6.

1 hour ago, teknashop said:

oggi con l'aggiornamento alla versione 1.7.6 tornano a non funzionare eti rimettono nella condizione di effettuare ulteriri spese.

Questo non corrisponde al vero quindi le cose sono 2, ho non ti sei informato se segui da te la parte tecnica o chi te la segue e un muratore o un zappaterra, lavori umilissimi che senza di loro non avremo alcuni comfort di cui usufruiamo oggi, ma e chiaro che un zappaterra non possa essere un sistemista o sviluppatore.

Nel primo caso sei male informato perchè con l'uscita della 1.7 specialmente nell'add on di presta sono presenti moduli anche per la versione 1.7 senza acquistare nulla!

1 hour ago, teknashop said:

I programmatori dei moduli (uno a caso FNAC della CommonServices) affermano che la versione 1.7.6 ha introdotto nuovi Core e per questo molti moduli non funzioneranno.

Nuovi core ancora mi mancava, cosa vuol dire nuovi core!!?!!

Il solo ed unico vero core, se proprio vogliamo chiamarlo così e che con l'arrivo della 1.7 è stato introdotto il framework symfony, specificatamente progettato per questi tipi di progetti che non e altro di un insieme di classi e funzioni pubbliche scritte sempre in php!

Non solo è stato ampiamente dichiarato che smarty pian piano fosse stato eliminato con l'introduzione di symfony.

Ora potrebbe essere plausibile che usando smarty in alcuni moduli o temi questi smettano di funzionare ma non e per adesso se ne parla in una 2.0 se non oltre!

Io ho aggiornato 2 shop ieir uno con leo theme e un'altro con temeforest a 1.7.6 e non e accaduto assolutamente nulla!....

Se poi mi parli di "sviluppatori" stile copia e incolla posso darti ragione, ma quelli sono delinquenti perchè hanno adattato i moduli per la 1.6 alla 1.7 cosa che nel sito ufficiale di ps non ho visto.

1 hour ago, teknashop said:

i soloni che programmano Prestashop e perdono mesi in beta tester si rendono conto di quello che combinano agli utenti? oppure anche Prestashop è diventata una macchinetta mangiasoldi?

Ma io dico se siete impazziti o veramente assurdi.

Per quanto uso anche altri cms e lavoro su tutto, ps e  forse uno dei più potenti cms in circolazione gratuiti che ci si fanno delle cose spaventose senza spendere un centesimo, e aperto, puoi migliorarlo e customizarlo come ti pare e volete anche i moduli 1clck gratis!

Non so se ci si rende conto delle assurde pretese che avete!

1 hour ago, teknashop said:

Deluso e in procinto di passare ad altro CMS

Fai pure.......scoprirai che altri cms sfruttano il medesimo sistema, alcuni anche gli stessi framework!.

E assurdo ragionare in questo modo e pretendere di avere l'alfa giulia allo stesso prezzo della punto!.....

Iniziate ad affidarvi ai professionisti e smettetela di lamentarvi e vedrete che il vostro shop funziona!

Share this post


Link to post
Share on other sites

Prestashop 1.6.1.24 = fine degli aggiornamenti di sicurezza (è un po' come la gente che pretende ancora di lavorare ancora con l'XP perché "funziona bene"

Prestashop 1.6.1.24 = non supporta PHP 7.2 - Prova ad avere nel market 100000 prodotti e vedrai che i "millisecondi" in eccesso quando viene calcolato un carrello, fanno scappare i clienti.

i miei riferimenti erano sui moduli per l'export per i marketplace. Lavorando con oltre 15 market in tutto l'Occidente...i millisecondi "servono"

Avendo già predisposto per la migrazione verso la versione 1.7.5.2 e avendo dovuto acquistare le nuove versioni perché il "Presta" è completamente diverso (conosco anch'io Symphony)...ti senti di FRIGGERE quando la nuova versione ti rende incompatibile gli acquisti fatti da due settimane.

Aggiornamenti - ognuno è libero di pensarla come meglio ritiene. In fondo ci sono ancora siti che girano su versioni 1.4 o 1.5. Come d'altronde vi è gente che gira in macchina con la Balilla. Sono scelte...non spetta a te criticarle. Le mie critiche e le Ri-Affermo sono sul carattere speculativo inteso a far proliferare esclusivamente un market Add-On che ormai accoglie programmatori di tutti i generi.

In conclusione: Windows Vista era compatibile con le applicazioni dell'XP. Windows 8 era compatibile con Vista e con XP etc. etc. Voglio vedere cosa sarebbe accaduto se uno avesse comprato un pacchetto Office o un Photoshop originale e non lo può utilizzare su un sistema più recente. La retrocompatibilità deve essere garantita.

I moduli integrati nel Prestashop sono buoni se vendi i tuoi prodotti. Se lavori con decine di fornitori e in Dropshipping hai bisogno di moduli performanti e software di appoggio (StoreManager o altro). Se tu rimani con le vecchie versioni...ti assicuro che ti blocchi dopo qualche mese.

Chiudo e ringrazio chi ha compreso lo spirito del mio post...

Share this post


Link to post
Share on other sites

Il mio catalogo più oneroso realizzato si aggira a 400.000 prodotti per lingua....erano 3 fatti 2 conti.

Come mai ho clienti con la 1.6 e lavorano con fornitori di tutto il mondo.

Vuoi la retro compatibilità???paga un developer il codice a aperto non vedo il problema.

Stessa cosa per i sistemi operativi....ripeto non sei informato....basta chiedere e il tuo office 97 o dos 6.22 gira anche con il tuo più recente pc con tanto di connessioni esterne...conosco queste situazioni ma non e vero che non ci sono alternative.....il problema che il professionista si paga giustamente.

Tu parli per fai da te...un professionista a altre risorse e ti assicuro che a me e altri come me non le ha regalato nulla nessuno...non si può avere sempre tutto gratis...di qualcosa dovremmo pure campare non siamo smanettoni della donenica. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More