Jump to content

Recommended Posts

Bonjour, 

Hier tout sur mon site marchait parfaitement et aujourd'hui c'est une pluie de messages d'erreurs alors que je n'ai rien touché entre temps.

Je n'y connais vraiment rien du coup je ne comprend pas d'où ça vient ni comment régler ça.

 

https://vaporalis.fr

erreur sur le site :

Deprecated: strpos(): Non-string needles will be interpreted as strings in the future. Use an explicit chr() call to preserve the current behavior in /homepages/22/d741467604/htdocs/modules/sekeywords/sekeywords.php on line 89

Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/22/d741467604/htdocs/classes/Blowfish.php on line 69

 

 

Erreurs sur le panneau d'admin :

Warning à la ligne 551 du fichier /homepages/22/d741467604/htdocs/classes/controller/AdminController.php
[2] count(): Parameter must be an array or an object that implements Countable

Warning à la ligne 3274 du fichier /homepages/22/d741467604/htdocs/classes/controller/AdminController.php
[2] count(): Parameter must be an array or an object that implements Countable

 

Unknown error à la ligne 75 du fichier /homepages/22/d741467604/htdocs/tools/smarty/sysplugins/smarty_internal_compilebase.php
[8192] The each() function is deprecated. This message will be suppressed on further calls

 

Unknown error à la ligne 198 du fichier /homepages/22/d741467604/htdocs/classes/helper/HelperList.php
[8192] Function create_function() is deprecated

Unknown error à la ligne 1554 du fichier /homepages/22/d741467604/htdocs/classes/module/Module.php
[8192] Function create_function() is deprecated


Warning à la ligne 104 du fichier /homepages/22/d741467604/htdocs/cache/smarty/compile/40/da/6e/40da6ec62da6a6e6860b8411b44bf77f0f3979b4.file.view.tpl.php
[2] count(): Parameter must be an array or an object that implements Countable

 

Si quelqu'un sait d'où ça vient et peut m'expliquer comment régler tout ça ça serait super, merci!

 

 

 

Share this post


Link to post
Share on other sites

Rien n'arrive tout seul en informatique.

Il semblerait que vous ayez modifié votre version PHP de 5.6 à 7.2 ou 7.3 et/ou que vous ayez mis le display_error sur true dans /config/defines.inc.php

Share this post


Link to post
Share on other sites

Je n'y ai pourtant pas touché... Je vais aller regarder.

Share this post


Link to post
Share on other sites

Le PHP a changé en effet... Mon hébergeur l'a automatiquement changé puisque le 5.6 est passé obsolète. Il m'a mis automatiquement en 7.3. Je dois modifier certaines choses suite à ce changement du coup?

 

Edit

J'ai vu que ma version de prestashop était pas compatible avec le 7.3 donc j'ai basculé en 7.1 et ça m'a tout réglé!

Edited by Leyah (see edit history)

Share this post


Link to post
Share on other sites

Prestashop 1.6 n'est compatible avec PHP7.2 qu'à partir de la 1.6.1.18

Aucune version Presta n'est compatible 7.3

Votre hébergeur (1&1) est malhonnête et ne peut pas vous obliger à passer en 7.3 sans votre accord.

Share this post


Link to post
Share on other sites

J'ai vu et je suis passé en 7.1 ça a réglé le soucis. Merci!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More