Jump to content
Mlng

Bug mise à jour Prestashop module inixframe

Recommended Posts

Bonjour à tous,

Il était impossible de passer une commande sur mon site bohovibes.fr.

En effet, sous Chrome lorsqu'un produit était ajouté au panier, le panier restait vide et donc impossible d'aller plus loin dans le tunnel d'achat.
Sur Firefox, les produits étaient bien ajoutés au panier, mais dans le tunnel d'achat, impossible d'accéder à la page de paiement (choix du transporteur OK).

J'ai donc mis à jour Prestashop vers la dernière version 1.7.6.0, mais hélas j'ai rencontré un gros problème lors de la mise à jour : erreur 500 (impossible ensuite d'accéder au back-office Prestashop ni au site.

La sauvegarde de la base de données s'est bien passée, la mise à jour des fichiers Prestashop aussi, cependant l'erreur provient du module inixframe (voir copie écran ci-jointe).
J'ai activé le mode debug afin de voir d'où venait le problème, voici ce que j'obtiens côté back office et front-office :

(1/1) FatalErrorException
Compile Error: Access level to Inix2Module::displayInformation() must be public (as in class ModuleCore)
in InixModule.php line 4462

Après avoir retiré le dossier du module inixframe du serveur via FileZilla, logiquement le problème aurait dû disparaitre et j'aurai pu avoir accès de nouveau au back-office Prestashop, mais ce n est pas le cas car le dossier se recrée automatiquement à chaque fois...

En cherchant sur les forums, c'est visiblement un problème connu que de nombreux utilisateurs rencontrent.

Je ne peux pas contacter le développeur du module (ce module était visiblement était installé sur Prestashop par défaut) car leur site est inaccessible : http://www.presta-apps.com

Je suis donc coincée, pouvez-vous m'aider ?

En vous remerciant par avance :)

Capture.JPG

Share this post


Link to post
Share on other sites

Ce module n'a jamais été installé par défaut dans prestashop, c'est forcement quelqu'un qui l'a fait sur votre boutique.

L'avez vous acheté sur Addons ? Si oui alors vous pouvez contacter le développeur sur la fiche du module sur Addons.

Sinon vous devez vous débrouiller, en tout cas nous n'avons pas accès au code de ce module, nous ne pouvons donc pas vous aider.

Share this post


Link to post
Share on other sites

Merci pour cette réponse.

Non, il n'a pas été acheté sur Addons, je ne comprends pas pourquoi il est installé. Impossible de parvenir à contacter le développeur.

Il y a forcément un moyen de m'aider (en vous communiquant mes accès par exemple), car j'ai regardé le code du module mais je ne vois pas ce qui cloche...

Sinon, le bug initial (impossible de passer commande jusqu'au bout) peut-il être résolu si je restaure le site avant d'avoir fait la mise à jour ?

Merci par avance

 

Share this post


Link to post
Share on other sites

J'avais lu, je ne sais plus sur quel forum, une solution à ce genre de problème.

Regardes dans le dossier de ton module, le fichier xxxxx.php.
Il doit y avoir la fonction displayInformation() déclarée avec la visibilité 'private'.
Tu changes en 'public'...

Share this post


Link to post
Share on other sites

Bonjour Louis !

 

Effectivement, cela semble avoir fonctionné, merci à toi :)

 

Je clôture de ce pas le topic.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More