Jump to content
ChrisL18

Validation commande impossible - "Duplicate entry '0' for key 'PRIMARY' - 1.7

Recommended Posts

Bonjour,

 

Après mise en place sur un nom de domaine de test sur Serveur mutu OVH Pro 2014 où tout se passait bien, la migration vers le nouvel hébergeur (qui loue des serveurs OVH) a été un peu chaotique. Le nouveau serveur était en PHP7.3, ce qui a occasionné des soucis avec des modules ainsi que certaines parties du site. 

Le site a été de nouveau migré ce matin vers un serveur avec PHP7.0 mais des problème très handicapants persistent. 

 

- La validation d'une commande en FO est impossible (voir capture 166 en PJ).

- L'ajout d'un nouveau produit crée la même erreur (capture 169). 

- Certains onglets du BO ne sont accessibles qu'en mode debug (Modules, Performances), sinon c'est erreur 500. 

 

Après des recherches sur le forum, cela proviendrait d'un problème d'auto-incrémentation de MySQL.

J'ai donc envoyé une requête commeALTER TABLE `ulb-orders` AUTO_INCREMENT = 1 

mais mon problème persiste. 

Auriez-vous une idée, pour résoudre mes multiples problèmes.. ?

 

Merci d'avance.

 

Prestashop 1.7.4.2

Serveur PHP7.0

MySQL 5.5.60

Thème : WA_Fishing

URL : https://www.ultimebaits.com

FireShot Capture 169 - Duplicate entry '0' for key 'PRIMARY'{br _}{br _}{pre}INSERT INTO `ul_ - www.ultimebaits.com.png

FireShot Capture 166 -  - www.ultimebaits.com.png

Share this post


Link to post
Share on other sites

ulb_log ne semble pas avoir de colonne en autoincrément.

Je soupçonne que le transfert bdd  a été un peu raté

Share this post


Link to post
Share on other sites

Merci de la réponse. Je refais un import et vous tiens au courant.

Share this post


Link to post
Share on other sites
1 hour ago, doekia said:

ulb_log ne semble pas avoir de colonne en autoincrément.

Je soupçonne que le transfert bdd  a été un peu raté

C'était bien ça. Tout refonctionne sauf certains onglets du BO qui ne sont accessibles qu'en mode debug. 

Le plus important est que le site soit utilisable en FO.

 

merci beaucoup !

Share this post


Link to post
Share on other sites

Vider le cache (à la main car depuis la 1.7, ce truc qui fonctionnait à merveille depuis longtemps est tout boiteux)

Share this post


Link to post
Share on other sites
On 7/15/2019 at 5:23 PM, doekia said:

Vider le cache (à la main car depuis la 1.7, ce truc qui fonctionnait à merveille depuis longtemps est tout boiteux)

Uniquement en mutualisé, si le serveur a des limitations/lenteurs sur les IO/inodes ;) et uniquement si le cache est volumineux.

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More