Jump to content
Meekelenkamp

Erreur durant l'installation des modules à 67%

Recommended Posts

Bonjour je cherche à comprendre depuis hier pourquoi l'installation ne fonctionne pas, cependant je n'ai rien trouvé en ce qui concerne mon erreur.

Quelqu'un aurait-il une idée d'où le problème pourrait venir ? j'ai mis le screen de l'erreur d'installation et ce que les logs me disent ... 

Merci à vous et bonne journée ! :)

 

 

1677122992_prestashop1.PNG.74071d6fc43b4137bb6014eb5182ce98.PNGpresta2.thumb.PNG.f8d72141eea44884496652424f68df52.PNG

Share this post


Link to post
Share on other sites
Quote

MySQL server has gone away

Votre serveur de base de données ne semble pas assez puissant pour aller jusqu'au bout de l'installation de PrestaShop.

Vous êtes sur un hébergement mutualisé ?

Share this post


Link to post
Share on other sites

Peut être mal configuré ou alors l'installation a vraiment mis beaucoup de temps à cause d'une latence de PrestaShop Addons ?

Share this post


Link to post
Share on other sites

J'ai oublié de spécifier ce message d'erreur en début d'installation je pense que ça doit venir de là... mais je n'arrive absolument pas à le solutionner :

"To avoid internationalization data inconsistencies upgrade the symfony/intl component."

 

Share this post


Link to post
Share on other sites

Avez vous l'extension php-intl activée sur votre serveur ? Peut être la version des packages ICU trop ancienne ?

Share this post


Link to post
Share on other sites

Je suis dans les dernières versions il me semble... j'ai cru voir qu'il fallait peut être downgrade cette version quelques part.. 

J'ai testé en version php 7.1, 7.2 et de base j'étais en php 7.3... Rien n'y fait ! lol

 Intl.PNG.bfee12f38837c2e7aa53b38bbbb8d404.PNG

Share this post


Link to post
Share on other sites

Oui Oui j'ai vu que php7.3 n'était pas compatible, 

Je pense que c'est un warning qui génère un Error, c'est ce que je lis sur le fichier de log... Après savoir si j'interprète correctement c'est autre chose étant donné que je ne connais pas du tout Prestashop. Je l'ai installé sur une VM, l'installation s'est passé correctement. La seule différence est que j'utilise VestaCp (qui est une interface de gestion) en plus, mais du coup ça ne fonctionne pas ... j'aimerais comprendre d'où le problème vient ...Pour info je suis sur debian stretch et à jour dans mes paquets ! lol

Merci en tous cas d'essayer de m'aider c'est sympa ! :)

Share this post


Link to post
Share on other sites

@Janett   Alors après plusieurs test j'ai enfin réussi à installer Prestashop.

Il est à noter que Prestashop est compatible avec php7.3 ! 

Je suis sur un Debian Stretch à jour pour information.

Mon problème se situait au niveau de la configuration de mysql, à savoir que j'utilise vestaCP également et qui configure le serveur Mysql.

Donc 

#nano /etc/mysql/my.cnf

et modifier ces valeurs là !

thread_cache_size = 8   => thread_cache_size = 16

wait_timeout=10   => wait_timeout=120

interactive_timeout=50 => interactive_timeout=120

 

C'est peut-être un peu grossier mais je n'ai pas encore eu le temps d'affiner ! 

Voilà peut-être que ce Post pourra aider quelqu'un. 

Bonne journée à tous.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More