Jump to content
Mathayus

Problème avec Babi Jewelry Theme

Recommended Posts

Posted (edited)

Bonjour tout le monde,

 

J'ai acheté il y a quelques mois le thème "Thème Babi - Jewelry Store eCommerce Bootstrap 4 Template" que l'on peut trouver sur le store officiel https://addons.prestashop.com/fr/themes-bijoux-accessoires/41590-babi-jewelry-store-ecommerce-bootstrap-4-template.html?ab=1

 

Après l'avoir installé, j'ai que des bugs avec les modules du theme.

En gros j'ai que des problèmes :

 

Soit les modules admin ont mal implémenté l'interface "ModuleAdminController", ce qui fait que la méthode

"setMedia()" ne correspond pas à l'interface : public function setMedia($isNewTheme = false)

(première capture)

Perso j'ai pas envie de me taper tout le theme a modifier car il a mal fait son boulot... Si je regarde les commits de prestashop ça fait 3 ans que l'interface a changée. Il aurait du voir l'erreur non ?

Ou alors c'est moi l'incompétent et j'ai mal installé quelque chose.

 

Sinon j'ai des erreurs random comme sur la seconde capture.

Avez vous aussi les mêmes problèmes ?

Suis je le seul a avoir acheté ce truc ?

 

Merci à vous

 

 

p1.PNG

p2.PNG

Edited by Mathayus (see edit history)

Share this post


Link to post
Share on other sites

Ce bug (setMedia) reporté à la team dès la 1.7 (3ans) n'a finalement été corrigé que dans la 1.7.5.1 si j'ai bonne mémoire

Il n'est pas dû au thème, mais bien au coeur de prestashop.

 

Share this post


Link to post
Share on other sites

Merci Doekia mais j'ai la version image.png.a6c4f02214de026463e81e50bad7e757.png

Donc je ne comprends pas pourquoi ça déconne...

Share this post


Link to post
Share on other sites

J'ai du mal lire ...

Il te suffit d'ajouter le paramètre manquant dans la fonction

public function setMedia($isNewTheme = false)

En même temps tellement peu de développeur testent leur code en mode debug, ils passent à coté - la team pareil

 

Share this post


Link to post
Share on other sites

Ok donc de ce coté là c'est le dev qui a mal fait son boulot... ça fait chier d'avoir dépensé 50€ dans un truc qui fonctionne pas de base :(

Share this post


Link to post
Share on other sites

HS:

Et je peux savoir comment ce mec arrive a dire chier dans un message sans être filtré

Tandis que nous on poste une réponse technique et nous sommes filtrés

Je veux une réponse officielle là dessus @ttoine

Share this post


Link to post
Share on other sites
33 minutes ago, doekia said:

 

En même temps tellement peu de développeur testent leur code en mode debug, ils passent à coté - la team pareil

 

Ouais mais la ça marche meme pas si je ne corrige pas :(

Bref merci beaucoup pour ton aide :)

Share this post


Link to post
Share on other sites
20 minutes ago, doekia said:

HS:

Et je peux savoir comment ce mec arrive a dire chier dans un message sans être filtré

Tandis que nous on poste une réponse technique et nous sommes filtrés

Je veux une réponse officielle là dessus @ttoine

Apparement toi aussi

Share this post


Link to post
Share on other sites

Oui donc on peut dire chier sans être filtré, mais pas ça:

 

index.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More