Jump to content
bartekcs

Zapomniane hasło administratora

Recommended Posts

Witam!

Mam pewien problem, otóż zapomniałem hasło logowania do panelu presty gdzie dodawałem przedmioty na sprzedaż, próba przypomnienia hasła nic nie daję, bo przenosiłem prestę na nowy hosting, przez co straciłem dostęp do starego maila.

Ktoś może wie w jaki sposób mogę odzyskać konto do stronki?

Z góry dziękuję!

Share this post


Link to post
Share on other sites

W tej chwili po wejściu na adres strony/admin nie mam formularza logowania

Share this post


Link to post
Share on other sites

Sprawdź czy wpisujesz poprawny link do panelu logowania zazwyczaj nie jest to samo admin a jeszcze kilka innych znaków typu adminxxxxxx, adres email administratora możesz zmienić w bazie danych i wtedy skorzystać z opcji odzyskania hasła.

Share this post


Link to post
Share on other sites

Link wpisuje poprawny: www.adres.net/admin044xxxxxx/

Po wpisaniu wyskakuje image.png.4eb7c08f3aab8ce4fe14af8db2def3c2.png

Możesz mi podać nazwę tabeli w której zmieniam email?

Share this post


Link to post
Share on other sites

*Update

Zauważyłem, że jak włącze tryb debugowania w pliku config/defines.inc.php

to panel logowania administratora działa, jednak na stronie głównej wyświetlają się 3 linie błędu

Share this post


Link to post
Share on other sites
Posted (edited)
39 minutes ago, bartekcs said:

jednak na stronie głównej wyświetlają się 3 linie błędu

To tak wyczerpująca teza, domniemam, że ten problem sobie rozwiązałes? 

A co do tabeli to tabela 'employee' a hasło edytujesz przez MD5 wraz z kluczem 'key', który masz w configu 

Sprawdź czy masz poprawna wersję PHP spełniająca warunki twojej wersji PS

Edited by design4VIP (see edit history)

Share this post


Link to post
Share on other sites

image.thumb.png.6018230fb1fb57383af9231a2b59cdcf.png

Tak wyglądają te błędy na stronie głównej.

Do tabelii employee dotarłem, zmieniłem email i hasło z funkcją "MD5", jednak nie wiem w jaki sposób mam to zrobić z kluczem.

W panelu logowania nadal wpisując nowy email wyskakuje komunikat: 

Jest jeden błąd.

  1. Pracownik nie istnieje lub hasło jest nieprawidłowe.

Wersja php dla strony jest ustawiona na 7.2, pod niższymi nie współpracuje strona główna, także stwierdzam, że jest prawidłowa.

Share this post


Link to post
Share on other sites

*Ponowny update

Po godzinie szukania, kombinowania, udało mi się zresetować hasło i zalogowałem się do panelu administratora.

Pozostaje zagadka, co zrobić aby bez trybu debugowania panel logowania się wyświetlał?

Share this post


Link to post
Share on other sites

Spróbuj skasować zawartość folderu var/cache

  • Like 1

Share this post


Link to post
Share on other sites

Działa!

Dzięki wielkie! :)

Jeszcze mam jedno małe pytanko.

Gdzie mogę zmieniać zawartość strony, mam na myśli podane numery kontaktowe, jeden jest już nieważny i chciałbym go usunąć?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More