Jump to content

Recommended Posts

Posted (edited)
Olá Pessoal!
 
Fiz a atualização de minha LOJA prestashop este final de semana, estava na versão 1.7.5.1 passei pra 1.7.5.2
 
Logo após a migração ficou excelente, mas dois dias depois acessei e a loja esta muito lenta no back office. Demora as vezes quase 30s processando requisições.
 
Já desativei todos os modulos. Não consigo entender o problema. Alguem ja passou por esse problema ?

erro.jpg

Edited by MAYCON HENRIQUE (see edit history)

Share this post


Link to post
Share on other sites

Pode ser a API do addons. Algumas vezes isso ocorre quando o servidor da PrestaShop está lento.

A versão 1.7.6 vai ser lançada nos próximos dias e promete resolver o problema. Você pode tentar também desativar a api do addons (não testei essa solução)

Há um módulo que faz isso para você:

disableaddonsapi.zip

Se não for isso, ainda dá para ativar o debug_profiling para ver onde o PrestaShop está gastando mais tempo. Ou olhar o log de queries longas de seu servidor. 

Share this post


Link to post
Share on other sites

Instalei esse módulo mas não funcionou. Não sou programador, então não sei como mecher com esse tal "debug"

uma vez fui mexer nisso e tirei o site do ar. 

Você aceitaria um convite para dar uma olhada no meu back office e me indicar qual esta sendo o problema? 

Eu poderia conversar com você via skype? 

Share this post


Link to post
Share on other sites

Olá Pessoal 

[PROBLEMA PARCIALMENTE RESOLVIDO ]

Descobri que o problema de lentidão no PS estava sendo causado por Regras muito rígidas no Firewall do CPANEL/WHM

Se você usa Cpanel/WHM fique atento as configurações do seu firewall.

As versões anteriores da PS não faziam muitas chamadas externas, porém essa versão nova da PS depende de muitas conexões externas.

Se você aplicar regras de IP por país, blocos de range, anti ddos, você pode ter problemas com lentidão enquanto prestashop tenta sem sucesso se conectar a essas APIs, Marketplaces e Addons. 

Quando eu baixei a proteção do CPANEL meu site voltou ao normal e ficou rápido.

Agora isso é um problema porque sites com grandes acessos sofrem com DDOs entao estou estudando soluções de como aumentar a proteção sem interferir nas conexões do PS.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More