Jump to content

Cannot login to front office - TOO MANY REDIRECTS


ezigo36
 Share

Recommended Posts

Hello forum! 

I have created some dummy accounts to test the functionality of my eshop and I am having the following problem:

every time I try to log in I get the "ERR TOO MANY REDIRECTS" error. The page trying to load is the "my account" page and it - obviously - doesn't load. However, if I truncate the url to that of my home page, the page loads correctly with the account logged in!

I have tried this with chrome, mozilla and opera using my desktop pc and I get the same "too many redirects" error with every one of them.

I am using prestashop 1.7.3.2 and my theme is sp_hitheme.

I have enabled SSL to all pages and tried different combinations of turning the "Friendly URL" and "Accented URL" options on/off.

I ran the mozilla devtools (as it was suggested in a similar topic I found on this forum while searching for a solution) and here is what it shows:

https://i.imgur.com/gEW6FPT.png

My eshop is: houseoftennis.gr and you can use the following dummy account

username: [email protected]

password: 123456

Anny suggestions?

Thanks in advance!

Share this post


Link to post
Share on other sites

  • 1 year later...
  • 2 months later...
On 6/16/2019 at 3:42 PM, ezigo36 said:

Hello forum! 

I have created some dummy accounts to test the functionality of my eshop and I am having the following problem:

every time I try to log in I get the "ERR TOO MANY REDIRECTS" error. The page trying to load is the "my account" page and it - obviously - doesn't load. However, if I truncate the url to that of my home page, the page loads correctly with the account logged in!

I have tried this with chrome, mozilla and opera using my desktop pc and I get the same "too many redirects" error with every one of them.

I am using prestashop 1.7.3.2 and my theme is sp_hitheme.

I have enabled SSL to all pages and tried different combinations of turning the "Friendly URL" and "Accented URL" options on/off.

I ran the mozilla devtools (as it was suggested in a similar topic I found on this forum while searching for a solution) and here is what it shows:

https://i.imgur.com/gEW6FPT.png

My eshop is: houseoftennis.gr and you can use the following dummy account

username: [email protected]

password: 123456

Anny suggestions?

Thanks in advance!

I entered your website with your credentian without problems. (i'm in right now)

Danny

PS. Sorry, just saw this was an old post. 

 

Quote

We are seeing exactly the same issue.

Did you guys find a solution?

can you share your website to check?

Danny

Edited by Danny (see edit history)

Share this post


Link to post
Share on other sites

On 5/2/2021 at 1:06 PM, Louis7777 said:

Have you solved this by now?

 

1 hour ago, leonemusicreader said:

Did you guys find a solution?

Without domain name nobody can really help you.

Share this post


Link to post
Share on other sites

Quote

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

That means you could have a mistake in htaccess or in the DB the urls are different

 

Share this post


Link to post
Share on other sites

Thanks for suggestion.

Both have already been ruled out.
Htaccess was fully disabled and urls are double checked.
Also this issue only happens in frontoffice and not in backoffice.

We see this issue with two Prestashop installations by the way.
The one we shared is a basic installation without any third party modules / themes.
They do both run on the same host.

Share this post


Link to post
Share on other sites

In the end we found out that the 302 redirects where not really visible in access logs.
That made us think of some kind of caching problem.
We contacted the support of our host and they came with a solution.

They told us to add these lines to .htaccess :
#deactivate caching:
Header always set Cache-Control: s-maxage=0
#disables fastcgi_buffering and gzip in Nginx :
Header always set X-Accel-Buffering: no

On our websites this one was enough:
#deactivate caching:
Header always set Cache-Control: s-maxage=0

That fixed the issue on our end.
Hopefully this is also helpful for others who see this.

Share this post


Link to post
Share on other sites

On 7/16/2021 at 11:56 AM, leonemusicreader said:

In the end we found out that the 302 redirects where not really visible in access logs.
That made us think of some kind of caching problem.
We contacted the support of our host and they came with a solution.

They told us to add these lines to .htaccess :
#deactivate caching:
Header always set Cache-Control: s-maxage=0
#disables fastcgi_buffering and gzip in Nginx :
Header always set X-Accel-Buffering: no

On our websites this one was enough:
#deactivate caching:
Header always set Cache-Control: s-maxage=0

That fixed the issue on our end.
Hopefully this is also helpful for others who see this.

But you don't use Nginx mode? Do you use Apache? Correct?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More