Jump to content
kerlin

Envoi mail En cours de préparation : erreur

Recommended Posts

Bonjour,

 

Sur un PS 1.6.1.24, les mails lors du passage d'une commande à l'état En cours de préparation ne fonctionnent pas. Message : impossible d'envoyer le mail au client (ou approchant).
Les autres modifs d'état de commande fonctionnent bien, l'email est bien envoyé.
Donc ce n'est pas un souci au niveau de la fonction mail()

Sur la copie de travail du site, située sur le même serveur, je n'ai pas ce problème. J'ai donc renvoyé le dossiers mails du thème dans celui du site de prod, mais cela ne résout rien.
Cela serait-il déjà arrivé à quelqu'un ? Comment réparer ce bug ?

Merci d'avance

Share this post


Link to post
Share on other sites

généralement c'est le template hors-stock payé qui n'existait pas dans les version avec 1.6 et qui n'a pas été créé lors de la mise à jour

Comme dit @Esh-Network consulte tes logs tu en saura plus

Share this post


Link to post
Share on other sites

merci à tous les deux. Le message dans le bo est "Une erreur est survenue lors du changement d'état et/ou de l'envoi de l'email au client.

Vu que l'état est bien changé dans le BO, c'est que c'est l'email qui n'est pas envoyé.

Dans les logs effectivement, il signale l'absence de 2 fichiers pour les mails (productofstock et new_order.html.) Je les ai mis depuis le thème de base. Mais ça ne résout pas le souci.

Une autre erreur signalée :

 

PACKLINK LOG: | Date: 14/06/2019 | Time: 17:29:13 | Log level: ERROR | Message: | Context data: [{\"referenceId\":\"FR2019PRO0000506275\"}]

Je viens de refaire une commande pour voir les logs, la ligne correspondant à l'heure de la commande est

Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart

A moins qu'il y ait un client qui ait fait une fausse manip en même temps que je changeais l'état de la commande, ce serait le message correspondant. Mais il n'y a ^pas de nouvelle erreur PACKLINK

Le site de prod est un clone du site de travail sur lequel il n'y a pas d'erreur.

J'ai vérifié, le fichier preparation.html est bien présent.

 

C'est curieux.

Merci pour votre aide !

Share this post


Link to post
Share on other sites

Bonjour,

Vérifier si les fichiers productofstock & new_order son bien dans les deux dossier Fr & autres langues du dossier mail.

Ainsi qu'à la racine & les autres dossier thème.

Pour le message

Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart

Ne pas en tenir compte En gros c'est quand un client ce créer un compte il indique que le panier & vide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More