Jump to content

Recommended Posts

Bien le bonjour à tous,

Je travaille pour un client qui m'a fait remonté un problème qu'il a depuis quelques temps.

Impossible de payer via CB via le module Paybox (Version :3.3.1) j'obtiens au choix une erreur 403 ou 500 (suivant certaine modifications) effectué.

Spécificité : 
- PrestaShop™ 1.5.4.1
- Paybox (Version :3.3.1)
- Hébergement Mutualisé Pro perf2014x3 OVH
- Erreur dans les logs trouvé

AH00037: Symbolic link not allowed or link target not accessible: /home***/espac***/****/www/cgibin, referer: https://*****.fr/index.php?controller=order&multi-shipping=
End of script output before headers: modulev2.cgi,

- Erreur sur le site : 
 

Forbidden
You don't have permission to access /cgibin/modulev2.cgi on this server.



Bon bien sûre au début j'ai penser à faire des mises à jour voir si le problème ne venait pas de là, mais ^^ impossible le client ne trouve plus les logs avec lesquels il a acheter le dit plugin et sa version de prestashop est bien trop ancienne pour faire une maj de son site (et le theme n'en parlons pas)

Sys,
Un vilain zombie attristé de voir que je ne trouve pas de solutions.

En espérant qu'un sauveur passe par là ^^

Share this post


Link to post
Share on other sites

Comme le message d'erreur l'explique:

Ton cgibin est un lien symbolique (interdit par la config serveur ( Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch ))

Et/ou les droits du cgibin ne permettent pas l'exécution

Share this post


Link to post
Share on other sites
Posted (edited)

Je ne vois pas comment mettre l'option pour autoriser les liens symbolique j'ai l'habitude de travailler sous du apache mais sur vps 

Et mon CGIBIN est en 655 et le chemin est en 755 et le lien symbolique en 777

Du coup je ne vois pas trop

Edited by VilainZombie

Share this post


Link to post
Share on other sites

ton cgibin est un executable, il doit donc être en 755

 

Share this post


Link to post
Share on other sites
Posted (edited)
8 minutes ago, doekia said:

ton cgibin est un executable, il doit donc être en 755

 

Le problème persiste même si le .cgi est en 755, est ce que si je modifie le paybox.php est que je met le chemin direct cela peut il marcher ?

 

Edited by VilainZombie

Share this post


Link to post
Share on other sites

si le chemin est dans la zone cgibin non

si le chemin est hors du cgibin il faut que le vhost autorise l'execution dans cette section

Share this post


Link to post
Share on other sites
Posted (edited)

Une fois que j'ai mis dans le .htacces : Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

Tout le sites part en erreur 500.

J'ai mis un lien symbolique sur la racine de site prestashop qui redirige vers : modules/paybox/cgibin

Et je ne sais pas si le vhost accepte son éxécution j'ai quasi aucun réglage possible du au mutualisé ...

----------------------------------

Edit j'avais mal placé Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch

La c'est inclus et il n'y a pas de problème

---------------------------------------
Je me demandais aussi est ce qu'il ne faudrait pas que je génére des .htaccess jusqu'au fichier qui est appeler ?

Edited by VilainZombie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More