Jump to content
couillaler

[RESOLU] PS 1.7.5.1 - Renommer nom de domaine sans changer de serveur

Recommended Posts

Hello,

Ma boutique Prestashop (PS) se trouve sur un serveur Linux hébergé chez un prestataire (Amen) sur un nom de domaine .com

Je me prépare à renommer ce domaine .com en .fr plutôt.
(Pour info, je ne l'avais pas fait avant car ma boutique actuelle utilise le .fr (plus pour longtemps du coup), j'utilisais juste le .com pour finir de développer en ligne la nouvelle boutique PS.)

Je ne vais pas changer de serveur, je vais juste renommer le domaine. Je n'ai pas à migrer mes données ou ma base de données. Heureusement, car c'était déjà bien galère du local à la version en ligne ! 😓

Avant que je n'opère ce changement de nom, je voulais savoir si cela risquait d'impacter le fonctionnement de ma boutique PS 1.7.5.1 installée sur mon domaine .com. Hormis de devoir aller (ensuite ou avant ?) dans le menu Paramètre boutique - Trafic et SEO - SEO & URL - URL de la boutique , dois-je faire autre chose encore au préalable ou après ?

Merci pour votre assistance,

Antoine

 

Share this post


Link to post
Share on other sites

Bonjour,

Si vos 2 domaines pointent sur le même emplacement serveur le changement dans SEO&URLs devrait suffire.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour Mediacom87,

Merci beaucoup, c'est juste la réponse dont j'avais besoin !

Au fait, je dois faire la modification dans PS (SEO&URLs) avant ou après le changement de nom de domaine ?

Antoine

Edited by couillaler
ajout question (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

ma question rejoins ce TOPIC.
Je dois refaire un site marchand vieux de plus de 10 ans. Un vieux Magento jamais mis a jour par son propriétaire.
Je repars à zéro sur un Presta 1.7.

Le client veux pouvoir conserver son ancien site actif pendant la construction du nouveau et veut aussi  pouvoir assister aux évolutions du nouveau.
Je vais donc créer le nouveau prestatshop sur un sous domaine comme www.2019.sonsite.com
Si je comprends bien les seules choses que j'aurais à faire pour que tout se passe bien c'est :

1 faire pointer www.sonsite.com vers le dossier d'installation que j'aurai utilisé

2 dans l'admin changer les deux urls  SEO&URLs en retirant simplement le sous-domaine

C'est tout?
merci beaucoup.

Share this post


Link to post
Share on other sites

Bonjour,

Il faut penser au certificats SSL qui fonctionne pas domaine, en conséquent en générer de nouveaux.

Bonne journée !

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci pour la réponse.

Pour tout dire, le site à remplacer est si ancien qu'il n'a meme pas de SSL du tout actuellement..

Donc je le mettrai en place directement sur le domaine principal après l'échange.

Bonne journée également 😉

Share this post


Link to post
Share on other sites

Merci @Mathieu R effectivement, il y a aussi le certif SSL à mettre à jour, enfin, à générer à nouveau, selon les case de chacun. J'ai dû passer par là aussi. Et ça marche mieux avec ce nouveau certificat. :)

J'ai aussi dû vider le cache (menu performance) pour qu'il remette à jour certains liens (comme les catégories par exemple qui étaient restées en .com).

Par contre, toutes mes images ne s'affichent plus, le lien n'est plus bon (j'imagine). Pas celles du thème, mais celles de mes produits et catégories.

Le lien ne se fait plus j'imagine, mais où ai-je omis quelques chose ? Ou bien me suis-je trompé quelque part ? Je ne trouve pas, la gestion des images dans PS est assez particulière et je n'arrive pas à voir où corriger cela dans la BDD, ou ailleurs si cela ne doit pas être corrigé ici.

Merci.

Antoine

Share this post


Link to post
Share on other sites
5 hours ago, couillaler said:

Merci @Mathieu R effectivement, il y a aussi le certif SSL à mettre à jour, enfin, à générer à nouveau, selon les case de chacun. J'ai dû passer par là aussi. Et ça marche mieux avec ce nouveau certificat. :)

J'ai aussi dû vider le cache (menu performance) pour qu'il remette à jour certains liens (comme les catégories par exemple qui étaient restées en .com).

Par contre, toutes mes images ne s'affichent plus, le lien n'est plus bon (j'imagine). Pas celles du thème, mais celles de mes produits et catégories.

Le lien ne se fait plus j'imagine, mais où ai-je omis quelques chose ? Ou bien me suis-je trompé quelque part ? Je ne trouve pas, la gestion des images dans PS est assez particulière et je n'arrive pas à voir où corriger cela dans la BDD, ou ailleurs si cela ne doit pas être corrigé ici.

Merci.

Antoine

As tu pensé à "régénérer les miniatures" tout en bas de la page images située sous "PERSONALISER---->apparence--->images"

Share this post


Link to post
Share on other sites

Oui, merci pour cette idée. J'ai essayé aussi cette régénération. J'avais vu l'info ici : https://www.prestashop.com/forums/topic/989573-problème-de-lien-dimages-et-de-catégories-après-un-changement-de-lurl-de-mes-sites/?tab=comments#comment-3126956

J'ai ensuite aussi revidé le cache, mais c'est pareil. Mes produits et catégories n'affichent plus d'images en front office. En back office, par contre, je les vois bien.

Il doit donc y avoir quelque chose à faire... mais où, je ne le sais pas encore! :)

Antoine

Share this post


Link to post
Share on other sites

Je note, par ailleurs, que lorsque j'affiche la page d'accueil, ou du produit, et que j'affiche le code source de la page, le lien vers une image (l'exemple est le même pour toutes les images) est du type https://www.mondomaine.fr/3750-medium_default/sony-v8-25cld.jpg (cette adresse ne mène nulle part quand je la saisis directement dans mon navigateur) 

Le chemin réel pour l'image ci-dessus est https://www.mondomaine.fr/img/p/3/7/5/0/3750-medium_default.jpg (cette adresse envoie bien vers mon image quand je la saisis directement dans mon navigateur), j'imagine donc qu'un lien se fait quelque part, et que ce lien ne se fait plus.

Après, savoir tout cela me fait une belle jambe, car je ne sais qu'en faire et que cela n'a peut-être rien à voir avec mon souci actuel. :)

Antoine
PS : pour changer l'URL de ma boutique dans PS, j'étais passé par phpMyAdmin (table _shop_url où j'ai modifié le champs domain et domain_SSL en mettant www.mondomaine.fr), et pas par la rubrique SEO&URL dans le back office. Devais-je encore modifier autre chose ? C'est peut-être là que j'ai omis un truc ?

Share this post


Link to post
Share on other sites

Ha! Finalement, j'ai trouvé l'astuce pour résoudre le bidule, c'est ma dernière remarque qui m'y a fait penser.

Citation

PS : pour changer l'URL de ma boutique dans PS, j'étais passé par phpMyAdmin (table _shop_url où j'ai modifié le champs domain et domain_SSL en mettant www.mondomaine.fr), et pas par la rubrique SEO&URL dans le back office. Devais-je encore modifier autre chose ? C'est peut-être là que j'ai omis un truc ?

Comme j'avais fait la manip de la manière décrite ci-dessus, je me suis dit que le fait de le faire via le back office changeait peut-être plus de choses dans la base de données. Je suis donc allé dans le back office Menu Trafic et SEO / SEO & URL / URL de la boutique et j'ai modifié mon www.mondomaine.fr en www.mondomaine.fr (ce qui, vous le notez, ne change rien). J'ai ensuite enregistré les modifications, vidé le cache, et là, miracle, les images sont réapparues sur mon front office ! :)

J'en déduis donc que de passer par le BO pour cette modif fait plus que modifier les deux lignes de la table _shop_url . Ou bien qu'il sagit là encore d'un des nombreux mystères de l'informatique (et de PS) ! :)

Dans tous les cas, cela fonctionne, merci pour l'aide apportée ci-dessus, et à bientôt !

Antoine

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More