Jump to content

Recommended Posts

Hallo ich benötige dringend Hilfe.

Ich habe heute morgen drei Module geupdatet. Leider weiß ich nicht mehr genau, welche da zur Verfügung standen.

Auf jeden Fall gibt es eine Logdatei:

"Ausnahmefehler im Modul ps_facetedsearch bei upgrade: Failed to copy \"/mnt/web403/a0/84/5719984/htdocs/shop/app/cache/prod/sandbox/5cf8b56c8a6f3/ps_facetedsearch/vendor/symfony/console/Tests/Helper/ProgressIndicatorTest.php\" to \"/mnt/web403/a0/84/5719984/htdocs/shop/modules/ps_facetedsearch/vendor/symfony/console/Tests/Helper/ProgressIndicatorTest.php\" because target file could not be opened for writing."

Ich kann im Backoffice nun auch die Seite der Module nicht mehr auffrufen.  Es erscheint folgende Meldung:

"

Oops! An Error Occurred

The server returned a "500 Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused."
 
Im Shop selber sind die Artikelseiten auch nicht mehr erreichbar. 
"

Diese Seite funktioniert nicht

silly-sewing.de kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500"
 
Kennt jemand das Problem und wie kann ich es als technischer Laie lösen.
 
Hier kann man sich das Problem anschauen https://silly-sewing.de/
 
 
Vielen Dank für die Tipps.
 
Gruss Volker

 

Share this post


Link to post
Share on other sites
Posted (edited)

Ich würde wohl versuchen, den Kopiervorgang händisch vorzunehmen.

Ansonsten mal den Ordner des Moduls umbenennen, um es zu deaktivieren.

Artikelseiten kann ich übrigens erreichen, jedoch nicht die Kategorieseiten (was auch logisch ist, weil dort das Modul Facettennavigation aktiv ist).

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Danke für die Antwort----nur leider erzeugt diese bei mir nur "Fragezeichen" in den Augen.

 

Ich habe mich per FTP auf dem Server eingeloggt und auch den Ordner Module gefunden. Ich dachte ich nehme die Ordner, die heute morgen geändert wurden, da ich nicht mehr weiß, um welche Module es sich handelt. Aber bei allen Ordnern ist das Änderungsdatum in der Zukunft. Aktuell haben wir den 06.06.2019 11.07 Uhr. Änderungsdatum auf dem Server ist 06.06.2019 11.30 Uhr. Ob hier das Problem liegt?

 

Da ich in die Module derzeit über das Backoffice nicht mehr komme, kann ich die Facettennavigation nicht deaktivieren. Wo immer ich auch das machen müsste. 

Also mir gelingt es derzeit nicht eine Artikelseite aufzurufen.

Danke vorab für weitere Hilfe......  :)

Share this post


Link to post
Share on other sites

Ich hatte meinen Post noch ergänzt, Artikelseiten lassen offenbar aufrufen, jedoch Kategorieseiten (da wo die Facettennavigation ja auch angezeigt wird) nicht. Bitte beachte, daß die korrekte Ausdrucksweise wichtig ist, um Mißverständnisse zu vermeiden!

Daß das Problem mit der Zeitabweichung zu tun hat, glaube ich weniger, normal erscheint mir das aber nicht zu sein.

Was ist jetzt mit meinen Vorschlägen (mit dem zweiten deaktivierst du ja die Facettennavigation, ohne über das BackOffice zu müssen)?

Share this post


Link to post
Share on other sites
Posted (edited)

Ich habe das Modul ps_facetedsearch umbenannt. Nun kann ich die Artikel wieder erreichen, und die Kunden hoffentlich auch  ;)

 

Ich komme auch wieder im Backoffice in die Module hinein. Hat jetzt nur das eine Modul das Problem ausgelöst???

Erstmal Danke für den Tipp. Gerade heute hatten wir ein paar Angebote zum Geburtstag drin  ;)....

Aber wofür ist die Facettennavigation nützlich??? Würde das gerne verstehen, um zu entscheiden, ob ich diese nun dauerhaft deaktiviert lasse.

Was noch seltsam ist, dass ich seit gestern Abend keine Modulauswahl angzeigt bekomme, sondern nur die installierten Module.....

modul.PNG

Edited by Silly_Admin (see edit history)

Share this post


Link to post
Share on other sites

Auf dem Screenshot wird überhaupt nichts angezeigt ...

Du weißt nicht, was die Facettennavigation ist? Sorry, ist dein Username Programm? Mit den Grundlagen von Prestashop sollte man sich schon vertraut machen, bei der Facettennavigation handelt es sich um die Filter, um Produkte vorauswählen zu können, ob du die benötigst, hängt auch von deinem Sortiment ab. Ich würde den Ordner des Moduls aus einer Sicherheitskopie (die man immer haben sollte) oder dem Installations-ZIP auf eine funktionierende Version setzen und ggf. das Update neu versuchen.

Share this post


Link to post
Share on other sites

Genau das was man auf dem Screenshot sieht, sehe ich seit gestern auch. Nämlich nichts. Da scheint noch was anderes defekt zu sein.

Share this post


Link to post
Share on other sites
Posted (edited)

Das ist allerdings seltsam. Sind die anderen Tabs auch betroffen?

Lösche mal alle Caches.

OT: Kümmere dich um die Rechtssicherheit!

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More