Jump to content
jerryblack

Der Name "Bruttopreis" kann auf der Artikelseite nicht in "inkl. MwSt" geändert werden.

Recommended Posts

Hallo,

ich hoffe ich bin hier richtig und man kann mir helfen. Ich benutze die Presta Shop Version 1.7.5.2 mit dem Design "at_gucci" von Themeforest. Mein Problem besteht darin das unter dem Preis im Artikelfenster "Bruttopreis" statt "inkl. MwSt." steht. Die Übersetzung ( Office, Module und Template) habe ich mir auch schon angeguckt und jedes Tax, Bruttopreis abgeändert. Cache gelöscht, Cookies gelöscht etc. Dennoch erscheint immer noch der Name "Bruttopreis." Dieser lässt sich einfach nicht ändern.  Könnt Ihr mir vielleicht helfen.

Freundliche Grüße

 

Bruttopreis.png

Share this post


Link to post
Share on other sites

Schau doch mal in deine Theme Dateien (Startpunkt product.tpl) - dort findest du dann die exakte Stelle der Übersetzung.

Share this post


Link to post
Share on other sites

Das hatten wir gerade in einem anderen Thread. Müßte eigentlich in den Übersetzungen des Rechtssicherheitsmoduls sein.

Share this post


Link to post
Share on other sites

Manchmal findet sich der zu übersetzende Ausdruck in der templates/catalog/_partials/product-prices.tpl

Im Alysum heißt der Ausdruck

{if $configuration.display_taxes_label}
     {$product.labels.tax_long}
 {/if}

und lässt sich meines Wissens auch nicht direkt übersetzen.

Modul Rechtssicherheit ist bei mir nicht installiert und ich habe das auch nicht geschafft, den String in der Übersetzungsfunktion zu lokalisieren.

Bei Fremdthemes kann es aber sich um einen Bug handeln:

https://github.com/PrestaShop/PrestaShop/issues/12186

 

Share this post


Link to post
Share on other sites

Kuckst du hier: 

1 hour ago, Gurkcity said:

und lässt sich meines Wissens auch nicht direkt übersetzen.

Müsste eigentlich heißen: ... lässt sich mit dem Übersetzungstool von Prestashop 1.7 nicht (oder nur auf Umwegen) finden. Du musst quasi schon vorher wissen, wo genau du suchen musst, denn die globale Suche funktioniert nicht.

Edited by Wuschel (see edit history)

Share this post


Link to post
Share on other sites

Fehler habe ich gelöst. Man muss leider auch im Standardtemplate "Classic" in den Übersetzungen unter Global den Text ändern. Dann hat es geklappt. Was eigentlich keinen Sinn macht.

Edited by jerryblack (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Richtig, das macht keinen Sinn und ist sehr französisch gelöst 😅

Die Übersetzung hat eigentlich mit dem verwendeten Theme nicht zu tun, da es eine Core Übersetzung ist. Der Ursprung liegt im ProductLazyArray Presenter und wird über das TranslatorInterface gesteuert. Wieso das im Classic Template auftaucht, kann ich momentan auch nicht erklären. Richtig wäre es, wenn bei den Übersetzungen eine Rubrik unabhängig von den Templates gäbe, die sich Core-Übersetzungen nennen würde. Aber so denken nur wir Deutschen.

Somit als Fazit: lösche niemals das Classic Template, denn hier könnten Core-Übersetzungen versteckt sein, die Du auch für Deine anderen Teile des Shops brauchst, die nicht im eigenen Template übersetzbar sind.

Share this post


Link to post
Share on other sites

Guten Abend,

bin gerade auch an genau diesem Punkt angekommen.
Verwende Prestashop 1.7.6.3

Weiß zufällig jemand welche Dateien ich bearbeiten muss?

Gruß Pascal

Share this post


Link to post
Share on other sites

Normalerweise mußt du gar keine Dateien bearbeiten, sondern die Übersetzungsfunktion im BackOffice nutzen.

Share this post


Link to post
Share on other sites

Das habe ich auch gesehen und auch abgeändert. Läd beim abspeichern eine Weile dann kommt ganz schnell eine rote Meldung die dann verschwindet und darunter dann Erfolgreich gespeichert. 
Ändert sich aber trotzdem auf den Seiten nicht.

Kann es was damit zu tun haben, dass das classic Theme nicht mehr auf dem FTP ist? 
 

EDIT: Hier die Ausgabe der Logfile

Failed to copy \"/mnt/web120/e1/26/57725526/htdocs/fitfuerfestival/var/cache/prod/themes/AngarTheme/translations/de-DE/ModulesProductcommentsProductcomments_reviews.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.xlf\" to \"/mnt/web120/e1/26/57725526/htdocs/fitfuerfestival/var/cache/prod/themes/AngarTheme/translations/de-DE/ModulesProductcommentsProductcomments_reviews.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.xlf\" because target file could not be opened for writing.

Edited by PaHa386 (see edit history)

Share this post


Link to post
Share on other sites

Sehr seltsam und es geht da ja nur um eine Datei im Cache ... Und dann geht es anders als in dem Thread, an den du dich angehängt hast, offenbar um das Produkt-Kommentar-Modul.

Evtl. lösche mal den Ordner var/cache.

Das classic-Theme sollte wohl nicht entfernt werden (s. Beitrag von Gurkcity).

Welche PHP-Version?

Share this post


Link to post
Share on other sites

Bei diesem Dateinamen wird mir ganz schwindelig: ModulesProductcommentsProductcomments_reviews.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.de-DE.xlf 😵

Bist Du sicher, dass es diese Datei überhaupt gibt?

Versuche mal das original-Template /themes/classic/ wiederherzustellen. Und danach nutze die Übersetzungsfunktion von PrestaShop. Vielleicht beschreibst Du nochmal genau, welchen Teil Du übersetzen möchtest.

Viele Grüße
Chris

Share this post


Link to post
Share on other sites
5 minutes ago, Gurkcity said:

Bist Du sicher, dass es diese Datei überhaupt gibt?

Die gibt es natürlich nicht. Aber dank der kruden Logik der Programmierer von 1.7 darf man unter keinen Umständen das Classic Theme entfernen, weil diesem z.T. auch die Übersetzungen der Fremdtemplates zugeordnet werden. Ist es nicht mehr vorhanden, kommt es zu solchen Fehlern.

Share this post


Link to post
Share on other sites

Ich habe die ShopThemeGlobal.de-DE.xlf einfach abgeändert und die Cache geleert danach ging es.
Falls noch jemand das Problem hat, ihr findet sie unter
\app\Resources\translations\de-DE\ShopThemeGlobal.de-DE.xlf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More