Jump to content
Studio Créations

Cette page tente de charger des scripts à partir de sources non authentifiées

Recommended Posts

Bonjour,

Je me suis rendu compte d'un problème sur un site, suite à la désactivation d'annonces Google Adwords d'un client avec la mention suivante dans l'admin Google:

Refusé: Logiciels malveillants ou indésirables
 
A noter que hier le site a été inactif 4/5h, car le client avait oublié de renouveler son abonnement OVH, une fois remis en ligne le problème est apparu.
 
En allant sur Chrome, à droite dans la barre d'adresse, un petit bouclier s'est ajouté avec la mention "Contenu non sécurisé bloqué, cette page tente de charger des scripts à partir de sources non authentifiées"
 
Après quelques recherches et différents tests j'ai observé dans les performances dans le BO Prestashop, que le fait de désactiver "Déplacer le code JavaScript à la fin" résolvait le problème. A première vue je pensais que tout rentrait dans l'ordre, mais quand je désactive le déplacement du code javascript à la fin d'autres problèmes surviennent:
 
- Le slider à l'accueil disparait.
- Sur la version mobile le menu de navigation disparait (uniquement sur les pages produits).
- Le carrousel des photos produits ne fonctionne plus, les photos s'affichent les unes à côté et en dessous des autres en dessous de la photo de couverture.
- Les photos des produits s'ouvrent dans une nouvelle page.
 
Quelqu'un aurait une idée ou une piste que je peux fouiller pour résoudre ce problème ?
 
J'ai également analysé le site avec https://aw-snap.info/file-viewer/
Mais rien n'est détecté.
 
Le site: www.vo-expo.fr
Presta 1.6.1.18
 
Merci d'avance pour vos réponses.

Share this post


Link to post
Share on other sites

Bonjour,

Déjà il fraudais activé le SSL ( https ).

Ensuite si tu peux faire un MAJ vers la 1.6.1.24 pour des raisons de patch serais cool.

 

Ensuite pour le script qui charge pas je n'est pas ce message en allant sur le site.

Si le script apparaît après avoir mis le certificat SSL c'est qu'il y as un lien http sans le ssl dans un fichier de ton site ou module, mais pas de bug. 

Share this post


Link to post
Share on other sites

Bonjour,

Il y a 2 lien en http dans ton site.

0b72f50566ac98e976a87451850d0f3a.png
https://gyazo.com/0b72f50566ac98e976a87451850d0f3a

 

c521143af2bb3f0addec7c229bfdbd68.png
https://gyazo.com/c521143af2bb3f0addec7c229bfdbd68

Puis tu as aussi celui de google qui est  utilise du coup le javascript : 

40cfbe3a6edbd3f8ca3e5daa604bb72c.png
https://gyazo.com/40cfbe3a6edbd3f8ca3e5daa604bb72c

Surement ça qui bloque.

 

 

Puis dans la console il y a énormément de problèmes :

6d01e23ab7ae919de4e4e3fdc43099d0.png
https://gyazo.com/6d01e23ab7ae919de4e4e3fdc43099d0

Edited by Esh-Network (see edit history)

Share this post


Link to post
Share on other sites

C'est ce que je m'étais dis hier, j'ai fais un site de test, il n'y a plus aucun http dans le code source de la page mais le problème est toujours présent et modifier le code du module Analytics je ne suis pas sur que ce soit très bon.

Share this post


Link to post
Share on other sites

Si jamais quand tu ajoute un lien manuelle par exemple une image ou autres au lieu de mettre http ou https ...

Tu met juste un / ou // qui fera office du lien exemple : / ou //image/xx.png ce qui donnera https://lien.fr/image/xx.png pour que ce genre de problème sois régler en partie.

Edited by Esh-Network (see edit history)

Share this post


Link to post
Share on other sites

Je l'ai fais également en désactivant le module Analytics et en le laissant et en modifiant le code comme tu proposes mais ça ne change rien.

Share this post


Link to post
Share on other sites

Peux-tu essayer de supprimer le htacess allez dans paramètre boutique -> seo & url, désactive la réecriture d'url ensuite tu réactive stp ?

Share this post


Link to post
Share on other sites

J'ai fais les différentes manipulation mais je ne vois pas la différence.

Sur le site de test le lien de l'accueil est bien en https

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More