Jump to content
kerlin

Problème script Doekia contre spam compte client

Recommended Posts

Salut à tous, sur un PS 1.6.1.11 pollué par les inscriptions bidon, j'ai installé le patch de Doekia (pourquoi faire compliqué quand il nous a mâché le travail !).
Plus de problèmes de fausses inscriptions. Mais plus d'inscription du tout 😉 Si on essaie de s'inscrire, un message s'affiche disant qu'il y a 2 erreurs : Nom de famille invalide, Prénom invalide.

Le fichier class-index.php a bien été supprimé, les adresses bidon effacées avec autorisation de réinscription, le cache désactivé et vidé, les overrides sont bien autorisés. Les deux fichiers Customer.php et Validate.php ont bien été créés dans le dossier override/classes

Site visible ici

 

Merci d'avance

Share this post


Link to post
Share on other sites

avec quel éditeur avez-vous écrit vos fichiers ?

Vous devez avoir ajouté des caractères indésirables dans la regex à mon avis si vous avez c/c le code depuis le forum.

 

Ci-joint les 2 overrides

Customer.php

Validate.php

  • Thanks 1

Share this post


Link to post
Share on other sites

Hello Eolia, un tout grand merci, ça marche maintenant. Je n'avais pas fait de copier/coller depuis le forum si mes souvenirs sont bons mais depuis le lien donné en premier dans le topic. En utilisant Notepad++ donc pour créer le patch. Et c'est lui qui a créé les 2 fichiers. Curieux.

Mais là ça marche.

Un big thanks !

Share this post


Link to post
Share on other sites

le forum rajoute des caractères invisibles et le c/c donne un fichier encodé en ISOXXXX au lieu de utf8 ce qui pète la regex^^

Share this post


Link to post
Share on other sites
Le 5/25/2019 à 7:34 PM, kerlin a dit :

ce pourquoi je n'avais pas fait le c/c depuis le forum mais

Et tu as fais le c/c dans un éditeur digne de ce nom? en UTF-8, sans BOM? Transféré en FTP en mode binaire?

99.999% de chance que ce ne soit pas le cas, du coup tu auras le même problème avec les 2 fichiers

Share this post


Link to post
Share on other sites

Ok, merci pour les deux fichiers (ils n'étaient pas accessibles tant que pas logué)

En éditeur, j'avais utilisé Context, généralement je n'ai pas de problème avec ...

Merci encore de vos réponses !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More