Jump to content
caligueco

AYUDA: Actualizada version php 5.4 a 5.6 y no puedo entrar back office

Recommended Posts

buenas tardes a todos.

Empiezo por decir que "en que hora me he metido a tocar nada"馃槖.

Tengo una tienda en prestashop 1.6 y hab铆a decidido instalar prestashop 1.7 en una subcarpeta para una vez migrado todo colocar la nueva instalacion en la carpeta principal.

Los problemas empiezan cuando al comenzar la instalaci贸n desde el cpanel en la subcarpeta, me da un error diciendo que la versi贸n php que tengo (5.4.45 creo) es incompatible con la instalaci贸n de PS 1.7 y que como m铆nimo tengo que tener la 5.6.

Entro en cpanel y veo que puedo seleccionar la versi贸n con un programa preinstaldo que se llama "seleccionar versi贸n php" y despliego una lista de distintas versiones desde 5.6 a 7.3 (aqui ya veo que no est谩 la que tengo instalada ya obsoleta php 5.4). Me decido a cambiar de versi贸n seleccionando php 5.6 y a partir de aqui ya no puedo entrar en mi back office, meto usuario y contrase帽a y se queda pensando, dando vueltas la ruedecita y termina por mandarme un error 500. y ya no puedo volver a la 5.4 porque no est谩 en el desplegable.

No se que hacer, he restaurado bases de datos, tienda, etc pero no consigo entrar en el BO de la tienda para gestionar los pedidos.

Por favor, me pod茅is ayudar?. Desde el administrador de archivos puedo cambiar algo en alg煤n archivo?

De momento la tienda para los clientes funciona bien. Menos mal...

Saludos y muchas gracias por adelantado.

Share this post


Link to post
Share on other sites

Hola:

Probablemente tengas alg煤n problema de compatibilidad de alg煤n modulo, porque el Prestashop deber铆a funcionar perfectamente en PHP 5.6. Tendras que entrar por FTP y activar el modo debug para que te de mas detalles sobre el error que se esta presentando y asi poder ayudarte un poco mas.

Saludos

Share this post


Link to post
Share on other sites

Muchas gracias por contestar.

He ido cambiando las versiones de php desde el cpanel del hosting y sorprendentemente despues de borrar cookies y todo eso, al final con la versi贸n 7.2 de php ha entrado al back office despu茅s de 1 minuto pens谩ndoselo. He probado con optros navegadores y lo mismo, despu茅s de como 1 minuto consigue entrar. Por lo menos puedo gestionar la tienda...

Una pregunta, donde se activa el modo debug para ver porque tarda tanto?

Muchas gracias!

Share this post


Link to post
Share on other sites

Desde el archivo:聽/config/defines.inc.php
Seteando en true la variable:聽_PS_MODE_DEV_

O si estas en PrestaShop 1.7 lo puedes hacer desde la pesta帽a de rendimiento.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More