Jump to content

Recommended Posts

Posted (edited)

Bonjour à tous

 

Qui peut m'aider à résoudre les derniers mixed content qui me reste pour avoir un joli cadenas sur mes page produits?  J'en ai viré pas mal mais il en reste

Les images de la galerie par exemple !

 

https://www.jackjamon.fr/gallerie/index.php

Presta 1.5.6

merci

Pascal

Edited by freebike

Share this post


Link to post
Share on other sites

Changer les url de ton slider (surement en base de données) de http => https

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci doekia

le slider à créé des centaines d'entrées en BDD

Qu'est il préconisé dans ce cas? une commande SQL? si oui laquelle ?

Pascal

Share this post


Link to post
Share on other sites

qui peut me donner la commande SQL pour changer les http en https depuis phpmyadmin?

Share this post


Link to post
Share on other sites
UPDATE ma_table SET mon_champ = replace(mon_champ, 'ancienne-chaine', 'nouvelle-chaine'); 

 

  • Thanks 2

Share this post


Link to post
Share on other sites

petite ligne bien utile a garder dans un coin de son cerveau. .Elle fait des miracles. Merci Mediacom

Share this post


Link to post
Share on other sites

Super merci, je n'ai plus de http: dans ma bdd, je garde ce bout de code précieusement de coté !

Il me reste encore du http: dans le module homeslider : j'ai modifié les fichiers du module et la BDD, vider les fichiers du cache smarty, ré-uploader les images qui posent problème, mais le http: résiste dans ce module, Avez vous une idée?

https://www.jackjamon.fr/gallerie/index.php

Share this post


Link to post
Share on other sites

Bonjour,

Donc là vous ne parlez pas du tout du module slider de base de PrestaShop mais d'un module créé spécifiquement pour faire des galeries d'images sur plusieurs pages.

Donc c’est le module qui est mal développé donc demandez à son créateur de corriger son erreur.

Share this post


Link to post
Share on other sites

Ah zut

Cela veux dire que même en regardant de près je ne pourrais pas le faire moi même ? 

Sinon je vais devoir installer un autre module...

Share this post


Link to post
Share on other sites

Ben surtout que n'ayant pas acheté ce module ou développé ce module c’est difficile de vous dire la structure du code.

Share this post


Link to post
Share on other sites
On 5/28/2019 at 11:28 AM, Mediacom87 said:

Bonjour,

Donc là vous ne parlez pas du tout du module slider de base de PrestaShop mais d'un module créé spécifiquement pour faire des galeries d'images sur plusieurs pages.

Donc c’est le module qui est mal développé donc demandez à son créateur de corriger son erreur.

Je viens de vérifier mais apparemment Homeslider est un module développé par prestashop

 

Image1.JPG

Share this post


Link to post
Share on other sites
Posted (edited)

Normalement ce genre de module utilise les url relatives même si je ne connait pas le numéro de la dernière version du homeslider en 1.6, c'est donc étonnant que vous ayez du http, si ce n'est dans le contenu de vos slides. Du coup, ne serait il pas plus simple de regarder directement dans le source html de votre contenu  (le contenu de vos slides) ? 

Ensuite c'est peut être une vielle version ? 

Pour info votre logo est aussi en http

 

Edited by Jean Francois G

Share this post


Link to post
Share on other sites

Oui c'est une vieille version. Apparemment il existe en version 1.6 mais je n'ai pas trouvé le lien de téléchargement !

Share this post


Link to post
Share on other sites
Posted (edited)

HomeSlider est directement inclus dans la 1.6, il suffit de le mettre en place. 

Il est légèrement différent de celui de la 1.5 mais fait son job aussi. Il faudra juste jouer un peu sur les CSS

 

 

homeslider.rar

Edited by Jean Francois G

Share this post


Link to post
Share on other sites

Merci beaucoup

Je l'ai mis en place, je suis bien en 1.6 pour le module, mais je suis en http: quand je l'active.

J'ai ensuite remplacé tous les http: dans les fichiers du module et la bdd, mais c'est pareil, pas de cadenas...

bizarre

Share this post


Link to post
Share on other sites

Sur mon FTP, j'ai vidé smarty/cache et smarty/compile, puis réactivé le module

et depuis j'ai un message d'erreur avec ce nouveau module

-----------------------------

Le ou les modules suivants n'ont pas été correctement installés :

  • - homeslider : 
    The version of your module is not compliant with your PrestaShop version.

----------------------------

pas compatible avec mon presta 1.5?

Share this post


Link to post
Share on other sites

IL a raison, je vous ai envoyé un module 1.6 (je vous l'ai noté pesant que cétait la version de votre shop). Mais vous êtes encore en 1.5.6 (je viens de le voir) donc vous pouvez le désinstaller, ça marchera pas. 

Mea culpa, ca fait des lustres que je n'ai pas touché de 1.5. 

Share this post


Link to post
Share on other sites
Posted (edited)

ok

Quelle sont les autres pistes ?

Trouver le module pour un presta 1.5 ?

Trouver un autre module ? payant ?

Edited by freebike

Share this post


Link to post
Share on other sites
Posted (edited)

Avec une petite recherche google toute bête :

Pas testé, mais il y a ca  : https://www.store-opart.fr/p/1-opartslideshow.html

Ca aussi : https://www.webbax.ch/2014/06/02/un-slider-gratuit-et-responsive-pour-prestashop/

ou encore ça : https://www.prestashop.com/forums/topic/194690-free-module-minic-slider-for-ps-15/

Edited by Jean Francois G
  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour,

Le soucis vient de PrestaShop 1.5 qui ne force pas le ssl si celui-ci est activé.

Vous pouvez surcharger votre classe Link sur la fonction getMediaLink en forçant le ssl

	public function getMediaLink($filepath)
	{
		return Tools::getProtocol(true).Tools::getMediaServer($filepath).$filepath;
	}

 

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Jean Francois G said:

Avec une petite recherche google toute bête :

Pas testé, mais il y a ca  : https://www.store-opart.fr/p/1-opartslideshow.html > toujours HTTP;

Ca aussi : https://www.webbax.ch/2014/06/02/un-slider-gratuit-et-responsive-pour-prestashop/ > OK HTTPS !!!

ou encore ça : https://www.prestashop.com/forums/topic/194690-free-module-minic-slider-for-ps-15/

cool, merci beaucoup Jean Francois ça marche, ouf

Edited by freebike

Share this post


Link to post
Share on other sites
2 hours ago, Mediacom87 said:

Bonjour,

Le soucis vient de PrestaShop 1.5 qui ne force pas le ssl si celui-ci est activé.

Vous pouvez surcharger votre classe Link sur la fonction getMediaLink en forçant le ssl


	public function getMediaLink($filepath)
	{
		return Tools::getProtocol(true).Tools::getMediaServer($filepath).$filepath;
	}

 

Merci de ton aide Mediacom, pas eu le temps d'essayer mais apparemment ça marche avec le lien webbax

Share this post


Link to post
Share on other sites
Posted (edited)

Parfait ! Content que mon lien ai pu t'aider :) 

Allez ! Bon week end 

Edited by Jean Francois G
  • Like 1

Share this post


Link to post
Share on other sites
On 5/25/2019 at 11:35 AM, Mediacom87 said:

UPDATE ma_table SET mon_champ = replace(mon_champ, 'ancienne-chaine', 'nouvelle-chaine'); 

 

Elle m'a encore servie aujourd'hui celle ligne la.. Ca mérite un oscar une ligne pareille :)

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More