Jump to content
Sign in to follow this  
lutinfute

[RESOLU] Pb mineur - perte de fiche lors d’erreur de saisie

Recommended Posts

Lors de la création de ma fiche, dans le moteur de recherche SEO, rubrique Meta mots clés,
j'ai commis l'erreur de mettre le mot "français" avec cédille.

Lors de l'enregistrement de la fiche, le message suivant est apparu :
Le champ suivant est invalide, selon la méthode Validate::isGenericName:
(Product->meta_keywords = artilleur francais,artilleur fran��ais, pour la langue 2)

Ce n'est pas très grave, si ce n'est qu'il n'y a pas eu moyen de revenir en arrière, que la fiche n'a pas été enregistrée, et que j'ai du la resaisir.

Version 1.4

Share this post


Link to post
Share on other sites

Bonjour,
l'orthographe dans votre post " fran��ais," laisse à penser que vous n'êtes pas en UTF 8 ?!? si vous saisissez ainsi vous risquez fort d'avoir des problêmes avec vos fichiers......

Share this post


Link to post
Share on other sites

J'ai bien saisi "français", et il s'est inscrit "français" lors de la saisie, mais il a été compris "fran��ais" une fois la fiche enregistrée.

Je suis en local sur easyphp 5.3.3
J'ai rajouté dans my.ini, en fin de section [mysqld], conformément à un post pour mettre uft8 sur le forum easyphp :
character-set-server=utf8
skip-character-set-client-handshake

Cà n'a rien changé.
Mais je connais mal easyphp
Comment voir si on est ou non en uft8 ?

Merci pour cette piste.

Share this post


Link to post
Share on other sites

RE :
"Comment voir si on est ou non en uft8 ?" et bien quand on obtient des caractères ainsi ...... fran��ais.
Si tu as des problêmes de ce genre tu écris dans ton bloc note et tu "enregistres sous" : UTF8, ( la 3ème ligne où il est demandé codage ) ainsi le français est transcrit en utf8.
Je suis quasiment certain qu'ainsi tu n'auras plus d'erreurs de saisie, ceci est fréquent avec les fichiers .csv également....

Share this post


Link to post
Share on other sites

Merci beaucoup, Yvon.
Je suis reparti à zéro, et j'ai donc réinstallé mon site prestashop (et j'ai mis la dernière version d'easyphp)
La première fois, je définissais la base dans mysql, en laissant l'encodage sur interclassement.
A présent, j'ai mis l'encodage sur uft8-unicode.ci, pour php et mysql
Et le problème a effectivement disparu.
Heureusement que tu étais là, car j'aurai continué sur de mauvaises bases !

Share this post


Link to post
Share on other sites

ouaip et comme c'est loin d'être un rapport de bug, je déplace...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More