Jump to content
FCZ

"Ajouter une image" dans le BO...

Recommended Posts

Bonjour, quand je veux changer l'image du logo de ma boutique 1.7.5.2 hebergé chez ovh, en cliquant sur "Ajouter un fichier"  dans "thème & logo" la fenêtre qui s'ouvre c'est un chemin local de mon HDD... Comment faire pour que l'ajout d'image aille chercher sur le serveur et non sur ma machine ??

Share this post


Link to post
Share on other sites

Bonjour,

Ce comportement est logique puisqu'il permet de charger un fichier sur votre site, si il est déjà en ligne, téléchargez le sur votre ordinateur et envoyez le grâce à ce formulaire sur votre site pour qu'il soit enregistré comme il faut au bon format au bon endroit.

Share this post


Link to post
Share on other sites

[ V 1.7.5.2
Hébergement mutualisé OVH
Uploadé sur serveur après dev en localhost. ]

Par exemple le problème est qu'en uploadant un fichier dans design/theme&logo/logo de l'entête, le fichier lorsqu'il est visible sur la page de maintenance, est hébergé sous une url en http et non en httpS (là je ne suis plus en mode maintenance, j'ai mis ma boutique en prod).

Je rencontre un lourd problème actuellement sur mon site tous les liens des résultat de recherche pointant vers mon domaine affiche une page d'avertissement de sécurité ce qui fait peur aux clients.

J'ai activé le protocole SSL hier et il y avait un "i" dans un petit cercle au lieu du cadenas, j'ai vu que j'avais du contenu mixte (http & https) à cause des URL des images (ajoutées manuellement sur pages CMS) qui étaient en http et non en httpS. J'ai corrigé la majeur partie des url en rajoutant le S au http et le petit cadenas apparaît bien sur la majorité des pages, mais même pour ouvrir une page de mon site qui ont ce petit cadenas les navigateur lance un avertissement de sécurité...

Que dois je faire ?

Edited by FCZ (see edit history)

Share this post


Link to post
Share on other sites

Bon en faite j'ai tripatouillé les options dans l'onglet multisite (ovh) puis j'ai réactualiser le ceritifcat SSL et tout est rentré dans l'ordre, y avait la ligne avec les www qui n'avait pas le certificat d'actif. Par contre si je supprime le "s" de https dans l'url et que je met des caractères aléatoire après le slash / qui suit le nom de domaine, je pointe sur une erreur 404 mais qui est en http, il n ya pas de redirection automatique vers une 404 en https. Comment faire ?

Share this post


Link to post
Share on other sites

Finalement j'ai trouvé:

Dans .htacces cherchez la ligne "RewriteEngine On" en dessous il faut mettre le code suivant:

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Cela redirige le http vers du https!

 

Edited by FCZ (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More