Jump to content
Jean Francois G

[RESOLU] PS1.7 erreur google sur indexation : Uncaught TypeError: undefined is not a function. Besoin d'aide SVP

Recommended Posts

Posted (edited)

Bonjour a tous..

(pour mieux cerner les choses, voici ma config PS :

PS 1.7.5.2, serveur dédié sous debian avec PHP 7.0, OPcache activé, cache presta et CCC activé, robot.txt de base, pas de modif dans le htaccess, Affichage visuel sous mobile et PC sans aucun soucis (constatation manuelle), j'ai désactivé tous les effets de dégradé javascript du thème (au cas ou), j'ai un module de review snippets acheté sur addon, le thème SA4-Pure-bio acheté sur Addon, et le blog "blockblog 2.2.9" acheté sur addon. le reste est d'origine. Pas de fichiers core modifiés non plus. )

Encore la version 1.7 qui n'arrête pas de faire crier mon  indexation google (en train de partir en miette)

Maintenant j'ai un message d'alerte de google qui me dit que mes pages produits ne peuvent pas être indexer correctement avec cette info (en image) :

1355970459_Screenshot_2019-05-17Testdoptimisationmobile-GoogleSearchConsole.thumb.png.2b6c3623c8a999b5641eaa8254681c1f.png

Je désespère depuis ma mise à jour, car plus rien ne va avec cette 1.7. jamais vu un truc pareil !

J'ai aussi cette erreur sur mes produits :

1661158174_Screenshot_2019-05-17Produits.thumb.png.746cf1c5167f44e3317f27cdd7756ce0.png

J'appelle donc directement au secours.. je vais craquer !  Quelqu'un pourrait il m'aider ?

S'il le faut, je peux payer une participation raisonnable (mais je ne suis pas Rothschild) si le resultat est la...

 

Edited by Jean Francois G

Share this post


Link to post
Share on other sites

On vous avait pourtant prévenu :-/

Share this post


Link to post
Share on other sites

Il y a une issue sur github à ce sujet: https://github.com/PrestaShop/PrestaShop/issues/12687

A priori en février Google a commencé à sanctionner plus violemment les infos invalides de schema.

Et donc rien à voir avec la 1.7, la 1.6 ou la 1.5, simplement Google qui fait évoluer ses règles SEO

Share this post


Link to post
Share on other sites
Posted (edited)

correctif appliqué et toujours le même avertissement (considéré comme erreur grave et donc bloquant) quand je lance le test de la page..

Edited by Jean Francois G

Share this post


Link to post
Share on other sites

Problème rattingcount et notes cumulées résolu en appliquant les directives données sur le site de webbax et en en modifiant quelques lignes pour que google prenne bien les avis clients tels qu'ils sont notés.

Je n'ai pas totalement résolu le problème des images non reconnues par google (a noter que le message Uncaught TypeError disqparait si j'active la mise en cache JS dans les paramètres CCC) . Mais je passe le sujet en résolu quand même car de toute façon, aucune autre suggestion n'est apparue.

Merci a tous : )

Edited by Jean Francois G
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More