Jump to content
dixset

[résolu] Migration de mon site d'un hébergeur à un autre

Recommended Posts

Posted (edited)

Bonjour, 

Je tente de migrer mon site (PS 1.7.3) d'un hébergeur à un autre.

Quand je tape la nouvelle URL de mon site, je suis redirigé vers l'ancien hébergement. 

Quand je tape l'URL d'administration je tombe sur une page blanche.

- J'ai transféré la base de données

- J'ai uploadé tous les fichiers sur le nouvel hébergement

- J'ai modifié le .htaccess à la racine, qui contenait le chemin d'accès vers l'ancien dossier

- J'ai modifié via phpmyadmin, les valeurs PS_SHOP_DOMAIN et PS_SHOP_DOMAIN_SSL

Ce que je n'arrive pas à faire, c'est vider le cache via FTP (vu que je n'ai pas accès au back office je n'ai pas d'autre moyen) J'ai trouvé cette astuce en ligne, mais les dossiers indiqués ne semble pas exister dans PS v 1.7.3 "If you have a blank page in your admin, using a FTP program, try renaming the public_html/var/cache/prod and public_html/var/cache/dev folders to public_html/var/cache/prod_OFFLINE and public_html/var/cache/dev_OFFLINE"

Là je sèche complètement, après des heures de recherche sur google et sur le forum. Pouvez-vous m'aider SVP ?

MERCI !!!

Alexandre

 

Edited by dixset
question résolue

Share this post


Link to post
Share on other sites

Quand tu est novice très compliqué de migré un prestashop.

 

Déjà tu doit avoir un link.
Tondomaine & old.tondodmaine

Pour vidé le cache :

à la racine cherche le dossier VAR/CACHE/ tu supprime les dossier PROD & DEV

Tu change d’hébergeur pour quel raison ? 

Share this post


Link to post
Share on other sites

Je confirme  c'est compliqué ! J'ai passé vraiment des heures à trouver des infos.

C'est le problème: je n'ai pas de dossier VAR/

Je change d'hébergeur parce que j'avais installé mon site sur un hébergement temporaire, je ne pensais pas que ce serait aussi dur de transférer le site...

Quote

Déjà tu doit avoir un link.
Tondomaine & old.tondodmaine

--> je ne vois pas de quoi tu parles

Merci en tous cas d'avoir répondu aussi vite !

Alexandre

Share this post


Link to post
Share on other sites

Ce que tu essayes de nous dire c'est que tu as changé et d'hébergeur et de nom de domaine

..et quand tu tapes ton nouveau nom de domaine chez ton nouvel hébergeur, ca te redirige sur ton ancien nom de domaine de l'ancien hébergeur?

Share this post


Link to post
Share on other sites

11d33e6f9f31185a0b43170e78275bd1.png
https://gyazo.com/11d33e6f9f31185a0b43170e78275bd1

5306948fc38f8de462e8276de329d898.png
https://gyazo.com/5306948fc38f8de462e8276de329d898

 

Voila le dossier que tu as à la racine du prestashop 1.7.

 

Tu va chez quel hébergeur du coup ?

Pour l'histoire du domaine & old.domaine me suis trompé.

SI tu tombe encore sur l'ancien en tapant l'url cela est normal il te faut un temps pour que tes dns suivent.

Share this post


Link to post
Share on other sites
Quote

..et quand tu tapes ton nouveau nom de domaine chez ton nouvel hébergeur, ca te redirige sur ton ancien nom de domaine de l'ancien hébergeur?

exactement !

en fait le nom de domaine ce sera un autre: je changerai simplement de DNS, quand le site sera up sur le nouvel hébergement...

 

 

Share this post


Link to post
Share on other sites

je n'ai pas de dossier VAR entre UPLOAD et VENDOR: regarde 😕

Capture d’écran 2019-05-15 à 23.06.51.png

Share this post


Link to post
Share on other sites
Posted (edited)

je migre chez O2switch.

je ne crois pas que ce soit une question de DNS: je tape l'URL du dossier: www.mondomaineprincipal/mondossier (et ça redirige vers www/monAncienDomaine/dossier). Et quand je tape www.mondomaineprincipal/mondossier/adminxxx  j'ai une page blanche

je n'ai pas encore fait pointer les DNS vers /mondossier

 

Edited by dixset

Share this post


Link to post
Share on other sites

Hum, bizarre déjà que le dossier var n'est pas existant.

Tout les clients que j'ai passer sur mon serveur je n'ai jamais eu ce problème.

il faut comprendre tout les facteurs de ta migration vers le nouveau serveur, déjà regarde sur cette version en la téléchargeant si il y a ce dossier VAR.

Share this post


Link to post
Share on other sites
1 minute ago, Esh-Network said:

déjà regarde sur cette version en la téléchargeant si il y a ce dossier VAR.

je viens de télécharger la version 1.7.3.0 : pas de dossier VAR en effet... 😕

Share this post


Link to post
Share on other sites

je vais essayer de mettre à jour le site en 1.7.5.2 sur l'ancien hébergement, et je recommencerai le transfert (enfin si la MàJ se passe bien ce dont je doute, par expérience).

Merci pour votre aide à tous les deux en tous cas. Je ne clos pas le topic

Share this post


Link to post
Share on other sites

Bon, déjà change le dns vers le nouveau serveur. 
Ne change pas l'url du site laisse comme c'était une fois que le dns pointe sur le nouveau serveur pour le savoir

Ouvre ta console executé : CMD tape ping tondomaine.fr si sa pointe sur l'ip de ton serveur va sur le back office de ton site.
Ensuite prochaine étape si tu change de domaine.
Prend le nouveau domaine puis change tout via le back office si cela suffit pas change via la bdd.
Pense à mettre à jours vers la 1.7.5 il y as pas mal de correctif.

Share this post


Link to post
Share on other sites
2 minutes ago, dixset said:

je vais essayer de mettre à jour le site en 1.7.5.2 sur l'ancien hébergement, et je recommencerai le transfert (enfin si la MàJ se passe bien ce dont je doute, par expérience).

Merci pour votre aide à tous les deux en tous cas. Je ne clos pas le topic

Si jamais je fait de l’hébergement n’hésite pas à me contacté en mp :d.

Share this post


Link to post
Share on other sites

ok merci, je tenterai ça vendredi (pas possible demain)

Share this post


Link to post
Share on other sites
46 minutes ago, dixset said:

exactement !

en fait le nom de domaine ce sera un autre: je changerai simplement de DNS, quand le site sera up sur le nouvel hébergement...

Vu que tu passes d'un hébergeur a l'autre avec un nouveau nom de domaine, de quel DNS parles tu ?

Share this post


Link to post
Share on other sites

Il garde juste le nom de domaine principal le temps de tout mettre en ordre avant de changer de Ndd. Tout simplement. 

Share this post


Link to post
Share on other sites

exactement : c'est ça esh-network.

Merci !

Share this post


Link to post
Share on other sites

Bonjour, problème résolu !

Il fallait aussi changer la valeur de la table ps_shop_url 

Merci au support de O2switch qui a assuré et qui est hyper réactif !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More